aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2016-02-20 19:42:41 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2016-02-20 19:42:41 +0000
commit5e73abeb5dacccf280b5adf5e8069f447a138acd (patch)
tree6235c4bd8a9281cd47ce8dc7e0482ed686bd2dab /www/nginx-devel
parent53625bac52bb8604215639523b1893cebc9a58d3 (diff)
downloadports-5e73abeb5dacccf280b5adf5e8069f447a138acd.tar.gz
ports-5e73abeb5dacccf280b5adf5e8069f447a138acd.zip
Notes
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 41fd8e37cc74..fc869f71d911 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.9.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
MASTER_SITES+= LOCAL/osa
@@ -1106,7 +1106,7 @@ do-install:
.for i in koi-utf koi-win win-utf
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${STAGEDIR}${ETCDIR}
.endfor
-.for i in fastcgi_params mime.types nginx.conf scgi_params uwsgi_params
+.for i in fastcgi_params mime.types scgi_params uwsgi_params
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${STAGEDIR}${ETCDIR}/${i}-dist
.endfor
.if !empty(PORT_OPTIONS:MHTTP) && !empty(PORT_OPTIONS:MWWW)
@@ -1148,6 +1148,13 @@ post-install:
# Add dynamic modules to the plist
(cd ${STAGEDIR}${PREFIX} && ${FIND} ${MODULESDIR:S|${PREFIX}/||} \
- ! -type d >> ${TMPPLIST})
+ ! -type d >>${TMPPLIST})
+# Update nginx.conf-dist with a list of staged dynamic modules
+ (cd ${STAGEDIR}${ETCDIR} && \
+ ${FIND} ${MODULESDIR:S|${ETCDIR}/||} -type f -name '*.so' \
+ -exec ${ECHO_CMD} "load_module {};" \; \
+ >>${STAGEDIR}${ETCDIR}/nginx.conf-dist && \
+ ${CAT} ${WRKSRC}/conf/nginx.conf \
+ >>${STAGEDIR}${ETCDIR}/nginx.conf-dist)
.include <bsd.port.mk>