aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorVeniamin Gvozdikov <vg@FreeBSD.org>2015-08-27 17:36:31 +0000
committerVeniamin Gvozdikov <vg@FreeBSD.org>2015-08-27 17:36:31 +0000
commite80238f30c0eb115be49c51cf2404647efa81ea7 (patch)
tree3dedca30a903da761f51e48d8514f891e0ecba65 /www/nginx-devel
parentb543e44628ccc853820e823911d2a4886e7895c4 (diff)
downloadports-e80238f30c0eb115be49c51cf2404647efa81ea7.tar.gz
ports-e80238f30c0eb115be49c51cf2404647efa81ea7.zip
Notes
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile18
-rw-r--r--www/nginx-devel/distinfo2
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_tarantool-config11
3 files changed, 31 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 2d11824e47d9..cfade72d52e9 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -79,6 +79,7 @@ OPTIONS_DEFINE= \
HTTP_REDIS \
HTTP_RESPONSE \
HTTP_SUBS_FILTER \
+ HTTP_TARANTOOL \
HTTP_UPLOAD \
HTTP_UPLOAD_PROGRESS \
HTTP_UPSTREAM_FAIR \
@@ -174,6 +175,7 @@ HTTP_PUSH_STREAM_DESC= 3rd party push stream module
HTTP_REDIS_DESC= 3rd party http_redis module
HTTP_RESPONSE_DESC= 3rd party http_response module
HTTP_SUBS_FILTER_DESC= 3rd party subs filter module
+HTTP_TARANTOOL_DESC= 3rd party tarantool upstream module
HTTP_UPLOAD_DESC= 3rd party upload module
HTTP_UPLOAD_PROGRESS_DESC= 3rd party uploadprogress module
HTTP_UPSTREAM_FAIR_DESC= 3rd party upstream fair module
@@ -530,6 +532,17 @@ GH_TAGNAME+= ${NGINX_HTTP_SUBS_FILTER_VERSION}:subs_filter
CONFIGURE_ARGS+=--add-module=${WRKSRC_subs_filter}
.endif
+.if ${PORT_OPTIONS:MHTTP_TARANTOOL}
+LIB_DEPENDS+= libmsgpuck.so:${PORTSDIR}/devel/msgpuck \
+ libyajl.so:${PORTSDIR}/devel/yajl
+GH_ACCOUNT+= tarantool:nginx_tarantool
+GH_PROJECT+= nginx_upstream_module:nginx_tarantool
+GH_TAGNAME+= 966f2f5:nginx_tarantool
+CFLAGS+= -I${LOCALBASE}/include/msgpuck
+CONFIGURE_ARGS+=--add-module=${WRKSRC_nginx_tarantool}
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_tarantool-config
+.endif
+
.if ${PORT_OPTIONS:MHTTP_SECURE_LINK}
CONFIGURE_ARGS+=--with-http_secure_link_module
.endif
@@ -1022,6 +1035,11 @@ post-patch:
's!%%PREFIX%%!${LOCALBASE}!g' \
${WRKDIR}/modsecurity-${NGINX_MODSECURITY_VERSION}/configure
.endif
+.if ${PORT_OPTIONS:MHTTP_TARANTOOL}
+ @${REINPLACE_CMD} \
+ 's!%%PREFIX%%!${LOCALBASE}!g' \
+ ${WRKSRC_nginx_tarantool}/config
+.endif
pre-configure:
.if ${PORT_OPTIONS:MMODSECURITY}
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 688c399bfcbf..5bbca66ae70f 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -64,6 +64,8 @@ SHA256 (wandenberg-nginx-push-stream-module-0.3.5_GH0.tar.gz) = 8a9e27a79020bf08
SIZE (wandenberg-nginx-push-stream-module-0.3.5_GH0.tar.gz) = 153122
SHA256 (yaoweibin-ngx_http_substitutions_filter_module-0.6.2_GH0.tar.gz) = 2814340bf57581a04873e26d773ec216bfceebb1abb87d4904ce314790897b17
SIZE (yaoweibin-ngx_http_substitutions_filter_module-0.6.2_GH0.tar.gz) = 91878
+SHA256 (tarantool-nginx_upstream_module-966f2f5_GH0.tar.gz) = 8142475d8ecf0c02d2fc8051364729d842fe06b0b445b416c87c2f796bb42fa7
+SIZE (tarantool-nginx_upstream_module-966f2f5_GH0.tar.gz) = 873343
SHA256 (vkholodkov-nginx-upload-module-aba1e3f34c_GH0.tar.gz) = 62a2c4388585aec463a1cee30bc84953593a93f341dc1df61b42b452594d2a05
SIZE (vkholodkov-nginx-upload-module-aba1e3f34c_GH0.tar.gz) = 28296
SHA256 (masterzen-nginx-upload-progress-module-v0.9.0_GH0.tar.gz) = 93e29b9b437a2e34713de54c2861ea51151624aca09f73f9f44d1caaff01a6b1
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_tarantool-config b/www/nginx-devel/files/extra-patch-ngx_http_tarantool-config
new file mode 100644
index 000000000000..dedf15566c23
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-ngx_http_tarantool-config
@@ -0,0 +1,11 @@
+--- ../nginx_upstream_module-966f2f5/config.orig 2015-08-20 23:33:02.000000000 +0300
++++ ../nginx_upstream_module-966f2f5/config 2015-08-23 16:04:59.572045669 +0300
+@@ -4,7 +4,7 @@
+ "
+
+ CORE_LIBS="$CORE_LIBS $ngx_feature_libs \
+- $ngx_addon_dir/third_party/yajl/build/yajl-2.1.0/lib/libyajl_s.a \
++ %%PREFIX%%/lib/libyajl_s.a \
+ "
+
+ HTTP_MODULES="$HTTP_MODULES \