aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2015-08-10 22:19:51 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2015-08-10 22:19:51 +0000
commit6d43a7284fc5b839c13b231413194250208b2436 (patch)
tree76c87fe44970f30a00e01e23b0c753f5dc6ad072 /www/nginx-devel
parentd52f3b66564827e780f46ee4e9bd620cedf41250 (diff)
downloadports-6d43a7284fc5b839c13b231413194250208b2436.tar.gz
ports-6d43a7284fc5b839c13b231413194250208b2436.zip
Notes
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile17
-rw-r--r--www/nginx-devel/distinfo2
2 files changed, 19 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 5b3eef20f5e1..cbaa02c7f1e8 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -52,6 +52,7 @@ OPTIONS_DEFINE= \
MAIL_SMTP \
MAIL_SSL \
SPDY \
+ HTTPV2 \
STREAM \
STREAM_SSL \
THREADS \
@@ -145,6 +146,7 @@ MAIL_POP3_DESC= Enable POP3 proxy module
MAIL_SMTP_DESC= Enable SMTP proxy module
MAIL_SSL_DESC= Enable mail_ssl module
SPDY_DESC= Enable SPDY protocol support (SSL req.)
+HTTPV2_DESC= Enable HTTP/2 protocol support (SSL req.)
STREAM_DESC= Enable stream module
STREAM_SSL_DESC= Enable stream_ssl module (SSL req.)
THREADS_DESC= Enable threads support
@@ -818,12 +820,27 @@ GH_TAGNAME+= v${NGINX_XSS_VERSION}:xss
CONFIGURE_ARGS+=--add-module=${WRKSRC_xss}
.endif
+.if ${PORT_OPTIONS:MSPDY} && ${PORT_OPTIONS:MHTTPV2}
+IGNORE= current HTTP/2 implementation replaces SPDY module support, please disable SPDY
+.endif
+
.if ${PORT_OPTIONS:MSPDY}
NGINX_OPENSSL= yes
USE_HTTP_SSL= yes
CONFIGURE_ARGS+=--with-http_spdy_module
.endif
+.if ${PORT_OPTIONS:MHTTPV2}
+NGINX_OPENSSL= yes
+USE_HTTP_SSL= yes
+CONFIGURE_ARGS+=--with-http_v2_module
+USE_OPENSSL_PORT= yes
+NGINX_HTTPV2_VERSION= 1
+PATCH_SITES+= http://nginx.org/patches/http2/:httpv2
+PATCHFILES+= patch.http2-v${NGINX_HTTPV2_VERSION}_${PORTVERSION}.txt:httpv2
+PATCH_DIST_STRIP= -p1
+.endif
+
.if ${PORT_OPTIONS:MSTREAM}
CONFIGURE_ARGS+=--with-stream
.if ${PORT_OPTIONS:MSTREAM_SSL}
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index efb55f28f295..a76ee579174b 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -114,3 +114,5 @@ SHA256 (calio-form-input-nginx-module-v0.07_GH0.tar.gz) = c0c56cc697a290e98b88d4
SIZE (calio-form-input-nginx-module-v0.07_GH0.tar.gz) = 10563
SHA256 (calio-iconv-nginx-module-v0.10_GH0.tar.gz) = 88e326eba7fdf9fd2376b1ba033b48cb0eee45136528cf5430ac9340088ce324
SIZE (calio-iconv-nginx-module-v0.10_GH0.tar.gz) = 12513
+SHA256 (patch.http2-v1_1.9.3.txt) = 14e37643c43e24ed7de9cc57bd4a082ff3b5d85423a998dc1a3226c9d00b1d6e
+SIZE (patch.http2-v1_1.9.3.txt) = 308749