aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2015-04-29 00:42:06 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2015-04-29 00:42:06 +0000
commit7d7831884204274d4367e75a5a3b83838c7ce67a (patch)
tree3b4b7204c01e3636e5d34bdc6c72a2460d21171b /www/nginx-devel
parentf7c61bd95f67af83a048cf1e41fbaade08832cd5 (diff)
downloadports-7d7831884204274d4367e75a5a3b83838c7ce67a.tar.gz
ports-7d7831884204274d4367e75a5a3b83838c7ce67a.zip
Notes
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index a2fcd2f597c7..91ff32caeaab 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -52,6 +52,8 @@ OPTIONS_DEFINE= \
MAIL_SMTP \
MAIL_SSL \
SPDY \
+ STREAM \
+ STREAM_SSL \
THREADS \
WWW \
CACHE_PURGE \
@@ -136,6 +138,8 @@ MAIL_POP3_DESC= Enable POP3 proxy module
MAIL_SMTP_DESC= Enable SMTP proxy module
MAIL_SSL_DESC= Enable mail_ssl module
SPDY_DESC= Enable SPDY protocol support (SSL req.)
+STREAM_DESC= Enable stream module
+STREAM_SSL_DESC= Enable stream_ssl module (SSL req.)
THREADS_DESC= Enable threads support
WWW_DESC= Enable html sample files
CACHE_PURGE_DESC= 3rd party cache_purge module
@@ -723,6 +727,15 @@ USE_HTTP_SSL= yes
CONFIGURE_ARGS+=--with-http_spdy_module
.endif
+.if ${PORT_OPTIONS:MSTREAM}
+CONFIGURE_ARGS+=--with-stream
+.if ${PORT_OPTIONS:MSTREAM}
+NGINX_OPENSSL= yes
+USE_HTTP_SSL= yes
+CONFIGURE_ARGS+=--with-stream_ssl_module
+.endif
+.endif
+
.if ${PORT_OPTIONS:MTHREADS}
CONFIGURE_ARGS+=--with-threads
.endif