aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2009-09-13 08:42:27 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2009-09-13 08:42:27 +0000
commitaa6fbabcca147b7b299ccc9b0116d14cce9803e1 (patch)
treef3f27e99bedc1ef29117972558af0fd1e8aedbf8 /www/nginx-devel
parent55c2126a72e1549eb56198a0d287d44ab419a1dd (diff)
downloadports-aa6fbabcca147b7b299ccc9b0116d14cce9803e1.tar.gz
ports-aa6fbabcca147b7b299ccc9b0116d14cce9803e1.zip
Notes
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile13
-rw-r--r--www/nginx-devel/distinfo6
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_uploadprogress_module.c40
3 files changed, 7 insertions, 52 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 4fce5c0b9679..860e338fa978 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -246,11 +246,10 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_upload_module-${NGINX_UPLOAD_MODULE
.endif
.if defined(WITH_HTTP_UPLOAD_PROGRESS)
-NGINX_UPLOAD_PROGRESS_MODULE_VERSION= 0.5
-MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:uploadprogress/}
-MASTER_SITE_SUBDIR+= osa/:uploadprogress
-DISTFILES+= nginx_uploadprogress_module-${NGINX_UPLOAD_PROGRESS_MODULE_VERSION}.tar.gz:uploadprogress
-CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_uploadprogress_module
+NGINX_UPLOAD_PROGRESS_MODULE_VERSION= 0.6
+MASTER_SITES+= http://wiki.nginx.org/images/7/70/:uploadprogress
+DISTFILES+= Nginx-upload-progress-module-${NGINX_UPLOAD_PROGRESS_MODULE_VERSION}.tar.gz:uploadprogress
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-upload-progress-module
.endif
.if defined(WITH_HTTP_UPSTREAM_FAIR)
@@ -350,10 +349,6 @@ post-patch:
's!$$HTTP_ACCESSKEY_MODULE!ngx_http_accesskey_module!' \
${WRKDIR}/nginx-accesskey-${NGINX_ACCESSKEY_MODULE_VERSION}/config
.endif
-.if defined(WITH_HTTP_UPLOAD_PROGRESS)
- @${PATCH} ${PATCH_ARGS} < \
- ${PATCHDIR}/extra-patch-ngx_http_uploadprogress_module.c
-.endif
.if defined(WITH_HTTP_FANCYINDEX_MODULE)
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_fancyindex_module.c
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index cdc976981f38..67e7a60bb57c 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -28,9 +28,9 @@ SIZE (ngx_http_response-0.3.tar.gz) = 2244
MD5 (nginx_upload_module-2.0.10.tar.gz) = 5ac249003c6eb6ce919510a5ff9ffc79
SHA256 (nginx_upload_module-2.0.10.tar.gz) = 96b6610996c83c4e2d1b2f31b263b5ff6cc86c3b4a4e7ad0e1bf6c1ec806e5a0
SIZE (nginx_upload_module-2.0.10.tar.gz) = 18331
-MD5 (nginx_uploadprogress_module-0.5.tar.gz) = 04cca031be26a0a37a24b8b2d475c77a
-SHA256 (nginx_uploadprogress_module-0.5.tar.gz) = b025bf8ea2e1cf405dd72587d52eb48135cb7b0843a2dbfcf91c8f562701d75c
-SIZE (nginx_uploadprogress_module-0.5.tar.gz) = 11578
+MD5 (Nginx-upload-progress-module-0.6.tar.gz) = 98cfd8a950edaecf1bdf95bd32f8c1f4
+SHA256 (Nginx-upload-progress-module-0.6.tar.gz) = 19db47b4d5e3e3c7304fb77c257daf1f8c727ccc8f16876352141152e32a2f5f
+SIZE (Nginx-upload-progress-module-0.6.tar.gz) = 11856
MD5 (nginx_upstream_fair-20081012.tar.gz) = 1f7b4f3e47c32f89afac59fa60381dc4
SHA256 (nginx_upstream_fair-20081012.tar.gz) = 4c2bd957168008e5b2397fad49824ca70f3685cf884e8d1be45d56c8e3bbe88c
SIZE (nginx_upstream_fair-20081012.tar.gz) = 10021
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_uploadprogress_module.c b/www/nginx-devel/files/extra-patch-ngx_http_uploadprogress_module.c
deleted file mode 100644
index 9752602780a6..000000000000
--- a/www/nginx-devel/files/extra-patch-ngx_http_uploadprogress_module.c
+++ /dev/null
@@ -1,40 +0,0 @@
---- ../nginx_uploadprogress_module/ngx_http_uploadprogress_module.c.orig 2009-06-26 15:32:01.000000000 +0400
-+++ ../nginx_uploadprogress_module/ngx_http_uploadprogress_module.c 2009-06-26 15:38:30.000000000 +0400
-@@ -187,8 +187,9 @@
- if (i) {
- start_p = p += 14;
- while (p < r->args.data + r->args.len) {
-- if (*p++ != '&') {
-- continue;
-+ if (*p++ == '&') {
-+ p--;
-+ break;
- }
- }
-
-@@ -799,7 +799,7 @@ ngx_clean_old_connections(ngx_event_t * ev)
- ngx_http_uploadprogress_ctx_t *ctx;
- ngx_slab_pool_t *shpool;
- ngx_rbtree_node_t *node;
-- ngx_http_uploadprogress_node_t *up;
-+ ngx_http_uploadprogress_node_t *up, *upprev;
- time_t now = ngx_time();
- int count = 0;
-
-@@ -822,6 +822,7 @@ ngx_clean_old_connections(ngx_event_t * ev)
- }
-
- up = (ngx_http_uploadprogress_node_t *) node;
-+ upprev = up->prev;
-
- ngx_log_debug3(NGX_LOG_DEBUG_HTTP, shm_zone->shm.log, 0,
- "uploadprogress clean: scanning %08XD (req done %ui) timeout at %T",
-@@ -840,7 +841,7 @@ ngx_clean_old_connections(ngx_event_t * ev)
- }
- else
- count++;
-- node = (ngx_rbtree_node_t *) up->prev;
-+ node = (ngx_rbtree_node_t *) upprev;
- }
-
- ngx_log_debug3(NGX_LOG_DEBUG_HTTP, shm_zone->shm.log, 0,