aboutsummaryrefslogtreecommitdiff
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2023-04-11 18:12:55 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2023-04-11 18:14:42 +0000
commitb7d44cc43e39664903e110442518c89d68264716 (patch)
tree567efba155667fbae0da4314e47cba06d30f59e5 /www/nginx-devel
parent6c5c4a1f5828b073e0e3eae1efd9484f234643e2 (diff)
downloadports-b7d44cc43e39664903e110442518c89d68264716.tar.gz
ports-b7d44cc43e39664903e110442518c89d68264716.zip
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile10
-rw-r--r--www/nginx-devel/Makefile.extmod14
-rw-r--r--www/nginx-devel/Makefile.options.desc2
-rw-r--r--www/nginx-devel/distinfo10
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_dynamic_healthcheck-config11
-rw-r--r--www/nginx-devel/pkg-plist2
6 files changed, 10 insertions, 39 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index b570248e9752..d4219047617f 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -1,6 +1,5 @@
PORTNAME?= nginx
-PORTVERSION= 1.23.4
-PORTREVISION= 4
+PORTVERSION= 1.24.0
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
LOCAL/osa
@@ -16,7 +15,7 @@ LICENSE_FILE?= ${WRKSRC}/LICENSE
CONFLICTS_INSTALL= nginx
-PORTSCOUT= limit:^1\.23\.[0-9]*
+PORTSCOUT= limit:^1\.24\.[0-9]*
USES= cpe
@@ -230,9 +229,8 @@ CFLAGS+= -DNDEBUG
CFLAGS+= -Wno-compound-token-split-by-macro
.endif
-.if empty(PORT_OPTIONS:MDYNAMIC_HC) && empty(PORT_OPTIONS:MLUA) && \
- empty(PORT_OPTIONS:MMODSECURITY3) && empty(PORT_OPTIONS:MPASSENGER) && \
- empty(PORT_OPTIONS:MSMALL_LIGHT)
+.if empty(PORT_OPTIONS:MLUA) && empty(PORT_OPTIONS:MMODSECURITY3) && \
+ empty(PORT_OPTIONS:MPASSENGER)
CONFIGURE_ARGS+= --with-ld-opt="-L ${LOCALBASE}/lib"
.else
CONFIGURE_ARGS+= --with-ld-opt="-L ${LOCALBASE}/lib -lpcre"
diff --git a/www/nginx-devel/Makefile.extmod b/www/nginx-devel/Makefile.extmod
index b42fccdf6c5d..ecb0ae0ecbc2 100644
--- a/www/nginx-devel/Makefile.extmod
+++ b/www/nginx-devel/Makefile.extmod
@@ -3,7 +3,7 @@
OPTIONS_GROUP+= THIRDPARTYGRP
# External modules (arrayvar MUST appear after devel_kit for build-dep)
OPTIONS_GROUP_THIRDPARTYGRP= AJP AWS_AUTH BROTLI CACHE_PURGE CLOJURE COOKIE_FLAG CT \
- DEVEL_KIT ARRAYVAR DRIZZLE DYNAMIC_HC DYNAMIC_UPSTREAM ECHO ENCRYPTSESSION \
+ DEVEL_KIT ARRAYVAR DRIZZLE DYNAMIC_UPSTREAM ECHO ENCRYPTSESSION \
FIPS_CHECK FORMINPUT GRIDFS HEADERS_MORE HTTP_ACCEPT_LANGUAGE HTTP_AUTH_DIGEST \
HTTP_AUTH_KRB5 HTTP_AUTH_LDAP HTTP_AUTH_PAM HTTP_DAV_EXT HTTP_EVAL \
HTTP_FANCYINDEX HTTP_FOOTER HTTP_GEOIP2 HTTP_IP2LOCATION HTTP_IP2PROXY \
@@ -12,7 +12,7 @@ OPTIONS_GROUP_THIRDPARTYGRP= AJP AWS_AUTH BROTLI CACHE_PURGE CLOJURE COOKIE_FLAG
HTTP_UPLOAD HTTP_UPLOAD_PROGRESS HTTP_UPSTREAM_CHECK HTTP_UPSTREAM_FAIR \
HTTP_UPSTREAM_STICKY HTTP_VIDEO_THUMBEXTRACTOR HTTP_ZIP ICONV LET LINK LUA MEMC \
MODSECURITY3 NAXSI OPENTRACING PASSENGER POSTGRES RDS_CSV RDS_JSON \
- REDIS2 RTMP SET_MISC SFLOW SHIBBOLETH SLOWFS_CACHE SMALL_LIGHT SRCACHE STS \
+ REDIS2 RTMP SET_MISC SFLOW SHIBBOLETH SLOWFS_CACHE SRCACHE STS \
VOD VTS XSS WEBSOCKIFY
AJP_GH_TUPLE= msva:nginx_ajp_module:fcbb2cc:ajp
@@ -58,14 +58,10 @@ DRIZZLE_GH_TUPLE= openresty:drizzle-nginx-module:3504fc6:drizzle
DRIZZLE_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-openresty-drizzle-nginx-module-config
DRIZZLE_VARS= DSO_EXTMODS+=drizzle
+DYNAMIC_UPSTREAM_IMPLIES= STREAM
DYNAMIC_UPSTREAM_GH_TUPLE= ZigzagAK:ngx_dynamic_upstream:960eef2:dynamic_upstream
DYNAMIC_UPSTREAM_VARS= DSO_EXTMODS+=dynamic_upstream
-DYNAMIC_HC_GH_TUPLE= ZigzagAK:ngx_dynamic_healthcheck:61acf02:dynamic_hc
-DYNAMIC_HC_VARS= DSO_EXTMODS+=dynamic_hc
-DYNAMIC_HC_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ngx_dynamic_healthcheck-config
-DYNAMIC_HC_IMPLIES= DYNAMIC_UPSTREAM
-
DEVEL_KIT_GH_TUPLE= simpl:ngx_devel_kit:v0.3.1:devel_kit
DEVEL_KIT_VARS= FIRST_DSO_EXTMODS+=devel_kit
@@ -308,10 +304,6 @@ SHIBBOLETH_VARS= DSO_EXTMODS+=shibboleth
SLOWFS_CACHE_GH_TUPLE= baysao:ngx_slowfs_cache:d011a18:slowfs_cache
SLOWFS_CACHE_VARS= DSO_EXTMODS+=slowfs_cache
-SMALL_LIGHT_USES= magick:6
-SMALL_LIGHT_GH_TUPLE= kawakibi:ngx_small_light:2f5e1d0:small_light
-SMALL_LIGHT_VARS= DSO_EXTMODS+=small_light
-
SRCACHE_GH_TUPLE= openresty:srcache-nginx-module:be22ac0:srcache
SRCACHE_VARS= DSO_EXTMODS+=srcache
diff --git a/www/nginx-devel/Makefile.options.desc b/www/nginx-devel/Makefile.options.desc
index 24110ba933a2..e56d3d83c6b1 100644
--- a/www/nginx-devel/Makefile.options.desc
+++ b/www/nginx-devel/Makefile.options.desc
@@ -10,7 +10,6 @@ DEBUGLOG_DESC= Enable debug log (--with-debug)
DEVEL_KIT_DESC= 3rd party Nginx Development Kit module
DRIZZLE_DESC= 3rd party drizzle module
DSO_DESC= Enable dynamic modules support
-DYNAMIC_HC_DESC= 3rd party dynamic_healthcheck module
DYNAMIC_UPSTREAM_DESC= 3rd party dynamic_upstream module
ECHO_DESC= 3rd party echo module
ENCRYPTSESSION_DESC= 3rd party encrypted_session module
@@ -104,7 +103,6 @@ SET_MISC_DESC= 3rd party set_misc module
SFLOW_DESC= 3rd party sflow module
SHIBBOLETH_DESC= 3rd party shibboleth module
SLOWFS_CACHE_DESC= 3rd party slowfs_cache module
-SMALL_LIGHT_DESC= 3rd party small_light module
SRCACHE_DESC= 3rd party srcache module
STREAMGRP_DESC= Modules that require STREAM module
STREAM_DESC= Enable stream module
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 783edb50e26e..6dd09eb91908 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1681160228
-SHA256 (nginx-1.23.4.tar.gz) = d43300e36bb249a7e6edc60bca1b0fc372a0bafce2f346d76acfb677a8790fc0
-SIZE (nginx-1.23.4.tar.gz) = 1112403
+TIMESTAMP = 1681229804
+SHA256 (nginx-1.24.0.tar.gz) = 77a2541637b92a621e3ee76776c8b7b40cf6d707e69ba53a940283e30ff2f55d
+SIZE (nginx-1.24.0.tar.gz) = 1112471
SHA256 (nginx_mogilefs_module-1.0.4.tar.gz) = 7ac230d30907f013dff8d435a118619ea6168aa3714dba62c6962d350c6295ae
SIZE (nginx_mogilefs_module-1.0.4.tar.gz) = 11208
SHA256 (nginx_mod_h264_streaming-2.2.7.tar.gz) = 6d974ba630cef59de1f60996c66b401264a345d25988a76037c2856cec756c19
@@ -29,8 +29,6 @@ SHA256 (simpl-ngx_devel_kit-v0.3.1_GH0.tar.gz) = 0e971105e210d272a497567fa2e2c25
SIZE (simpl-ngx_devel_kit-v0.3.1_GH0.tar.gz) = 66542
SHA256 (openresty-drizzle-nginx-module-3504fc6_GH0.tar.gz) = 86076735597f14db28cffabc0ab1f233cd51aab7cf112c56e267783e7814fc65
SIZE (openresty-drizzle-nginx-module-3504fc6_GH0.tar.gz) = 51596
-SHA256 (ZigzagAK-ngx_dynamic_healthcheck-61acf02_GH0.tar.gz) = 9a6ac88bcb85cd76e56ce03cf074a78b600cc787642379f76410e78326aca5aa
-SIZE (ZigzagAK-ngx_dynamic_healthcheck-61acf02_GH0.tar.gz) = 49810
SHA256 (ZigzagAK-ngx_dynamic_upstream-960eef2_GH0.tar.gz) = 86e7c6ed6dba2d4c5f5b87ecb91f25ccdb7a08b8a88236e632114f830b9e354b
SIZE (ZigzagAK-ngx_dynamic_upstream-960eef2_GH0.tar.gz) = 23003
SHA256 (openresty-echo-nginx-module-5a402aa_GH0.tar.gz) = bb2a4b1a0e5ffa0203c1be854e663fc92cee0d7b5e0f7a38c0e163ae9124a38f
@@ -131,8 +129,6 @@ SHA256 (nginx-shib-nginx-http-shibboleth-be12df5_GH0.tar.gz) = aff9830b5de78dd9c
SIZE (nginx-shib-nginx-http-shibboleth-be12df5_GH0.tar.gz) = 23872
SHA256 (baysao-ngx_slowfs_cache-d011a18_GH0.tar.gz) = 6ae8abb01a2aff788e75ec68621cb0159148a6f73730a84b30b0bdbc6cdc1758
SIZE (baysao-ngx_slowfs_cache-d011a18_GH0.tar.gz) = 11186
-SHA256 (kawakibi-ngx_small_light-2f5e1d0_GH0.tar.gz) = bb7b4943a2db89a6a7020850db123a9e0bea784aa6ce14261aa5f7121f96c3f4
-SIZE (kawakibi-ngx_small_light-2f5e1d0_GH0.tar.gz) = 57160
SHA256 (openresty-srcache-nginx-module-be22ac0_GH0.tar.gz) = 5753d1ffe87b5d6f5b7a0696667bb5ff1388738136fdee26ba55bc33f5796061
SIZE (openresty-srcache-nginx-module-be22ac0_GH0.tar.gz) = 51029
SHA256 (vozlt-nginx-module-sts-3c10d42_GH0.tar.gz) = 748b67ceb82b3b843ae915bf7863fd08b7c2427c045e5ec540242d050f7b30d0
diff --git a/www/nginx-devel/files/extra-patch-ngx_dynamic_healthcheck-config b/www/nginx-devel/files/extra-patch-ngx_dynamic_healthcheck-config
deleted file mode 100644
index 58f1bbee672a..000000000000
--- a/www/nginx-devel/files/extra-patch-ngx_dynamic_healthcheck-config
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../ngx_dynamic_healthcheck-61acf02/config.orig 2020-08-22 16:35:36.127913000 -0400
-+++ ../ngx_dynamic_healthcheck-61acf02/config 2020-08-22 16:39:36.187267000 -0400
-@@ -31,7 +31,7 @@
- match($0, /([^ ]*\/stream-lua-nginx-module\/src)/, arr)
- print arr[1]
- }')"
--CORE_INCS="$CORE_INCS $stream_lua_nginx_module_incs"
-+CORE_INCS="$CORE_INCS src/stream $stream_lua_nginx_module_incs"
-
-
- if test -n "$ngx_module_link"; then
diff --git a/www/nginx-devel/pkg-plist b/www/nginx-devel/pkg-plist
index 1f747d97c50b..5bb62a462ad9 100644
--- a/www/nginx-devel/pkg-plist
+++ b/www/nginx-devel/pkg-plist
@@ -20,7 +20,6 @@
%%DSO%%%%CT%%libexec/nginx/ngx_ssl_ct_module.so
%%DSO%%%%DEVEL_KIT%%libexec/nginx/ndk_http_module.so
%%DSO%%%%DRIZZLE%%libexec/nginx/ngx_http_drizzle_module.so
-%%DSO%%%%DYNAMIC_HC%%libexec/nginx/ngx_http_dynamic_healthcheck_module.so
%%DSO%%%%DYNAMIC_UPSTREAM%%libexec/nginx/ngx_http_dynamic_upstream_module.so
%%DSO%%%%ECHO%%libexec/nginx/ngx_http_echo_module.so
%%DSO%%%%ENCRYPTSESSION%%libexec/nginx/ngx_http_encrypted_session_module.so
@@ -77,7 +76,6 @@
%%DSO%%%%SET_MISC%%libexec/nginx/ngx_http_set_misc_module.so
%%DSO%%%%SHIBBOLETH%%libexec/nginx/ngx_http_shibboleth_module.so
%%DSO%%%%SLOWFS_CACHE%%libexec/nginx/ngx_http_slowfs_module.so
-%%DSO%%%%SMALL_LIGHT%%libexec/nginx/ngx_http_small_light_module.so
%%DSO%%%%SRCACHE%%libexec/nginx/ngx_http_srcache_filter_module.so
%%DSO%%%%STREAM%%%%NJS%%libexec/nginx/ngx_stream_js_module.so
%%DSO%%%%STREAM%%libexec/nginx/ngx_stream_module.so