aboutsummaryrefslogtreecommitdiff
path: root/www/nginx/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2011-12-29 11:30:39 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2011-12-29 11:30:39 +0000
commit1ddbbe018d3419f7982cb8406afc4a1fc727d352 (patch)
tree21f44d3419db4a3b2057274dd9ddfecc628f556c /www/nginx/Makefile
parent4b8cdee69d168d0558022170b99269fc04713e0e (diff)
downloadports-1ddbbe018d3419f7982cb8406afc4a1fc727d352.tar.gz
ports-1ddbbe018d3419f7982cb8406afc4a1fc727d352.zip
Notes
Diffstat (limited to 'www/nginx/Makefile')
-rw-r--r--www/nginx/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 6c733be9b51d..885d1923cc91 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -337,7 +337,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_response-${NGINX_RESPONSE_MODULE
.endif
.if defined(WITH_HTTP_SUBS_FILTER_MODULE)
-NGINX_HTTP_SUBS_FILTER_MODULE_VERSION= 0.5.2.r45
+NGINX_HTTP_SUBS_FILTER_MODULE_VERSION= 0.5.2.r53
MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:subs_filter/}
MASTER_SITE_SUBDIR+= osa/:subs_filter
DISTFILES+= ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_MODULE_VERSION}.tar.gz:subs_filter
@@ -369,11 +369,12 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_upload_module-${NGINX_UPLOAD_MODULE
.endif
.if defined(WITH_HTTP_UPLOAD_PROGRESS)
-NGINX_UPLOADPROGRESS_MODULE_VERSION= 0.8.2
-MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:uploadprogress/}
-MASTER_SITE_SUBDIR+= osa/:uploadprogress
-DISTFILES+= nginx_uploadprogress_module-${NGINX_UPLOADPROGRESS_MODULE_VERSION}.tar.gz:uploadprogress
-CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_uploadprogress_module-${NGINX_UPLOADPROGRESS_MODULE_VERSION}
+NGINX_UPLOADPROGRESS_MODULE_VERSION= 0.8.3
+GIT_UPLOADPROGRESS_MODULE_VERSION= 0-gc7c663f
+FETCH_ARGS= -pRr
+MASTER_SITES+= https://github.com/masterzen/nginx-upload-progress-module/tarball/v${NGINX_UPLOADPROGRESS_MODULE_VERSION}/:uploadprogress
+DISTFILES+= masterzen-nginx-upload-progress-module-v${NGINX_UPLOADPROGRESS_MODULE_VERSION}-${GIT_UPLOADPROGRESS_MODULE_VERSION}.tar.gz:uploadprogress
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/masterzen-nginx-upload-progress-module-${GIT_UPLOADPROGRESS_MODULE_VERSION:S/^0-g//}
.endif
.if defined(WITH_HTTP_UPSTREAM_FAIR) || defined(WITH_SUPERVISORD_MODULE)