aboutsummaryrefslogtreecommitdiff
path: root/www/nginx/Makefile
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2020-03-13 17:47:43 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2020-03-13 17:47:43 +0000
commit544741ba0d5f8d03113878a5249232c92a6a90cb (patch)
treebd033abaad58290d143d91597b2b01159a7296ad /www/nginx/Makefile
parent265a8799c18f0a93b7c9f6319e9b0dc09e192036 (diff)
downloadports-544741ba0d5f8d03113878a5249232c92a6a90cb.tar.gz
ports-544741ba0d5f8d03113878a5249232c92a6a90cb.zip
Notes
Diffstat (limited to 'www/nginx/Makefile')
-rw-r--r--www/nginx/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 7fb913f4c105..1ade039b7db3 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.16.1
-PORTREVISION?= 11
+PORTREVISION?= 12
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
@@ -168,7 +168,6 @@ HTTP_REWRITE_CONFIGURE_OFF= --without-http_rewrite_module
HTTP_SECURE_LINK_CONFIGURE_ON= --with-http_secure_link_module
HTTP_SLICE_CONFIGURE_ON= --with-http_slice_module
HTTP_SSL_CONFIGURE_ON= --with-http_ssl_module
-HTTP_SSL_USE= openssl_rpath
HTTP_SSL_USES= ssl
HTTP_STATUS_CONFIGURE_ON= --with-http_stub_status_module
HTTP_SUB_CONFIGURE_ON= --with-http_sub_module
@@ -365,6 +364,9 @@ do-install-NAXSI-on:
${WRKDIR}/naxsi-${NAXSI_NGINX_VER}/naxsi_config/naxsi_core.rules \
${STAGEDIR}${ETCDIR}
+do-install-NJS-on:
+ ${INSTALL_PROGRAM} ${WRKSRC_njs}/build/njs ${STAGEDIR}${PREFIX}/sbin
+
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share/vim/vimfiles
cd ${WRKSRC}/contrib/vim && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/vim/vimfiles