aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-06-08 11:28:41 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-06-08 11:28:41 +0000
commitd23410d39b435127591c9e404ff7b29ee860b4df (patch)
treedab444198ceb8ad1a84494cccd16083ed3ab3ffb /www/nginx
parenta8ed9abd7f32fcbe528c38e1b9408a5dbcde1b9b (diff)
Notes
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile6
-rw-r--r--www/nginx/distinfo6
-rw-r--r--www/nginx/files/extra-patch-ngx_http_slowfs_module.c15
3 files changed, 4 insertions, 23 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 8d658c31e899..05269d63e5c2 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -381,7 +381,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/passenger-${PASSENGER_VERSION}/ext/nginx
.endif
.if defined(WITH_SLOWFS_CACHE_MODULE)
-NGINX_SLOWFS_CACHE_MODULE_VERSION= 1.4
+NGINX_SLOWFS_CACHE_MODULE_VERSION= 1.5
MASTER_SITES+= http://labs.frickle.com/files/:slowfs_cache
DISTFILES+= ngx_slowfs_cache-${NGINX_SLOWFS_CACHE_MODULE_VERSION}.tar.gz:slowfs_cache
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_slowfs_cache-${NGINX_SLOWFS_CACHE_MODULE_VERSION}
@@ -485,10 +485,6 @@ post-patch:
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_upstream.h
.endif
-.if defined(WITH_SLOWFS_CACHE_MODULE)
- @${PATCH} ${PATCH_ARGS} < \
- ${PATCHDIR}/extra-patch-ngx_http_slowfs_module.c
-.endif
.if defined(WITH_SUPERVISORD_MODULE)
( cd ${WRKDIR}/nginx_upstream_fair-${NGINX_UPSTREAM_FAIR_VERSION} && \
${PATCH} -p0 < \
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 57d82fcc38a5..0986e2b7ee4b 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -73,9 +73,9 @@ SIZE (ngx_http_memc_module-0.08.tar.gz) = 92182
MD5 (passenger-2.2.14.tar.gz) = 296205978dffe1de3c35bf844c2bc3c7
SHA256 (passenger-2.2.14.tar.gz) = 9d23b509324a0d00c3e1aac1402a36ffa2470edf8dd13ab999bf260287481d2b
SIZE (passenger-2.2.14.tar.gz) = 2207394
-MD5 (ngx_slowfs_cache-1.4.tar.gz) = 0aafe80f856682a94f016fb4bb5dd3c6
-SHA256 (ngx_slowfs_cache-1.4.tar.gz) = 0e71a916832b1aa7586f973df1a731621c2bcb5198352525d95643615c9f422c
-SIZE (ngx_slowfs_cache-1.4.tar.gz) = 9741
+MD5 (ngx_slowfs_cache-1.5.tar.gz) = 165c93b1adc6b5cebc2b2aa28f881682
+SHA256 (ngx_slowfs_cache-1.5.tar.gz) = 8f3d1afd6bcaaeba89bc4f9d5e5ba3e2b334bf8e7e5b56bd37f25b5cbac8d828
+SIZE (ngx_slowfs_cache-1.5.tar.gz) = 9785
MD5 (ngx_supervisord-1.4.tar.gz) = 57b9cc2835f5fb66fc65b2fd3cc3ed37
SHA256 (ngx_supervisord-1.4.tar.gz) = 0954a4efb1b955692acf523e169221146d6aa93ad1643c9f2482f75a1fbf9e3b
SIZE (ngx_supervisord-1.4.tar.gz) = 19351
diff --git a/www/nginx/files/extra-patch-ngx_http_slowfs_module.c b/www/nginx/files/extra-patch-ngx_http_slowfs_module.c
deleted file mode 100644
index f20f4aa8d09d..000000000000
--- a/www/nginx/files/extra-patch-ngx_http_slowfs_module.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- ../ngx_slowfs_cache-1.4/ngx_http_slowfs_module.c.orig 2010-06-07 17:01:32.000000000 +0400
-+++ ../ngx_slowfs_cache-1.4/ngx_http_slowfs_module.c 2010-06-07 17:04:15.000000000 +0400
-@@ -809,12 +809,6 @@
- return NGX_DECLINED;
- }
-
--#if defined(nginx_version) && (nginx_version < 8038)
-- if (r->zero_in_uri) {
-- return NGX_DECLINED;
-- }
--#endif
--
- slowcf = ngx_http_get_module_loc_conf(r, ngx_http_slowfs_module);
- if (!slowcf->enabled) {
- return NGX_DECLINED;