aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-03-25 10:02:43 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-03-25 10:02:43 +0000
commit8c95869ed83cd13bfc6e0b1ef480ea4fad8e4ff1 (patch)
tree1e25e304c54afc39c8531a46773d1b83d87a0e3d /www/nginx
parent20d3f32c41931aab215538af7946b328b9a343d2 (diff)
Notes
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile9
-rw-r--r--www/nginx/distinfo3
2 files changed, 12 insertions, 0 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index df09bee11231..a3b488b48530 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -43,6 +43,7 @@ OPTIONS= DEBUG "Build with debug" off \
MAIL_SSL_MODULE "Enable mail_ssl module" off \
WWW "Enable html sample files" on \
CACHE_PURGE_MODULE "3rd party cache_purge module" off \
+ ECHO_MODULE "3rd party echo module" off \
HEADERS_MORE_MODULE "3rd party headers_more module" off \
HTTP_ACCEPT_LANGUAGE "3rd party accept_language module" off \
HTTP_ACCESSKEY_MODULE "3rd party http_accesskey module" off \
@@ -176,6 +177,14 @@ DISTFILES+= ngx_cache_purge-${NGINX_CACHE_PURGE_MODULE_VERSION}.tar.gz:cache_pur
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_cache_purge-${NGINX_CACHE_PURGE_MODULE_VERSION}
.endif
+.if defined(WITH_ECHO_MODULE)
+NGINX_ECHO_MODULE_VERSION= 0.26
+MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:echo/}
+MASTER_SITE_SUBDIR+= osa/:echo
+DISTFILES+= ngx_echo_module-${NGINX_ECHO_MODULE_VERSION}.tar.gz:echo
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_echo_module-${NGINX_ECHO_MODULE_VERSION}
+.endif
+
.if defined(WITH_HEADERS_MORE_MODULE)
NGINX_HEADERS_MORE_MODULE_VERSION= 0.07
MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:headers_more/}
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index b21d142970ff..81cbfbd309fd 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -16,6 +16,9 @@ SIZE (ngx_http_auth_request_module-0.2.tar.gz) = 6736
MD5 (ngx_cache_purge-1.0.tar.gz) = ec1dabaa8321530c100f9baf65370294
SHA256 (ngx_cache_purge-1.0.tar.gz) = 6f4229a4edc0e8b914dc89c0a3c5b6a746469a3f9e5942b3d025dbe6a5ab2d13
SIZE (ngx_cache_purge-1.0.tar.gz) = 4569
+MD5 (ngx_echo_module-0.26.tar.gz) = 21d1042481239c33b99b27bccbd2d574
+SHA256 (ngx_echo_module-0.26.tar.gz) = b85eede1ca0c99856b0a812723f2bb68fc60828723ed37f8251771c0c0bdaa9e
+SIZE (ngx_echo_module-0.26.tar.gz) = 112987
MD5 (ngx_headers_more_module-0.07.tar.gz) = 2077c792e1bf2d51852e14a5f89102f5
SHA256 (ngx_headers_more_module-0.07.tar.gz) = 6cc57f41468bb8f363cd72e842c68cad5b696b829d93dd4e490bedab7a510083
SIZE (ngx_headers_more_module-0.07.tar.gz) = 73339