aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2013-11-03 06:32:53 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2013-11-03 06:32:53 +0000
commit652acfb5ce2c698477b31e73991bfe7f6ad1b91e (patch)
tree692c3a37eae9653efcf81ff20092cc4ba45fc2cd /www/nginx
parent53591eb508239f231bc3550d871b84bb39a273b5 (diff)
downloadports-652acfb5ce2c698477b31e73991bfe7f6ad1b91e.tar.gz
ports-652acfb5ce2c698477b31e73991bfe7f6ad1b91e.zip
Notes
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 59ff719d758c..6f9129d4df7a 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -255,7 +255,7 @@ CATEGORIES+= ipv6
.endif
.if ${PORT_OPTIONS:MGOOGLE_PERFTOOLS}
-LIB_DEPENDS+= profiler:${PORTSDIR}/devel/google-perftools
+LIB_DEPENDS+= libprofiler.so:${PORTSDIR}/devel/google-perftools
CONFIGURE_ARGS+=--with-google_perftools_module
.endif
@@ -330,7 +330,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_cache_purge-${NGINX_CACHE_PURGE_VERSI
.endif
.if ${PORT_OPTIONS:MCTPP2}
-LIB_DEPENDS+= ctpp2:${PORTSDIR}/textproc/ctpp2
+LIB_DEPENDS+= libctpp2.so:${PORTSDIR}/textproc/ctpp2
NGINX_CTPP2_VERSION= 0.5
MASTER_SITES+= http://dl.vbart.ru/ngx-ctpp/:ctpp2
DISTFILES+= ngx_ctpp2-${NGINX_CTPP2_VERSION}.tar.gz:ctpp2
@@ -361,7 +361,7 @@ CONFIGURE_ARGS+=--with-http_dav_module
.if ${PORT_OPTIONS:MHTTP_DAV_EXT}
USE_HTTP_DAV= yes
-LIB_DEPENDS+= expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2
NGINX_DAV_EXT_VERSION= 0.0.2
GIT_DAV_EXT_VERSION= 0-g0e07a3e
FETCH_ARGS= -pRr
@@ -393,7 +393,7 @@ CONFIGURE_ARGS+=--with-http_flv_module
.if ${PORT_OPTIONS:MHTTP_GEOIP}
CONFIGURE_ARGS+=--with-http_geoip_module
-LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
.endif
.if ${PORT_OPTIONS:MHTTP_GZIP_STATIC}
@@ -405,7 +405,7 @@ CONFIGURE_ARGS+=--with-http_gunzip_module
.endif
.if ${PORT_OPTIONS:MHTTP_IMAGE_FILTER}
-LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= libgd.so:${PORTSDIR}/graphics/gd
CONFIGURE_ARGS+=--with-http_image_filter_module
.endif
@@ -557,7 +557,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/mod_zip-${NGINX_ZIP_VERSION}
.endif
.if ${PORT_OPTIONS:MDRIZZLE}
-LIB_DEPENDS+= drizzle:${PORTSDIR}/databases/libdrizzle
+LIB_DEPENDS+= libdrizzle.so:${PORTSDIR}/databases/libdrizzle
NGINX_DRIZZLE_VERSION= 0.1.5
GIT_DRIZZLE_VERSION= 0-g943c915
FETCH_ARGS= -pRr
@@ -608,7 +608,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/arut-nginx-let-module-${GIT_LET_VERSION:S
.endif
.if ${PORT_OPTIONS:MLUA}
-LIB_DEPENDS+= luajit-5.1:${PORTSDIR}/lang/luajit
+LIB_DEPENDS+= libluajit-5.1.so:${PORTSDIR}/lang/luajit
CONFIGURE_ENV+= "LUAJIT_INC=${LOCALBASE}/include/luajit-2.0"
CONFIGURE_ENV+= "LUAJIT_LIB=${LOCALBASE}/lib"
NGINX_LUA_VERSION= 0.8.6
@@ -630,8 +630,8 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/agentzh-memc-nginx-module-${GIT_MEMC_VERS
.if ${PORT_OPTIONS:MMODSECURITY}
NGINX_MODSECURITY_VERSION= 2.7.5
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre \
- apr-1:${PORTSDIR}/devel/apr1
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre \
+ libapr-1.so:${PORTSDIR}/devel/apr1
USE_APACHE= 22+
USE_GNOME= libxml2
MASTER_SITES+= http://www.modsecurity.org/tarball/${NGINX_MODSECURITY_VERSION}/:modsecurity
@@ -648,7 +648,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/naxsi-core-${NGINX_NAXSI_VERSION}/naxsi_s
.endif
.if ${PORT_OPTIONS:MHTTP_REWRITE} || defined(USE_HTTP_REWRITE)
-LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+=--with-pcre
.else
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-nopcre