aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2011-04-12 10:20:31 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2011-04-12 10:20:31 +0000
commit94fe64e9c3b0a40071acb50d0b3639ccf8526efb (patch)
tree4966066a980579cf5a975646dde11efd8c54c810 /www/nginx
parent48c298fafc18c8e78dbccafb55d64a2f841ba8eb (diff)
downloadports-94fe64e9c3b0a40071acb50d0b3639ccf8526efb.tar.gz
ports-94fe64e9c3b0a40071acb50d0b3639ccf8526efb.zip
Notes
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile11
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/nginx.8.in201
3 files changed, 8 insertions, 208 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index ed29b9692f51..6b68f11d2fee 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.8.54
-PORTREVISION= 2
+PORTVERSION= 1.0.0
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -102,8 +101,6 @@ USE_RC_SUBR= nginx.sh
SUB_LIST+= WWWOWN=${WWWOWN}
.if !defined(NO_INSTALL_MANPAGES)
MAN8= nginx.8
-SUB_FILES+= nginx.8
-SUB_LIST+= NGINX_ERRORLOG=${NGINX_ERRORLOG} NGINX_RUNDIR=${NGINX_RUNDIR}
.endif
HAS_CONFIGURE= yes
@@ -412,6 +409,10 @@ MASTER_SITES+= RF/passenger/:passenger
DISTFILES+= passenger-${PASSENGER_VERSION}.tar.gz:passenger
CONFIGURE_ARGS+=--add-module=${WRKDIR}/passenger-${PASSENGER_VERSION}/ext/nginx
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-passenger::build::nginx.rb
+.if !defined(WITH_DEBUG)
+CONFIGURE_ENV+= OPTIMIZE="yes"
+CFLAGS+= -DNDEBUG
+.endif
.endif
.if defined(WITH_SLOWFS_CACHE_MODULE)
@@ -564,7 +565,7 @@ post-install:
${ECHO_CMD} @dirrm ${SITE_PERL_REL}/${PERL_ARCH}/auto/nginx >> ${TMPPLIST}
.endif
.if !defined(NO_INSTALL_MANPAGES)
- @${INSTALL_MAN} ${WRKDIR}/nginx.8 ${MAN8PREFIX}/man/man8
+ @${INSTALL_MAN} ${WRKSRC}/objs/nginx.8 ${MAN8PREFIX}/man/man8
.endif
.include <bsd.port.post.mk>
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 491e09a20a6c..58a09b823552 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,5 +1,5 @@
-SHA256 (nginx-0.8.54.tar.gz) = 12e28efb9a54452fa6e579e08ce7c864e49d6ea6104cc2b3de5a4416ead90593
-SIZE (nginx-0.8.54.tar.gz) = 650001
+SHA256 (nginx-1.0.0.tar.gz) = 3de3d6caeed56751c24ebc5cfb03475620b9eb0fa999c766a01d44dca674c001
+SIZE (nginx-1.0.0.tar.gz) = 654760
SHA256 (nginx_accept_language_module.tar.gz) = 7a4c2d42a83c5b6efd2b7b13ad232850b6ab0ca4261df6b46fb7d2d2738b1c0a
SIZE (nginx_accept_language_module.tar.gz) = 3299
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
diff --git a/www/nginx/files/nginx.8.in b/www/nginx/files/nginx.8.in
deleted file mode 100644
index 8c3437b4e5b6..000000000000
--- a/www/nginx/files/nginx.8.in
+++ /dev/null
@@ -1,201 +0,0 @@
-.\"
-.\" Copyright (c) 2010 Sergey A. Osokin
-.\" All rights reserved.
-.\"
-.\" Redistribution and use in source and binary forms, with or without
-.\" modification, are permitted provided that the following conditions
-.\" are met:
-.\" 1. Redistributions of source code must retain the above copyright
-.\" notice, this list of conditions and the following disclaimer.
-.\" 2. Redistributions in binary form must reproduce the above copyright
-.\" notice, this list of conditions and the following disclaimer in the
-.\" documentation and/or other materials provided with the distribution.
-.\"
-.\" THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
-.\" ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-.\" IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-.\" ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
-.\" FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-.\" DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
-.\" OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-.\" HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
-.\" LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
-.\" OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
-.\" SUCH DAMAGE.
-.\"
-.\"
-.Dd November 14, 2010
-.Dt NGINX 8
-.Os
-.Sh NAME
-.Nm nginx
-.Nd "HTTP and reverse proxy server, mail proxy server"
-.Sh SYNOPSIS
-.Nm
-.Op Fl hqtvV?
-.Op Fl c Ar file
-.Op Fl g Ar directives
-.Op Fl p Ar prefix
-.Op Fl s Ar signal
-.Sh DESCRIPTION
-The
-.Nm
-(spelled
-.Dq engine x )
-is an HTTP and reverse proxy server, as well as a mail proxy server.
-The
-.Nm
-is known for its high performance, stability, rich feature set, simple
-configuration, and low resource consumption.
-.Pp
-The options are as follows:
-.Bl -tag -width ".Fl d Ar directives"
-.It Fl ?\& | h
-Print help.
-.It Fl c Ar file
-Use an alternative configuration
-.Ar file .
-.It Fl g Ar directives
-Set global configuration directives.
-See
-.Sx EXAMPLES
-for details.
-.It Fl p Ar prefix
-Set prefix path.
-Default value is
-.Pa %%PREFIX%%/etc/nginx .
-.It Fl q
-Suppress non-error messages during configuration testing.
-.It Fl s Ar signal
-Send signal to the master process.
-The argument
-.Ar signal
-can be one of:
-.Cm stop , quit , reopen , reload .
-The following table shows the corresponding system signals.
-.Pp
-.Bl -tag -width ".It Cm reopen" -compact
-.It Cm stop
-.Dv SIGTERM
-.It Cm quit
-.Dv SIGQUIT
-.It Cm reopen
-.Dv SIGUSR1
-.It Cm reload
-.Dv SIGHUP
-.El
-.It Fl t
-Don't run, just test the configuration file.
-The
-.Nm
-checks configuration for correct syntax and then tries to open files
-referred in configuration.
-.It Fl v
-Print
-.Nm
-version.
-.It Fl V
-Print
-.Nm
-version, compiler version and
-.Pa configure
-script parameters.
-.El
-.Sh SIGNALS
-The master process of
-.Nm
-can handle the following signals.
-.Pp
-.Bl -tag -width ".It Dv SIGINT , SIGTERM" -compact
-.It Dv SIGINT , SIGTERM
-Shut down quickly.
-.It Dv SIGHUP
-Reload configuration, start the new worker process with a new
-configuration, gracefully shut down old worker processes.
-.It Dv SIGQUIT
-Shut down gracefully.
-.It Dv SIGUSR1
-Reopen log files.
-.It Dv SIGUSR2
-Upgrade
-.Nm
-executable on the fly.
-.It Dv SIGWINCH
-Shut down gracefully worker processes.
-.El
-.Pp
-While there's no need to explicitly control worker processes normally,
-they support some signals, too:
-.Pp
-.Bl -tag -width ".It Dv SIGINT , SIGTERM" -compact
-.It Dv SIGTERM
-Shut down quickly.
-.It Dv SIGQUIT
-Shut down gracefully.
-.It Dv SIGUSR1
-Reopen log files.
-.El
-.Sh DEBUGGING LOG
-To enable a debugging log, reconfigure
-.Nm
-to build with debugging:
-.Pp
-.Dl "./configure --with-debug ..."
-.Pp
-and then set the
-.Cm debug
-level of the
-.Va error_log :
-.Pp
-.Dl "error_log /path/to/log debug;"
-.Pp
-It is also possible to enable the debugging for some IP address:
-.Bd -literal -offset indent
-events {
- debug_connection 127.0.0.1;
-}
-.Ed
-.Sh FILES
-.Bl -tag -width indent -compact
-.It Pa %%NGINX_RUNDIR%%/nginx/nginx.pid
-Contains the process ID of the
-.Nm
-listening for connections.
-The content of this file is not sensitive; it can be world-readable.
-.It Pa %%PREFIX%%/etc/nginx/nginx.conf
-Main configuration file.
-.It Pa %%NGINX_ERRORLOG%%
-Error log file.
-.El
-.Sh EXIT STATUS
-Exit status is 0 on success, or 1 if the command fails.
-.Sh EXAMPLES
-.Bd -literal
-nginx -t -c ~/mynginx.conf -g "pid %%NGINX_RUNDIR%%/mynginx.pid; worker_processes 2;"
-.Ed
-Test configuration file
-.Pa ~/mynginx.conf
-with global directives for PID and quantity of worker processes.
-.Sh SEE ALSO
-.Xr nginx.conf 5
-.Sh HISTORY
-Development of
-.Nm
-started in 2002, with the first public release in 2004.
-.Sh AUTHORS
-.An Igor Sysoev Aq igor@sysoev.ru
-.Pp
-Documentation available on
-.Pa http://nginx.org/
-and
-.Pa http://sysoev.ru/nginx/ .
-.Pp
-This manual page was written by
-.An Sergey A. Osokin Aq osa@FreeBSD.org.ru
-as a result of compilation of many
-.Nm
-documents all over the world.
-.Sh BUGS
-Report to mailing list
-.Aq Li nginx@nginx.org
-if you found one.