aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2019-11-28 10:17:37 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2019-11-28 10:17:37 +0000
commitab082438f713eb30023acda00eb98169bfbc33f8 (patch)
tree310238bc0604baee3d4a3cd2e392a26a6e46c03c /www/nginx
parentb766736619b6bc800f6472eb45381c69380d3aad (diff)
downloadports-ab082438f713eb30023acda00eb98169bfbc33f8.tar.gz
ports-ab082438f713eb30023acda00eb98169bfbc33f8.zip
Notes
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/Makefile.extmod2
-rw-r--r--www/nginx/distinfo6
-rw-r--r--www/nginx/files/extra-patch-spnego-http-auth-nginx-module-config2
-rw-r--r--www/nginx/files/nginx.in9
5 files changed, 15 insertions, 6 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 712db4e66eb6..c80e39dfd7ab 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.16.1
-PORTREVISION?= 6
+PORTREVISION?= 7
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
diff --git a/www/nginx/Makefile.extmod b/www/nginx/Makefile.extmod
index bba2cc623922..49707089b027 100644
--- a/www/nginx/Makefile.extmod
+++ b/www/nginx/Makefile.extmod
@@ -235,7 +235,7 @@ NAXSI_NGINX_VER= 0.56
NAXSI_GH_TUPLE= nbs-system:naxsi:${NAXSI_NGINX_VER}:naxsi
NAXSI_VARS= DSO_EXTMODS+=naxsi NAXSI_SUBDIR=/naxsi_src
-NJS_GH_TUPLE= nginx:njs:08ccd37:njs
+NJS_GH_TUPLE= nginx:njs:d9d2562:njs
NJS_VARS= DSO_EXTMODS+=njs NJS_SUBDIR=/nginx
PASSENGER_NGINX_VER= 6.0.4
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 3863ddd96ed2..59e21380d332 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1574782814
+TIMESTAMP = 1574931163
SHA256 (nginx-1.16.1.tar.gz) = f11c2a6dd1d3515736f0324857957db2de98be862461b5a542a3ac6188dbe32b
SIZE (nginx-1.16.1.tar.gz) = 1032630
SHA256 (ngx_cache_purge-2.3.tar.gz) = 279e0d8a46d3b1521fd43b3f78bc1c08b263899142a7cc5058c1c0361a92c89c
@@ -111,8 +111,8 @@ SHA256 (SpiderLabs-ModSecurity-nginx-71ede63_GH0.tar.gz) = 2914d2fc4b9a000748058
SIZE (SpiderLabs-ModSecurity-nginx-71ede63_GH0.tar.gz) = 28816
SHA256 (nbs-system-naxsi-0.56_GH0.tar.gz) = 0a66dcadd32432460fab180be9f2efe24e911e3798917b2787ee710e02901eb4
SIZE (nbs-system-naxsi-0.56_GH0.tar.gz) = 192120
-SHA256 (nginx-njs-08ccd37_GH0.tar.gz) = d58a10d1bd15dd7570ae191e0037635896c56042e812c6818a13ac8556f8d821
-SIZE (nginx-njs-08ccd37_GH0.tar.gz) = 339254
+SHA256 (nginx-njs-d9d2562_GH0.tar.gz) = fc9cd36b9571fe06a34983063f268e2bed3e1ffc9d253c4e5be4c02a3dc09164
+SIZE (nginx-njs-d9d2562_GH0.tar.gz) = 367471
SHA256 (FRiCKLE-ngx_postgres-1.0rc7_GH0.tar.gz) = c942e674a7273ab87caab4dcad626ab54852be192c29b1add50d2cb535e3cbb9
SIZE (FRiCKLE-ngx_postgres-1.0rc7_GH0.tar.gz) = 40742
SHA256 (openresty-rds-csv-nginx-module-v0.08_GH0.tar.gz) = 26e80646cc4ad87984c60dab584e8f32faf5dbebb4c6911784339822f4675c79
diff --git a/www/nginx/files/extra-patch-spnego-http-auth-nginx-module-config b/www/nginx/files/extra-patch-spnego-http-auth-nginx-module-config
index 37543286589a..7f2022d6da24 100644
--- a/www/nginx/files/extra-patch-spnego-http-auth-nginx-module-config
+++ b/www/nginx/files/extra-patch-spnego-http-auth-nginx-module-config
@@ -1,5 +1,5 @@
--- ../spnego-http-auth-nginx-module-0c6ff3f/config.orig 2017-04-15 13:07:01.159506000 -0400
-+++ ../spnego-http-auth-nginx-module-7e028a5/config 2018-04-20 00:15:08.515289000 +0200
++++ ../spnego-http-auth-nginx-module-21bb963/config 2018-04-20 00:15:08.515289000 +0200
@@ -1,9 +1,6 @@
ngx_addon_name=ngx_http_auth_spnego_module
-ngx_feature_libs="-lgssapi_krb5 -lkrb5 -lcom_err"
diff --git a/www/nginx/files/nginx.in b/www/nginx/files/nginx.in
index c0765f6b676f..3478a6948cb3 100644
--- a/www/nginx/files/nginx.in
+++ b/www/nginx/files/nginx.in
@@ -21,6 +21,9 @@
# Extra flags passed to start command.
# nginxlimits_args (str): Default to "-e -U %%WWWOWN%%"
# Arguments of pre-start limits run.
+# nginx_http_accept_enable (bool): Set to "NO" by default.
+# Set to yes to check for accf_http kernel module
+# on start-up and load if not loaded.
. /etc/rc.subr
@@ -44,6 +47,7 @@ extra_commands="reload configtest upgrade gracefulstop"
[ -z "$nginx_enable" ] && nginx_enable="NO"
[ -z "$nginxlimits_enable" ] && nginxlimits_enable="NO"
[ -z "$nginxlimits_args" ] && nginxlimits_args="-e -U %%WWWOWN%%"
+[ -z "$nginx_http_accept_enable" ] && nginx_http_accept_enable="NO"
load_rc_config $name
@@ -123,6 +127,11 @@ nginx_upgrade()
nginx_precmd()
{
+ if checkyesno nginx_http_accept_enable
+ then
+ required_modules="$required_modules accf_http accf_data"
+ fi
+
nginx_checkconfig
if checkyesno nginxlimits_enable