aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2008-11-21 12:39:18 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2008-11-21 12:39:18 +0000
commit0daaf237a833d039edc13b329c4212d162151633 (patch)
tree426525aa0b5d13f78e41b26b49cd424d69a2a0be /www/nginx
parentac915d0ec72bcc86d319eb31b488400573cc20ca (diff)
downloadports-0daaf237a833d039edc13b329c4212d162151633.tar.gz
ports-0daaf237a833d039edc13b329c4212d162151633.zip
Notes
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile3
-rw-r--r--www/nginx/distinfo6
-rw-r--r--www/nginx/files/patch-src::http::nginx_http.c10
3 files changed, 14 insertions, 5 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 44416bd78d67..a64c63ab655b 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.6.32
-PORTREVISION= 1
+PORTVERSION= 0.6.33
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 562c12259f30..bf70376aa634 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,3 +1,3 @@
-MD5 (nginx-0.6.32.tar.gz) = c09a2ace3c91f45dabbb608b11e48ed1
-SHA256 (nginx-0.6.32.tar.gz) = d74bbb9235e7beabf7be03a7dec99f0cab89fa4430a998a6a7151901ea141e9d
-SIZE (nginx-0.6.32.tar.gz) = 522183
+MD5 (nginx-0.6.33.tar.gz) = 36d7a2ae7204a7ba0cd7625c4ccdba68
+SHA256 (nginx-0.6.33.tar.gz) = f21b5923b51b799fc91292e513ec965239189f5ad2936bd88a18b0a807c49613
+SIZE (nginx-0.6.33.tar.gz) = 523162
diff --git a/www/nginx/files/patch-src::http::nginx_http.c b/www/nginx/files/patch-src::http::nginx_http.c
new file mode 100644
index 000000000000..e6cd2d60ff8e
--- /dev/null
+++ b/www/nginx/files/patch-src::http::nginx_http.c
@@ -0,0 +1,10 @@
+--- src/http/ngx_http.c.orig 2008-03-24 16:04:02.000000000 +0300
++++ src/http/ngx_http.c 2008-08-27 22:11:11.000000000 +0400
+@@ -558,6 +558,7 @@
+
+ in_addr[a].core_srv_conf = cscfp[s];
+ in_addr[a].default_server = 1;
++ in_addr[a].listen_conf = &lscf[l].conf;
+ }
+
+ goto found;