aboutsummaryrefslogtreecommitdiff
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2010-06-07 14:32:02 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2010-06-07 14:32:02 +0000
commite9a7261c81930349b24cd79ed361e0d95621d12c (patch)
treebdb96ce6cf44200f908e9513fbc4714e18e62444 /www/nginx
parent294fe32f0654d94cd330a404c1e9389847b535e1 (diff)
downloadports-e9a7261c81930349b24cd79ed361e0d95621d12c.tar.gz
ports-e9a7261c81930349b24cd79ed361e0d95621d12c.zip
Notes
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile22
-rw-r--r--www/nginx/distinfo6
-rw-r--r--www/nginx/files/extra-patch-StaticContentHandler.c15
-rw-r--r--www/nginx/files/extra-patch-ngx_http_echo_time.c20
-rw-r--r--www/nginx/files/extra-patch-ngx_http_fancyindex_module.c12
-rw-r--r--www/nginx/files/extra-patch-ngx_http_slowfs_module.c15
-rw-r--r--www/nginx/files/extra-patch-ngx_http_streaming_module.c13
7 files changed, 99 insertions, 4 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index cdbdcccdf017..9c56afad4886 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.7.65
+PORTVERSION= 0.7.66
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -16,6 +16,8 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= osa@FreeBSD.org
COMMENT= Robust and small WWW server
+LICENSE= BSD
+
OPTIONS= DEBUG "Build with debug" off \
DEBUGLOG "Enable debug log (--with-debug)" off \
IPV6 "Enable IPv6" off \
@@ -454,6 +456,18 @@ post-patch:
's!$$HTTP_ACCESSKEY_MODULE!ngx_http_accesskey_module!' \
${WRKDIR}/nginx-accesskey-${NGINX_ACCESSKEY_MODULE_VERSION}/config
.endif
+.if defined(WITH_ECHO_MODULE)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_echo_time.c
+.endif
+.if defined(WITH_HTTP_FANCYINDEX_MODULE)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_fancyindex_module.c
+.endif
+.if defined(WITH_HTTP_MP4_H264_MODULE)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_streaming_module.c
+.endif
.if defined(WITH_HTTP_NOTICE_MODULE)
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_notice_module.c
@@ -464,11 +478,17 @@ post-patch:
@${REINPLACE_CMD} '377s!-g!${CXXFLAGS}!; \
s!-lpthread!${PTHREAD_LIBS}!g' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/lib/phusion_passenger/platform_info.rb
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-StaticContentHandler.c
.endif
.if defined(WITH_HTTP_UPSTREAM_HASH)
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_upstream.h
.endif
+.if defined(WITH_SLOWFS_CACHE_MODULE)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_slowfs_module.c
+.endif
.if defined(WITH_SUPERVISORD_MODULE)
( cd ${WRKDIR}/nginx_upstream_fair-${NGINX_UPSTREAM_FAIR_VERSION} && \
${PATCH} -p0 < \
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 0ee5722c5cea..176160fbd82b 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,6 +1,6 @@
-MD5 (nginx-0.7.65.tar.gz) = abc4f76af450eedeb063158bd963feaa
-SHA256 (nginx-0.7.65.tar.gz) = c9f0ccaf5a09b01edf991f3adde8fced9361965838c0982112fa5c92aa2ec33a
-SIZE (nginx-0.7.65.tar.gz) = 604451
+MD5 (nginx-0.7.66.tar.gz) = 8e4712df2a3205b7e71d85ecdb712cb0
+SHA256 (nginx-0.7.66.tar.gz) = 63fc64fd690aab0952932b287e5a25a995cc5f11155fe54ea9571aaf957093f8
+SIZE (nginx-0.7.66.tar.gz) = 608376
MD5 (nginx_accept_language_module.tar.gz) = 330a8d3b2376fb476b5d3111a7905ec3
SHA256 (nginx_accept_language_module.tar.gz) = 7a4c2d42a83c5b6efd2b7b13ad232850b6ab0ca4261df6b46fb7d2d2738b1c0a
SIZE (nginx_accept_language_module.tar.gz) = 3299
diff --git a/www/nginx/files/extra-patch-StaticContentHandler.c b/www/nginx/files/extra-patch-StaticContentHandler.c
new file mode 100644
index 000000000000..60a108f77186
--- /dev/null
+++ b/www/nginx/files/extra-patch-StaticContentHandler.c
@@ -0,0 +1,15 @@
+--- ../passenger-2.2.14/ext/nginx/StaticContentHandler.c.orig 2010-06-04 14:37:15.000000000 +0400
++++ ../passenger-2.2.14/ext/nginx/StaticContentHandler.c 2010-06-07 16:59:47.000000000 +0400
+@@ -67,12 +67,6 @@
+ return NGX_DECLINED;
+ }
+
+- #if NGINX_VERSION_NUM < 8038
+- if (r->zero_in_uri) {
+- return NGX_DECLINED;
+- }
+- #endif
+-
+ log = r->connection->log;
+
+ ngx_log_debug1(NGX_LOG_DEBUG_HTTP, log, 0,
diff --git a/www/nginx/files/extra-patch-ngx_http_echo_time.c b/www/nginx/files/extra-patch-ngx_http_echo_time.c
new file mode 100644
index 000000000000..125a75bce5d6
--- /dev/null
+++ b/www/nginx/files/extra-patch-ngx_http_echo_time.c
@@ -0,0 +1,20 @@
+--- ../ngx_echo_module-0.30/src/ngx_http_echo_timer.c.orig 2010-06-07 16:32:51.000000000 +0400
++++ ../ngx_echo_module-0.30/src/ngx_http_echo_timer.c 2010-06-07 16:34:32.000000000 +0400
+@@ -25,7 +25,7 @@
+
+ /* force the ngx timer to update */
+
+-#if defined nginx_version && nginx_version >= 8035
++#if defined nginx_version && (nginx_version >= 8035 || nginx_version >= 7066)
+ ngx_time_update();
+ #else
+ ngx_time_update(0, 0);
+@@ -62,7 +62,7 @@
+
+ /* force the ngx timer to update */
+
+-#if defined nginx_version && nginx_version >= 8035
++#if defined nginx_version && (nginx_version >= 8035 || nginx_version >= 7066)
+ ngx_time_update();
+ #else
+ ngx_time_update(0, 0);
diff --git a/www/nginx/files/extra-patch-ngx_http_fancyindex_module.c b/www/nginx/files/extra-patch-ngx_http_fancyindex_module.c
new file mode 100644
index 000000000000..f37a86a094d7
--- /dev/null
+++ b/www/nginx/files/extra-patch-ngx_http_fancyindex_module.c
@@ -0,0 +1,12 @@
+--- ../ngx-fancyindex-0.2.2/ngx_http_fancyindex_module.c.orig 2010-05-24 17:59:08.000000000 +0400
++++ ../ngx-fancyindex-0.2.2/ngx_http_fancyindex_module.c 2010-05-24 17:59:36.000000000 +0400
+@@ -591,9 +591,6 @@
+ }
+
+ /* TODO: Win32 */
+- if (r->zero_in_uri) {
+- return NGX_DECLINED;
+- }
+
+ if (!(r->method & (NGX_HTTP_GET|NGX_HTTP_HEAD))) {
+ return NGX_DECLINED;
diff --git a/www/nginx/files/extra-patch-ngx_http_slowfs_module.c b/www/nginx/files/extra-patch-ngx_http_slowfs_module.c
new file mode 100644
index 000000000000..f20f4aa8d09d
--- /dev/null
+++ b/www/nginx/files/extra-patch-ngx_http_slowfs_module.c
@@ -0,0 +1,15 @@
+--- ../ngx_slowfs_cache-1.4/ngx_http_slowfs_module.c.orig 2010-06-07 17:01:32.000000000 +0400
++++ ../ngx_slowfs_cache-1.4/ngx_http_slowfs_module.c 2010-06-07 17:04:15.000000000 +0400
+@@ -809,12 +809,6 @@
+ return NGX_DECLINED;
+ }
+
+-#if defined(nginx_version) && (nginx_version < 8038)
+- if (r->zero_in_uri) {
+- return NGX_DECLINED;
+- }
+-#endif
+-
+ slowcf = ngx_http_get_module_loc_conf(r, ngx_http_slowfs_module);
+ if (!slowcf->enabled) {
+ return NGX_DECLINED;
diff --git a/www/nginx/files/extra-patch-ngx_http_streaming_module.c b/www/nginx/files/extra-patch-ngx_http_streaming_module.c
new file mode 100644
index 000000000000..3641090a9b5d
--- /dev/null
+++ b/www/nginx/files/extra-patch-ngx_http_streaming_module.c
@@ -0,0 +1,13 @@
+--- ../nginx_mod_h264_streaming-2.2.7/src/ngx_http_streaming_module.c.orig 2010-05-24 18:04:43.000000000 +0400
++++ ../nginx_mod_h264_streaming-2.2.7/src/ngx_http_streaming_module.c 2010-05-24 18:05:02.000000000 +0400
+@@ -155,10 +155,6 @@
+ }
+
+ /* TODO: Win32 */
+- if (r->zero_in_uri)
+- {
+- return NGX_DECLINED;
+- }
+
+ rc = ngx_http_discard_request_body(r);
+