aboutsummaryrefslogtreecommitdiff
path: root/www/node/Makefile
diff options
context:
space:
mode:
authorBradley T. Hughes <bhughes@FreeBSD.org>2020-09-18 04:50:56 +0000
committerBradley T. Hughes <bhughes@FreeBSD.org>2020-09-18 04:50:56 +0000
commit8d29214ebea5ae31ba7920939e11b77373ee414b (patch)
treed7c8e1a8da253e5f5f53f1d1abad745051d259b0 /www/node/Makefile
parent889d5f43d92e01e78a05d8f042818d5c653c5868 (diff)
downloadports-8d29214ebea5ae31ba7920939e11b77373ee414b.tar.gz
ports-8d29214ebea5ae31ba7920939e11b77373ee414b.zip
MFH: r541372 r543678 r543682 r545547 r545560 r547570 r548046 r548047 r548707 r548802
www/node: Update 14.4.0 -> 14.5.0 https://nodejs.org/en/blog/release/v14.5.0/ Refresh patches with `make makepatch`, and adapt them to the changes from upstream due to the V8 upgrade. Sponsored by: Miles AS www/node10: Update 10.21.0 -> 10.22.0 https://nodejs.org/en/blog/release/v10.22.0/ Sponsored by: Miles AS www/node: Update 14.6.0 -> 14.6.0_1 Bump PORTREVISION after updating the minimum version requirements for libuv, libnghttp2, and libcares. The previous change for www/node erroneously mentioned the most recent www/node10 update. The correct changelog should have read: www/node: Update 14.5.0 -> 14.6.0 https://nodejs.org/en/blog/release/v14.6.0/ Sponsored by: Miles AS www/node: Update 14.6.0_1 -> 14.7.0 https://nodejs.org/en/blog/release/v14.7.0/ Sponsored by: Miles AS www/node: Update 14.7.0 -> 14.8.0 https://nodejs.org/en/blog/release/v14.8.0/ Sponsored by: Miles AS www/node: Update 14.8.0 -> 14.9.0 https://nodejs.org/en/blog/release/v14.9.0/ Sponsored by: Miles AS www/node: Update 14.9.0 -> 14.10.0 https://nodejs.org/en/blog/release/v14.10.0/ While here, refresh patches with `make makepatch`. Sponsored by: Miles AS www/node: add dependency on archivers/brotli ... instead of building the version bundled with Node.js. Bump PORTREVISION due to the new dependency. Sponsored by: Miles AS www/node: Update 14.10.0_1 -> 14.10.1 https://nodejs.org/en/blog/release/v14.10.1/ Sponsored by: Miles AS www/node: Update 14.10.1 -> 14.11.0 https://nodejs.org/en/blog/release/v14.11.0/ This is a security release. See https://nodejs.org/en/blog/vulnerability/september-2020-security-releases/ Security: 4ca5894c-f7f1-11ea-8ff8-0022489ad614 Sponsored by: Miles AS Approved by: ports-secteam (fluffy)
Notes
Notes: svn path=/branches/2020Q3/; revision=548876
Diffstat (limited to 'www/node/Makefile')
-rw-r--r--www/node/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 7e484f32b6cc..e1fac4e95172 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 14.4.0
+PORTVERSION= 14.11.0
DISTVERSIONPREFIX= v
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
@@ -38,7 +38,7 @@ BUNDLED_SSL_CONFIGURE_OFF= --shared-openssl --openssl-use-def-ca-store
BUNDLED_SSL_RUN_DEPENDS_OFF= ca_root_nss>=0:security/ca_root_nss
NLS_CONFIGURE_ON= --with-intl=system-icu
-NLS_BUILD_DEPENDS= icu>=66.1:devel/icu
+NLS_BUILD_DEPENDS= icu>=67.1:devel/icu
NLS_LIB_DEPENDS= libicui18n.so:devel/icu
DTRACE_CONFIGURE_ON= --with-dtrace
@@ -52,6 +52,7 @@ CONFLICTS_INSTALL= node[68]-[0-9]* node10-[0-9]* node12-[0-9]*
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
--without-npm \
+ --shared-brotli \
--shared-cares \
--shared-libuv \
--shared-nghttp2 \
@@ -68,11 +69,13 @@ MAKE_ENV+= CC.host=${CC} CFLAGS.host="${CFLAGS}" \
CXX.host=${CXX} CXXFLAGS.host="${CXXFLAGS}" \
LINK.host=${CXX} LDFLAGS.host="${LDFLAGS}"
-BUILD_DEPENDS+= c-ares>=1.15.0:dns/c-ares\
- libuv>=1.37.0:devel/libuv \
- libnghttp2>=1.40.0:www/libnghttp2 \
+BUILD_DEPENDS+= brotli>=1.0.9,1:archivers/brotli \
+ c-ares>=1.16.0:dns/c-ares \
+ libuv>=1.39.0:devel/libuv \
+ libnghttp2>=1.41.0:www/libnghttp2 \
objdump:devel/binutils
-LIB_DEPENDS+= libcares.so:dns/c-ares\
+LIB_DEPENDS+= libbrotlidec.so:archivers/brotli \
+ libcares.so:dns/c-ares\
libuv.so:devel/libuv \
libnghttp2.so:www/libnghttp2