aboutsummaryrefslogtreecommitdiff
path: root/www/node/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-05 19:34:16 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-01-05 19:34:16 +0000
commit9c328055d5681a3a50276b318a309e64a016f230 (patch)
treec518d06c470a4c51320c3279ef74c7685f7cf11e /www/node/Makefile
parent7f13e4e93a8af9f96a47f7bfde46b4cbbd7cc06e (diff)
downloadports-9c328055d5681a3a50276b318a309e64a016f230.tar.gz
ports-9c328055d5681a3a50276b318a309e64a016f230.zip
Notes
Diffstat (limited to 'www/node/Makefile')
-rw-r--r--www/node/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index ad8b8c430525..1d9848d56706 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 7.3.0
+PORTVERSION= 7.4.0
DISTVERSIONPREFIX= v
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
@@ -22,7 +22,7 @@ OPTIONS_EXCLUDE+= DTRACE
OPTIONS_EXCLUDE_FreeBSD_10= DTRACE
-BUNDLED_SSL_DESC= Use node.js's bundled OpenSSL implementation
+BUNDLED_SSL_DESC= Use node.js's bundled OpenSSL implementation #'
BUNDLED_SSL_USES_OFF= ssl
BUNDLED_SSL_CONFIGURE_OFF= --shared-openssl
@@ -73,7 +73,7 @@ IGNORE= cannot build node.js with LibreSSL. You must enable BUNDLED_SSL
.endif
.if ${ARCH} == "armv6"
-CONFIGURE_ARGS= --openssl-no-asm
+CONFIGURE_ARGS+=--openssl-no-asm
.endif
.if ${COMPILER_TYPE} == gcc
@@ -82,10 +82,7 @@ CXXFLAGS+= -D_GLIBCXX_USE_C99
.endif
.if ${PORT_OPTIONS:MDTRACE}
-PLIST_SUB+= DTRACE=""
CONFIGURE_ARGS+= --with-dtrace
-.else
-PLIST_SUB+= DTRACE="@comment "
.endif
post-patch: