aboutsummaryrefslogtreecommitdiff
path: root/www/node010
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-03-04 02:47:52 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-03-04 02:47:52 +0000
commit7f4ceda80360b4a8456e18d9fc5ce602281a88c7 (patch)
treeb2640cedc9c92ffa66433ff8530359236679a2e5 /www/node010
parentcb6677063111f6174666180d40155efc2db2d092 (diff)
downloadports-7f4ceda80360b4a8456e18d9fc5ce602281a88c7.tar.gz
ports-7f4ceda80360b4a8456e18d9fc5ce602281a88c7.zip
Notes
Diffstat (limited to 'www/node010')
-rw-r--r--www/node010/Makefile61
-rw-r--r--www/node010/distinfo2
-rw-r--r--www/node010/pkg-descr3
-rw-r--r--www/node010/pkg-message2
-rw-r--r--www/node010/pkg-plist30
5 files changed, 98 insertions, 0 deletions
diff --git a/www/node010/Makefile b/www/node010/Makefile
new file mode 100644
index 000000000000..e1e98c92a6cd
--- /dev/null
+++ b/www/node010/Makefile
@@ -0,0 +1,61 @@
+# Created by: Jin-Sih Lin <linpct@gmail.com>
+# $FreeBSD$
+
+PORTNAME= node
+PORTVERSION= 0.10.36
+CATEGORIES= www
+MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
+PKGNAMESUFFIX= -0.10
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= linpct@gmail.com
+COMMENT= V8 JavaScript for client and server
+
+LICENSE= MIT
+
+USES= compiler execinfo gmake python:2
+HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+CONFLICTS= node-0.[02-9][0-9]* node-devel-0.[0-9]* iojs-*
+
+ONLY_FOR_ARCHS= i386 amd64
+CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} --without-npm --shared-zlib
+PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
+REINPLACE_ARGS= -i ''
+MAKE_ENV+= CC.host=${CC} CXX.host=${CXX} LINK.host=${CXX} LINK.target=${CXX}
+
+.include <bsd.port.pre.mk>
+.if ${COMPILER_TYPE} == clang
+MAKE_ENV+= LINK=clang++
+CFLAGS+= -Wno-unused-private-field
+.if ${COMPILER_VERSION} >= 33
+CFLAGS+= -Wno-nested-anon-types -Wno-unused-function
+.if ${COMPILER_VERSION} >= 34
+CFLAGS+= -Wno-unused-const-variable
+.endif
+.endif
+.else
+MAKE_ARGS+= strictaliasing=off
+USE_GCC= any
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '1 s|${SETENV} python|${PYTHON_CMD}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|'python',|'${PYTHON_CMD}',|" \
+ ${WRKSRC}/deps/v8/build/common.gypi \
+ ${WRKSRC}/deps/v8/tools/gyp/v8.gyp \
+ ${WRKSRC}/deps/v8/src/d8.gyp
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/deps/v8/build/common.gypi \
+ ${WRKSRC}/deps/v8/tools/gyp/v8.gyp
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/node_modules/
+ ${TOUCH} ${STAGEDIR}${PREFIX}/lib/node_modules/.keepme
+ ${CHMOD} ${MANMODE} ${STAGEDIR}${PREFIX}/man/man1/node.1
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Note: If you need npm (Node Package Manager), please install www/npm."
+ @${ECHO_MSG}
+
+.include <bsd.port.post.mk>
diff --git a/www/node010/distinfo b/www/node010/distinfo
new file mode 100644
index 000000000000..70a330b83f8b
--- /dev/null
+++ b/www/node010/distinfo
@@ -0,0 +1,2 @@
+SHA256 (node-v0.10.36.tar.gz) = b9d7d1d0294bce46686b13a05da6fc5b1e7743b597544aa888e8e64a9f178c81
+SIZE (node-v0.10.36.tar.gz) = 14410899
diff --git a/www/node010/pkg-descr b/www/node010/pkg-descr
new file mode 100644
index 000000000000..9a04228d0c91
--- /dev/null
+++ b/www/node010/pkg-descr
@@ -0,0 +1,3 @@
+node v0.10.x - evented I/O for V8 javascript
+
+WWW: http://nodejs.org/
diff --git a/www/node010/pkg-message b/www/node010/pkg-message
new file mode 100644
index 000000000000..e807568bd054
--- /dev/null
+++ b/www/node010/pkg-message
@@ -0,0 +1,2 @@
+
+Note: If you need npm (Node Package Manager), please install www/npm.
diff --git a/www/node010/pkg-plist b/www/node010/pkg-plist
new file mode 100644
index 000000000000..b4bfb8f1b6ff
--- /dev/null
+++ b/www/node010/pkg-plist
@@ -0,0 +1,30 @@
+bin/node
+include/node/ares.h
+include/node/ares_version.h
+include/node/common.gypi
+include/node/config.gypi
+include/node/nameser.h
+include/node/node.h
+include/node/node_buffer.h
+include/node/node_internals.h
+include/node/node_object_wrap.h
+include/node/node_version.h
+include/node/openssl/opensslconf.h
+include/node/uv-private/ngx-queue.h
+include/node/uv-private/stdint-msvc2008.h
+include/node/uv-private/tree.h
+include/node/uv-private/uv-bsd.h
+include/node/uv-private/uv-darwin.h
+include/node/uv-private/uv-linux.h
+include/node/uv-private/uv-sunos.h
+include/node/uv-private/uv-unix.h
+include/node/uv-private/uv-win.h
+include/node/uv.h
+include/node/v8-debug.h
+include/node/v8-preparser.h
+include/node/v8-profiler.h
+include/node/v8-testing.h
+include/node/v8.h
+include/node/v8stdint.h
+lib/node_modules/.keepme
+man/man1/node.1.gz