aboutsummaryrefslogtreecommitdiff
path: root/www/node04
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2010-11-18 18:01:25 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2010-11-18 18:01:25 +0000
commit4e38a3ff95aac0e3bf68079956d285662d4040ae (patch)
tree28e4f18652c15acb3d124e052837cb83d0e2bc46 /www/node04
parentc5912aade0fa8db9f4220f524f3277b947517d4c (diff)
downloadports-4e38a3ff95aac0e3bf68079956d285662d4040ae.tar.gz
ports-4e38a3ff95aac0e3bf68079956d285662d4040ae.zip
Notes
Diffstat (limited to 'www/node04')
-rw-r--r--www/node04/Makefile2
-rw-r--r--www/node04/distinfo5
-rw-r--r--www/node04/files/patch-wafadmin-Node.py15
3 files changed, 18 insertions, 4 deletions
diff --git a/www/node04/Makefile b/www/node04/Makefile
index c574c7fc2f06..9b6fb7fbf649 100644
--- a/www/node04/Makefile
+++ b/www/node04/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= node
-PORTVERSION= 0.2.4
+PORTVERSION= 0.2.5
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
diff --git a/www/node04/distinfo b/www/node04/distinfo
index fa22b536a79b..cb087adfa422 100644
--- a/www/node04/distinfo
+++ b/www/node04/distinfo
@@ -1,3 +1,2 @@
-MD5 (node-v0.2.4.tar.gz) = 413c8f648be1cb9f6f6db615894c75a2
-SHA256 (node-v0.2.4.tar.gz) = e6952007dacf18d9d85ae8ede8228e25cfe46e00be21b31c4d166239ec1fa533
-SIZE (node-v0.2.4.tar.gz) = 4002347
+SHA256 (node-v0.2.5.tar.gz) = 6c964096e2fb7bfa9108b31bdd2a920465a1b7f7a603e3937128eee9538b44bb
+SIZE (node-v0.2.5.tar.gz) = 4008314
diff --git a/www/node04/files/patch-wafadmin-Node.py b/www/node04/files/patch-wafadmin-Node.py
new file mode 100644
index 000000000000..b593bc720531
--- /dev/null
+++ b/www/node04/files/patch-wafadmin-Node.py
@@ -0,0 +1,15 @@
+--- tools/wafadmin/Node.py.orig 2010-10-25 05:45:39.000000000 +0800
++++ tools/wafadmin/Node.py 2010-10-27 18:30:12.000000000 +0800
+@@ -349,6 +349,12 @@
+ if self == from_node: return '.'
+ if from_node.parent == self: return '..'
+
++ from_node_path = from_node.abspath()
++ from_node_realpath = os.path.realpath(from_node_path)
++ if from_node_path != from_node_realpath:
++ from_node = self.__class__.bld.root.find_dir(from_node_realpath)
++ return self.relpath_gen(from_node)
++
+ # up_path is '../../../' and down_path is 'dir/subdir/subdir/file'
+ ancestor = self.find_ancestor(from_node)
+ lst = []