aboutsummaryrefslogtreecommitdiff
path: root/www/node6/Makefile
diff options
context:
space:
mode:
authorBradley T. Hughes <bhughes@FreeBSD.org>2019-03-29 04:57:05 +0000
committerBradley T. Hughes <bhughes@FreeBSD.org>2019-03-29 04:57:05 +0000
commit32926c7289fba7b87b4999a7c6054cbd449eb67f (patch)
treefd44da4b8781f15efba44f71c7790479c4547385 /www/node6/Makefile
parent19f0bd96bab155cf24bffe00c274b11b5c8fb0a2 (diff)
www/node*: specify minimum versions of dependencies in BUILD_DEPENDS
Add BUILD_DEPENDS for all LIB_DEPENDS, specifying the minimum version as the version bundled with a particlar version of Node.js. This should help people building from ports with out-of-date dependencies with a helpful message instead of build failures. Reported by: freebsd-ports@ Sponsored by: Miles AS
Notes
Notes: svn path=/head/; revision=497067
Diffstat (limited to 'www/node6/Makefile')
-rw-r--r--www/node6/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/www/node6/Makefile b/www/node6/Makefile
index 0c4715a4cc57..383ac175786b 100644
--- a/www/node6/Makefile
+++ b/www/node6/Makefile
@@ -41,6 +41,7 @@ BUNDLED_SSL_USES_OFF= ssl
BUNDLED_SSL_CONFIGURE_OFF+= --shared-openssl
NLS_CONFIGURE_ON= --with-intl=system-icu
+NLS_BUILD_DEPENDS= icu>=58.2:devel/icu
NLS_LIB_DEPENDS= libicui18n.so:devel/icu
DTRACE_CONFIGURE_ON= --with-dtrace
@@ -66,6 +67,8 @@ MAKE_ENV+= CC.host=${CC} CFLAGS.host="${CFLAGS}" \
CXX.host=${CXX} CXXFLAGS.host="${CXXFLAGS}" \
LINK.host=${CXX} LDFLAGS.host="${LDFLAGS}"
+BUILD_DEPENDS+= c-ares>=1.10.0:dns/c-ares\
+ libuv>=1.16.1:devel/libuv
LIB_DEPENDS+= libcares.so:dns/c-ares\
libuv.so:devel/libuv