aboutsummaryrefslogtreecommitdiff
path: root/www/node
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2011-05-12 15:57:42 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2011-05-12 15:57:42 +0000
commite4d5388e5bfaae63d515ca6a2fc2b6fbedb847fe (patch)
tree8737c560ffab25cd4c4acae7d1413565faffe437 /www/node
parent867c93ee025e38908bfb9e0e250ff6737c37c01e (diff)
downloadports-e4d5388e5bfaae63d515ca6a2fc2b6fbedb847fe.tar.gz
ports-e4d5388e5bfaae63d515ca6a2fc2b6fbedb847fe.zip
Notes
Diffstat (limited to 'www/node')
-rw-r--r--www/node/Makefile14
-rw-r--r--www/node/files/patch-SConstruct11
-rw-r--r--www/node/pkg-plist12
3 files changed, 28 insertions, 9 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index e38ca30495b8..d4b30b58665a 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -7,6 +7,7 @@
PORTNAME= node
PORTVERSION= 0.4.7
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -23,12 +24,19 @@ USE_LDCONFIG= yes
USE_PYTHON= yes
USE_GNOME= pkgconfig
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
MAKE_JOBS_SAFE= yes
-
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST}
PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64
+BUILD_DEPENDS= ${LOCALBASE}/include/v8.h:${PORTSDIR}/lang/v8
+CONFIGURE_ARGS+= --shared-v8-includes=${LOCALBASE}/include --shared-v8-libpath=${LOCALBASE}/lib
+PLIST_SUB+= SHAREDV8="@comment "
+.endif
+
.if !defined(DISABLE_MAKE_JOBS)
WAF_ARGS= --jobs=${MAKE_JOBS_NUMBER}
.endif
@@ -42,4 +50,4 @@ do-install:
post-install:
@${INSTALL_MAN} ${WRKSRC}/doc/node.1 ${MANPREFIX}/man/man1/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/node/files/patch-SConstruct b/www/node/files/patch-SConstruct
new file mode 100644
index 000000000000..b14bb95ffc1c
--- /dev/null
+++ b/www/node/files/patch-SConstruct
@@ -0,0 +1,11 @@
+--- deps/v8/SConstruct.orig 2011-04-06 19:17:46.000000000 +0800
++++ deps/v8/SConstruct 2011-05-12 20:48:13.000000000 +0800
+@@ -178,7 +178,7 @@ LIBRARY_FLAGS = {
+ }
+ },
+ 'os:freebsd': {
+- 'CPPPATH' : ['/usr/local/include'],
++ 'CPPPATH' : [join(root_dir, 'src'), '/usr/local/include'],
+ 'LIBPATH' : ['/usr/local/lib'],
+ 'CCFLAGS': ['-ansi'],
+ 'LIBS': ['execinfo']
diff --git a/www/node/pkg-plist b/www/node/pkg-plist
index 991e3b0261a0..013be64f0e5f 100644
--- a/www/node/pkg-plist
+++ b/www/node/pkg-plist
@@ -9,12 +9,12 @@ include/node/node_config.h
include/node/node_events.h
include/node/node_object_wrap.h
include/node/node_version.h
-include/node/v8-debug.h
-include/node/v8-preparser.h
-include/node/v8-profiler.h
-include/node/v8-testing.h
-include/node/v8.h
-include/node/v8stdint.h
+%%SHAREDV8%%include/node/v8-debug.h
+%%SHAREDV8%%include/node/v8-preparser.h
+%%SHAREDV8%%include/node/v8-profiler.h
+%%SHAREDV8%%include/node/v8-testing.h
+%%SHAREDV8%%include/node/v8.h
+%%SHAREDV8%%include/node/v8stdint.h
lib/node/wafadmin/Build.py
lib/node/wafadmin/Configure.py
lib/node/wafadmin/Constants.py