aboutsummaryrefslogtreecommitdiff
path: root/www/node
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-02-11 05:18:58 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-02-11 05:18:58 +0000
commit38a2d4ae3461e79498d1dc2d8acc3d904a338947 (patch)
treefbf9b277aec04d92347b42602228777c19e30272 /www/node
parentd6de710363307f112844e2c6706e3243fc5df410 (diff)
downloadports-38a2d4ae3461e79498d1dc2d8acc3d904a338947.tar.gz
ports-38a2d4ae3461e79498d1dc2d8acc3d904a338947.zip
Notes
Diffstat (limited to 'www/node')
-rw-r--r--www/node/Makefile17
-rw-r--r--www/node/distinfo4
-rw-r--r--www/node/files/patch-deps_v8_src_platform-freebsd.cc50
-rw-r--r--www/node/files/patch-deps_v8_src_platform-posix.cc11
-rw-r--r--www/node/pkg-plist30
5 files changed, 88 insertions, 24 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 351c6828134f..99f840ffa10c 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 0.10.35
+PORTVERSION= 0.12.0
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -12,7 +12,7 @@ COMMENT= V8 JavaScript for client and server
LICENSE= MIT
-USES= gmake compiler execinfo python:2
+USES= compiler execinfo gmake python:2
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -40,18 +40,21 @@ USE_GCC= any
.endif
post-patch:
- @${REINPLACE_CMD} -e '1 s|${SETENV} python|${PYTHON_CMD}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/deps/v8/tools/gyp/v8.gyp
+ @${REINPLACE_CMD} -e 's|/usr/bin/env python|${PYTHON_CMD}|' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|'python',|'${PYTHON_CMD}',|" \
- ${WRKSRC}/deps/v8/build/common.gypi \
+ ${WRKSRC}/deps/v8/build/shim_headers.gypi \
${WRKSRC}/deps/v8/tools/gyp/v8.gyp \
${WRKSRC}/deps/v8/src/d8.gyp
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
- ${WRKSRC}/deps/v8/build/common.gypi \
- ${WRKSRC}/deps/v8/tools/gyp/v8.gyp
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/node_modules/
${TOUCH} ${STAGEDIR}${PREFIX}/lib/node_modules/.keepme
${CHMOD} ${MANMODE} ${STAGEDIR}${PREFIX}/man/man1/node.1
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Note: If you need npm (Node Package Manager), please install www/npm."
+ @${ECHO_MSG}
.include <bsd.port.post.mk>
diff --git a/www/node/distinfo b/www/node/distinfo
index a514c4ad9267..ec133924234d 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v0.10.35.tar.gz) = 0043656bb1724cb09dbdc960a2fd6ee37d3badb2f9c75562b2d11235daa40a03
-SIZE (node-v0.10.35.tar.gz) = 14417025
+SHA256 (node-v0.12.0.tar.gz) = 9700e23af4e9b3643af48cef5f2ad20a1331ff531a12154eef2bfb0bb1682e32
+SIZE (node-v0.12.0.tar.gz) = 19096897
diff --git a/www/node/files/patch-deps_v8_src_platform-freebsd.cc b/www/node/files/patch-deps_v8_src_platform-freebsd.cc
index 2802769ea38f..63b85b4fe84c 100644
--- a/www/node/files/patch-deps_v8_src_platform-freebsd.cc
+++ b/www/node/files/patch-deps_v8_src_platform-freebsd.cc
@@ -1,6 +1,46 @@
---- deps/v8/src/platform-freebsd.cc.orig 2014-09-16 18:47:52.000000000 -0400
-+++ deps/v8/src/platform-freebsd.cc 2014-10-08 13:23:25.000000000 -0400
-@@ -343,7 +343,7 @@
+--- ./deps/v8/src/base/platform/platform-freebsd.cc.orig 2015-02-07 04:04:23.000000000 +0800
++++ ./deps/v8/src/base/platform/platform-freebsd.cc 2015-02-10 10:53:45.000000000 +0800
+@@ -131,23 +131,23 @@
+ addr_buffer[0] = '0';
+ addr_buffer[1] = 'x';
+ addr_buffer[10] = 0;
+- int result = read(fd, addr_buffer + 2, 8);
+- if (result < 8) break;
++ ssize_t bytes_read = read(fd, addr_buffer + 2, 8);
++ if (bytes_read < 8) break;
+ unsigned start = StringToLong(addr_buffer);
+- result = read(fd, addr_buffer + 2, 1);
+- if (result < 1) break;
++ bytes_read = read(fd, addr_buffer + 2, 1);
++ if (bytes_read < 1) break;
+ if (addr_buffer[2] != '-') break;
+- result = read(fd, addr_buffer + 2, 8);
+- if (result < 8) break;
++ bytes_read = read(fd, addr_buffer + 2, 8);
++ if (bytes_read < 8) break;
+ unsigned end = StringToLong(addr_buffer);
+ char buffer[MAP_LENGTH];
+- int bytes_read = -1;
++ bytes_read = -1;
+ do {
+ bytes_read++;
+ if (bytes_read >= MAP_LENGTH - 1)
+ break;
+- result = read(fd, buffer + bytes_read, 1);
+- if (result < 1) break;
++ bytes_read = read(fd, buffer + bytes_read, 1);
++ if (bytes_read < 1) break;
+ } while (buffer[bytes_read] != '\n');
+ buffer[bytes_read] = 0;
+ // Ignore mappings that are not executable.
+@@ -182,13 +182,13 @@
+
+ VirtualMemory::VirtualMemory(size_t size, size_t alignment)
+ : address_(NULL), size_(0) {
+- DCHECK(IsAligned(alignment, static_cast<intptr_t>(OS::AllocateAlignment())));
++ DCHECK((alignment % OS::AllocateAlignment()) == 0);
+ size_t request_size = RoundUp(size + alignment,
+ static_cast<intptr_t>(OS::AllocateAlignment()));
void* reservation = mmap(OS::GetRandomMmapAddr(),
request_size,
PROT_NONE,
@@ -9,7 +49,7 @@
kMmapFd,
kMmapFdOffset);
if (reservation == MAP_FAILED) return;
-@@ -415,7 +415,7 @@
+@@ -260,7 +260,7 @@
void* result = mmap(OS::GetRandomMmapAddr(),
size,
PROT_NONE,
@@ -18,7 +58,7 @@
kMmapFd,
kMmapFdOffset);
-@@ -445,7 +445,7 @@
+@@ -288,7 +288,7 @@
return mmap(base,
size,
PROT_NONE,
diff --git a/www/node/files/patch-deps_v8_src_platform-posix.cc b/www/node/files/patch-deps_v8_src_platform-posix.cc
new file mode 100644
index 000000000000..b503c60da038
--- /dev/null
+++ b/www/node/files/patch-deps_v8_src_platform-posix.cc
@@ -0,0 +1,11 @@
+--- ./deps/v8/src/base/platform/platform-posix.cc.orig 2015-02-07 04:04:23.000000000 +0800
++++ ./deps/v8/src/base/platform/platform-posix.cc 2015-02-08 01:11:42.000000000 +0800
+@@ -328,7 +328,7 @@
+ #elif V8_OS_ANDROID
+ return static_cast<int>(gettid());
+ #else
+- return static_cast<int>(pthread_self());
++ return static_cast<int>(reinterpret_cast<intptr_t>(pthread_self()));
+ #endif
+ }
+
diff --git a/www/node/pkg-plist b/www/node/pkg-plist
index b4bfb8f1b6ff..063f68b5a141 100644
--- a/www/node/pkg-plist
+++ b/www/node/pkg-plist
@@ -1,8 +1,10 @@
bin/node
+include/node/android-ifaddrs.h
include/node/ares.h
include/node/ares_version.h
include/node/common.gypi
include/node/config.gypi
+include/node/libplatform/libplatform.h
include/node/nameser.h
include/node/node.h
include/node/node_buffer.h
@@ -10,21 +12,29 @@ include/node/node_internals.h
include/node/node_object_wrap.h
include/node/node_version.h
include/node/openssl/opensslconf.h
-include/node/uv-private/ngx-queue.h
-include/node/uv-private/stdint-msvc2008.h
-include/node/uv-private/tree.h
-include/node/uv-private/uv-bsd.h
-include/node/uv-private/uv-darwin.h
-include/node/uv-private/uv-linux.h
-include/node/uv-private/uv-sunos.h
-include/node/uv-private/uv-unix.h
-include/node/uv-private/uv-win.h
+include/node/pthread-fixes.h
+include/node/smalloc.h
+include/node/stdint-msvc2008.h
+include/node/tree.h
+include/node/uv-aix.h
+include/node/uv-bsd.h
+include/node/uv-darwin.h
+include/node/uv-errno.h
+include/node/uv-linux.h
+include/node/uv-sunos.h
+include/node/uv-threadpool.h
+include/node/uv-unix.h
+include/node/uv-version.h
+include/node/uv-win.h
include/node/uv.h
include/node/v8-debug.h
-include/node/v8-preparser.h
+include/node/v8-platform.h
include/node/v8-profiler.h
include/node/v8-testing.h
+include/node/v8-util.h
include/node/v8.h
+include/node/v8config.h
include/node/v8stdint.h
lib/node_modules/.keepme
man/man1/node.1.gz
+share/systemtap/tapset/node.stp