aboutsummaryrefslogtreecommitdiff
path: root/www/node
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-01-31 16:14:42 +0000
committerSteve Wills <swills@FreeBSD.org>2014-01-31 16:14:42 +0000
commitea218b5176eb81dd89416e70bf89d93c9a141606 (patch)
tree5b5abd89947f057cbaf0597f7924aea6c016319b /www/node
parente64855c99cdf9b488ef56f8470ad17753526c8cc (diff)
downloadports-ea218b5176eb81dd89416e70bf89d93c9a141606.tar.gz
ports-ea218b5176eb81dd89416e70bf89d93c9a141606.zip
Notes
Diffstat (limited to 'www/node')
-rw-r--r--www/node/Makefile2
-rw-r--r--www/node/distinfo4
-rw-r--r--www/node/files/patch-kqueue.c28
-rw-r--r--www/node/pkg-plist36
4 files changed, 37 insertions, 33 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index ed171eaf0993..55f17afffd5a 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 0.10.22
+PORTVERSION= 0.10.25
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
diff --git a/www/node/distinfo b/www/node/distinfo
index fcaef21c00f1..16c18d6be2c5 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v0.10.22.tar.gz) = 157fc58b3f1d109baefac4eb1d32ae747de5e6d55d87d0e9bec8f8dd10679e7e
-SIZE (node-v0.10.22.tar.gz) = 13686897
+SHA256 (node-v0.10.25.tar.gz) = 46eef3b9d5475a2081dc2b2f7cf1f4c3a56824d1fc9b04e7ed1d7a88e8f6b36f
+SIZE (node-v0.10.25.tar.gz) = 13732322
diff --git a/www/node/files/patch-kqueue.c b/www/node/files/patch-kqueue.c
deleted file mode 100644
index e29f12c128db..000000000000
--- a/www/node/files/patch-kqueue.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- deps/uv/src/unix/kqueue.orig 2013-11-18 23:14:54.000000000 -0200
-+++ deps/uv/src/unix/kqueue.c 2013-11-18 23:16:51.000000000 -0200
-@@ -263,6 +263,25 @@
- }
- }
-
-+
-+void uv__platform_invalidate_fd(uv_loop_t* loop, int fd) {
-+ struct kevent* events;
-+ uintptr_t i;
-+ uintptr_t nfds;
-+
-+ assert(loop->watchers != NULL);
-+
-+ events = (struct kevent*) loop->watchers[loop->nwatchers];
-+ nfds = (uintptr_t) loop->watchers[loop->nwatchers + 1];
-+ if (events == NULL)
-+ return;
-+
-+ /* Invalidate events with same file descriptor */
-+ for (i = 0; i < nfds; i++)
-+ if ((int) events[i].ident == fd)
-+ events[i].ident = -1;
-+}
-+
-
- static void uv__fs_event(uv_loop_t* loop, uv__io_t* w, unsigned int fflags) {
- uv_fs_event_t* handle;
diff --git a/www/node/pkg-plist b/www/node/pkg-plist
index 6108ad1fcba0..d35f2f982529 100644
--- a/www/node/pkg-plist
+++ b/www/node/pkg-plist
@@ -1,5 +1,37 @@
bin/node
+include/node/ares.h
+include/node/ares_version.h
+include/node/common.gypi
+include/node/config.gypi
+include/node/nameser.h
+include/node/node.h
+include/node/node_buffer.h
+include/node/node_internals.h
+include/node/node_object_wrap.h
+include/node/node_version.h
+include/node/openssl/opensslconf.h
+include/node/uv-private/ngx-queue.h
+include/node/uv-private/stdint-msvc2008.h
+include/node/uv-private/tree.h
+include/node/uv-private/uv-bsd.h
+include/node/uv-private/uv-darwin.h
+include/node/uv-private/uv-linux.h
+include/node/uv-private/uv-sunos.h
+include/node/uv-private/uv-unix.h
+include/node/uv-private/uv-win.h
+include/node/uv.h
+include/node/v8-debug.h
+include/node/v8-preparser.h
+include/node/v8-profiler.h
+include/node/v8-testing.h
+include/node/v8.h
+include/node/v8stdint.h
+include/node/zconf.h
+include/node/zlib.h
lib/dtrace/node.d
lib/node_modules/.keepme
-@dirrm lib/node_modules
-@dirrm lib/dtrace
+@dirrmtry lib/node_modules
+@dirrmtry lib/dtrace
+@dirrmtry include/node/uv-private
+@dirrmtry include/node/openssl
+@dirrmtry include/node