aboutsummaryrefslogtreecommitdiff
path: root/www/node
diff options
context:
space:
mode:
authorBradley T. Hughes <bhughes@FreeBSD.org>2021-02-04 10:52:20 +0000
committerBradley T. Hughes <bhughes@FreeBSD.org>2021-02-04 10:52:20 +0000
commitfc27e30c9c5438b23d9e182e9c8a113f7be6d757 (patch)
tree5f8cceca624474f6e9b4ef91f13c254d986c20bf /www/node
parent04c855c44fd0339de350cf8a851a456b6c6f08e8 (diff)
downloadports-fc27e30c9c5438b23d9e182e9c8a113f7be6d757.tar.gz
ports-fc27e30c9c5438b23d9e182e9c8a113f7be6d757.zip
Notes
Diffstat (limited to 'www/node')
-rw-r--r--www/node/Makefile5
-rw-r--r--www/node/distinfo6
-rw-r--r--www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi4
-rw-r--r--www/node/files/patch-node.gypi4
4 files changed, 11 insertions, 8 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index c1752eb1b9db..b7176786cffe 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -2,7 +2,7 @@
PORTNAME= node
DISTVERSIONPREFIX= v
-DISTVERSION= 15.7.0
+DISTVERSION= 15.8.0
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${DISTVERSION}/
@@ -54,6 +54,7 @@ CONFLICTS_INSTALL= node10-[0-9]* node12-[0-9]* node14-[0-9]*
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} \
--without-npm \
--shared-brotli \
+ --shared-cares \
--shared-libuv \
--shared-nghttp2 \
--shared-zlib
@@ -70,10 +71,12 @@ MAKE_ENV+= CC.host=${CC} CFLAGS.host="${CFLAGS}" \
LINK.host=${CXX} LDFLAGS.host="${LDFLAGS}"
BUILD_DEPENDS+= brotli>=1.0.9,1:archivers/brotli \
+ c-ares>=1.17.1:dns/c-ares \
libuv>=1.40.0:devel/libuv \
libnghttp2>=1.42.0:www/libnghttp2 \
objdump:devel/binutils
LIB_DEPENDS+= libbrotlidec.so:archivers/brotli \
+ libcares.so:dns/c-ares \
libuv.so:devel/libuv \
libnghttp2.so:www/libnghttp2
diff --git a/www/node/distinfo b/www/node/distinfo
index eaa68674d013..68a81014bc68 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1611782205
-SHA256 (node-v15.7.0.tar.gz) = cda67d79fe69b7a977a5b7fcb64721a68daca1fc6890368813525c8b5d349ddb
-SIZE (node-v15.7.0.tar.gz) = 62478734
+TIMESTAMP = 1612391467
+SHA256 (node-v15.8.0.tar.gz) = e08c8778a6b767cd0d2ab4613946d1616c3d4054dead08b04f705d607c84510f
+SIZE (node-v15.8.0.tar.gz) = 62019805
diff --git a/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi b/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi
index ed61fb35e52c..eecbb2c181b6 100644
--- a/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi
+++ b/www/node/files/patch-deps_openssl_config_archs_linux-elf_no-asm_openssl.gypi
@@ -1,6 +1,6 @@
---- deps/openssl/config/archs/linux-elf/no-asm/openssl.gypi.orig 2020-10-20 11:49:49 UTC
+--- deps/openssl/config/archs/linux-elf/no-asm/openssl.gypi.orig 2021-02-02 17:47:01 UTC
+++ deps/openssl/config/archs/linux-elf/no-asm/openssl.gypi
-@@ -698,7 +698,7 @@
+@@ -696,7 +696,7 @@
'-Wall -O3 -fomit-frame-pointer',
],
'openssl_ex_libs_linux-elf': [
diff --git a/www/node/files/patch-node.gypi b/www/node/files/patch-node.gypi
index 79316657cfc9..25b2bd4da45f 100644
--- a/www/node/files/patch-node.gypi
+++ b/www/node/files/patch-node.gypi
@@ -1,6 +1,6 @@
---- node.gypi.orig 2020-10-20 11:49:51 UTC
+--- node.gypi.orig 2021-02-02 17:47:04 UTC
+++ node.gypi
-@@ -340,6 +340,9 @@
+@@ -322,6 +322,9 @@
['openssl_fips != "" or openssl_is_fips=="true"', {
'defines': [ 'NODE_FIPS_MODE' ],
}],