aboutsummaryrefslogtreecommitdiff
path: root/www/node
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-17 14:13:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-05-17 14:13:18 +0000
commit0c8c44d732fac52e772705c9ea3663959efdb7c8 (patch)
tree2bb6f4c6478334fdc1223d6599a0da8b03640c48 /www/node
parent3e789a4b0497f4beb43edd3929ed601a4d3756e3 (diff)
downloadports-0c8c44d732fac52e772705c9ea3663959efdb7c8.tar.gz
ports-0c8c44d732fac52e772705c9ea3663959efdb7c8.zip
Notes
Diffstat (limited to 'www/node')
-rw-r--r--www/node/Makefile5
-rw-r--r--www/node/distinfo4
-rw-r--r--www/node/files/patch-wscript10
3 files changed, 9 insertions, 10 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 44f455724a82..7512c2285914 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= node
-PORTVERSION= 0.6.17
-PORTREVISION= 1
+PORTVERSION= 0.6.18
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -31,7 +30,7 @@ MAKE_JOBS_SAFE= yes
ONLY_FOR_ARCHS= i386 amd64
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_PYTHON= -2.7
+USE_PYTHON= 2.7
USE_OPENSSL= yes
MAN1= node.1
diff --git a/www/node/distinfo b/www/node/distinfo
index 5bcf0ca2a2c4..8dcbdc13e79b 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v0.6.17.tar.gz) = 8dfe5948de27e37a14af184f06e7bd89a23c3b248af44c8ef5cffcd0e4c65778
-SIZE (node-v0.6.17.tar.gz) = 10252898
+SHA256 (node-v0.6.18.tar.gz) = 6cf4311ecbc1700e88f4382a31b3a7017c1572cd641fd06e653fc1692c2cffff
+SIZE (node-v0.6.18.tar.gz) = 10261465
diff --git a/www/node/files/patch-wscript b/www/node/files/patch-wscript
index af47e394e24a..1a5ea060d4da 100644
--- a/www/node/files/patch-wscript
+++ b/www/node/files/patch-wscript
@@ -1,12 +1,12 @@
---- wscript.orig 2011-11-12 06:56:27.000000000 +0800
-+++ wscript 2011-11-12 22:12:23.000000000 +0800
-@@ -634,8 +634,7 @@
+--- wscript.orig 2012-05-16 13:28:07.000000000 +0800
++++ wscript 2012-05-16 13:33:24.000000000 +0800
+@@ -642,8 +642,7 @@
#
cmd = 'cp -r ' + sh_escape(srcdir) + '/* ' + sh_escape(blddir)
if not sys.platform.startswith('win32'):
- make = ('if [ -z "$NODE_MAKE" ]; then NODE_MAKE=make; fi; '
- '$NODE_MAKE -C ' + sh_escape(blddir))
+ make = 'gmake -C ' + sh_escape(blddir)
+ flags = arch_cflags(bld)
+ if flags: make += ' CFLAGS=\'%s\'' % ' '.join(flags) # don't escape
else:
- make = 'make -C ' + sh_escape(blddir)
- return '%s && (%s clean) && (%s all)' % (cmd, make, make)