aboutsummaryrefslogtreecommitdiff
path: root/www/npm
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-12-01 11:18:03 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-12-01 11:18:03 +0000
commit8664861b1a575bcf859a90c6fea2b05a1187f1f0 (patch)
tree33a19b5745c1e5e7cbfa4a5ab2c30f6971177e74 /www/npm
parent30de4c11b252c73c33417ac534886e9651b233f1 (diff)
downloadports-8664861b1a575bcf859a90c6fea2b05a1187f1f0.tar.gz
ports-8664861b1a575bcf859a90c6fea2b05a1187f1f0.zip
Notes
Diffstat (limited to 'www/npm')
-rw-r--r--www/npm/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index a4f8be5afa7b..a155dc938f9c 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -83,9 +83,9 @@ maketar: do-clean
@${REINPLACE_CMD} -e '1 s|#!/bin/bash|#!${LOCALBASE}/bin/bash|; s|${MAKE}|${GMAKE}|g; s|perl -pi|perl -p|' ${MS_WRKSRC}/${MS_DISTNAME}/scripts/doc-build.sh
@${GREP} -lr share/man ${MS_WRKSRC}/${MS_DISTNAME}/doc/ ${MS_WRKSRC}/${MS_DISTNAME}/scripts/ | ${XARGS} -I % ${REINPLACE_CMD} 's|share/man|man|g' %
@cd ${MS_WRKSRC}/${MS_DISTNAME}/ && ${GMAKE} docclean markedclean all html/doc/misc/npm-index.html
- @${FIND} ${MS_WRKSRC}/${MS_DISTNAME}/ -type d -exec ${CHMOD} 755 '{}' \;
- @${FIND} ${MS_WRKSRC}/${MS_DISTNAME}/ -type f -exec ${CHMOD} 644 '{}' \;
- @${FIND} ${MS_WRKSRC}/${MS_DISTNAME}/ -type f -name '*.sh' -exec ${CHMOD} 755 '{}' \;
+ @${FIND} ${MS_WRKSRC}/${MS_DISTNAME}/ -type d -exec ${CHMOD} 755 {} \;
+ @${FIND} ${MS_WRKSRC}/${MS_DISTNAME}/ -type f -exec ${CHMOD} 644 {} \;
+ @${FIND} ${MS_WRKSRC}/${MS_DISTNAME}/ -type f -name '*.sh' -exec ${CHMOD} 755 {} \;
@cd ${MS_WRKSRC}/ && ${TAR} -Jcf ${MS_DISTNAME}.tar.xz ${MS_DISTNAME}/
@${REINPLACE_CMD} -e '/^PORTVERSION=/ s|${PORTVERSION}|'${MS_VERSION}'|; /^PORTREVISION=/d' ${.CURDIR}/Makefile
@sudo ${INSTALL} -m 644 ${MS_WRKSRC}/${PORTNAME}-${MS_VERSION}.tar.xz ${DISTDIR}/