aboutsummaryrefslogtreecommitdiff
path: root/www/npm
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-01-19 08:36:38 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-01-19 08:36:38 +0000
commit13c1b7fca82869d9f370fa6ba6446bac2f1cae51 (patch)
treedab66eafaa6fbd3b8c485a476cf00439e0ef2f27 /www/npm
parent11dadb882d67267e5baa60f987af69774610f9c8 (diff)
downloadports-13c1b7fca82869d9f370fa6ba6446bac2f1cae51.tar.gz
ports-13c1b7fca82869d9f370fa6ba6446bac2f1cae51.zip
Notes
Diffstat (limited to 'www/npm')
-rw-r--r--www/npm/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index 5efe41b59c19..d50a23c3a09e 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -15,10 +15,13 @@ LICENSE= MIT
RUN_DEPENDS= gmake:${PORTSDIR}/devel/gmake
OPTIONS_SINGLE= BACKEND
-OPTIONS_SINGLE_BACKEND= NODE NODE_DEVEL
+OPTIONS_SINGLE_BACKEND= NODE NODE_DEVEL NODE010 NODE012 NODE4
OPTIONS_DEFAULT=NODE
NODE_DESC= Use www/node as backend
NODE_DEVEL_DESC=Use www/node-devel as backend
+NODE010_DESC= Use www/node010 as backend
+NODE012_DESC= Use www/node012 as backend
+NODE4_DESC= Use www/node4 as backend
MAKE_ARGS= npm_config_prefix=${STAGEDIR}${PREFIX}
MANPREFIX= ${PREFIX}/lib/node_modules/npm
@@ -40,6 +43,9 @@ SHEBANG_FILES= lib/utils/completion.sh \
NODE_DEVEL_RUN_DEPENDS= node-devel>=0.8.0:${PORTSDIR}/www/node-devel
NODE_RUN_DEPENDS= node>=0.8.0:${PORTSDIR}/www/node
+NODE010_RUN_DEPENDS= node010>=0.8.0:${PORTSDIR}/www/node010
+NODE012_RUN_DEPENDS= node012>=0.8.0:${PORTSDIR}/www/node012
+NODE4_RUN_DEPENDS= node4>=0.8.0:${PORTSDIR}/www/node4
.include <bsd.port.pre.mk>