aboutsummaryrefslogtreecommitdiff
path: root/www/nscache
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-07 19:59:26 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-07 19:59:26 +0000
commit89b7d2a4465628b128b8f5f7fde5f2a3e2b2a8df (patch)
treedab293772a4c12d5e7f6c0f30c1e8ae09e1cfe4d /www/nscache
parent65b63032bfb3a3f1c8ac4ee660ac83927b43c92a (diff)
downloadports-89b7d2a4465628b128b8f5f7fde5f2a3e2b2a8df.tar.gz
ports-89b7d2a4465628b128b8f5f7fde5f2a3e2b2a8df.zip
Notes
Diffstat (limited to 'www/nscache')
-rw-r--r--www/nscache/Makefile11
-rw-r--r--www/nscache/files/patch-aa21
-rw-r--r--www/nscache/files/patch-ab19
-rw-r--r--www/nscache/pkg-plist3
4 files changed, 43 insertions, 11 deletions
diff --git a/www/nscache/Makefile b/www/nscache/Makefile
index 03c547ccb6b3..dd7f0f8c6434 100644
--- a/www/nscache/Makefile
+++ b/www/nscache/Makefile
@@ -16,6 +16,15 @@ MAINTAINER= kris@FreeBSD.org
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-USE_AUTOCONF= yes
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_AUTOMAKE= yes
+AUTOMAKE= automake -a -i
+CONFIGURE_ENV= CPPFALGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-configure:
+ @cd ${WRKSRC}; aclocal -I ${X11BASE}/share/aclocal
.include <bsd.port.mk>
diff --git a/www/nscache/files/patch-aa b/www/nscache/files/patch-aa
index 9730c34de154..dac7af60e7bc 100644
--- a/www/nscache/files/patch-aa
+++ b/www/nscache/files/patch-aa
@@ -1,6 +1,6 @@
---- configure.in.orig Sat Jan 15 09:40:55 2000
-+++ configure.in Sun Mar 5 02:00:42 2000
-@@ -41,14 +41,14 @@
+--- configure.in.orig Sun Jan 16 02:40:55 2000
++++ configure.in Sat Jul 1 19:10:54 2000
+@@ -41,17 +41,11 @@
AC_CHECK_LIB(c, gettext, CFLAGS="$CFLAGS -DHAVE_GETTEXT -DNLS_DIR=\"\\\"\$(prefix)/share/locale\\\"\"";MSUBDIRS="po", AC_CHECK_LIB(intl, gettext, LIBS="$LIBS -lintl";CFLAGS="$CFLAGS -DHAVE_GETTEXT -DNLS_DIR=\"\\\"\$(prefix)/share/locale\\\"\"";MSUBDIRS="po"))
@@ -10,12 +10,13 @@
AC_CHECK_HEADER(db1/db.h, CFLAGS="$CFLAGS -DHAVE_DB1_H", AC_CHECK_HEADER(db.h, CFLAGS="$CFLAGS -DHAVE_DB_H"))
-AC_CHECK_PROG(GTK_CONFIG, gtk-config, "yes", "no")
-+AC_CHECK_PROG(GTK_CONFIG, gtk12-config, "yes", "no")
- if eval "test x$GTK_CONFIG = xyes"; then
+-if eval "test x$GTK_CONFIG = xyes"; then
- CFLAGS="$CFLAGS `gtk-config --cflags`"
- LIBS="$LIBS `gtk-config --libs`"
-+ CFLAGS="$CFLAGS `gtk12-config --cflags`"
-+ LIBS="$LIBS `gtk12-config --libs`"
- else
- AC_MSG_ERROR("Unable to find \"gtk-config\" program")
- fi
+-else
+- AC_MSG_ERROR("Unable to find \"gtk-config\" program")
+-fi
++AM_PATH_GTK(1.2.0, , AC_MSG_ERROR(GTK+ is not installed or badly configured on your system...))
+
+ AC_SUBST(CFLAGS)
+ AC_SUBST(LIBS)
diff --git a/www/nscache/files/patch-ab b/www/nscache/files/patch-ab
new file mode 100644
index 000000000000..25f015017a95
--- /dev/null
+++ b/www/nscache/files/patch-ab
@@ -0,0 +1,19 @@
+--- Makefile.am.orig Tue Jan 18 04:49:06 2000
++++ Makefile.am Sat Jul 1 20:03:06 2000
+@@ -1,5 +1,7 @@
+ SUBDIRS = @MSUBDIRS@
+
++INCLUDES = $(GTK_CFLAGS)
++
+ bin_PROGRAMS = nscache
+
+ nscache_SOURCES = \
+@@ -12,6 +14,8 @@
+ indexdb.h \
+ nls.h \
+ setup.c
++
++nscache_LDADD = $(GTK_LIBS)
+
+ nscache.pot: $(nscache_SOURCES)
+ xgettext --default-domain=nscache -n -E -o $@ $(nscache_SOURCES)
diff --git a/www/nscache/pkg-plist b/www/nscache/pkg-plist
index 35dec41d2145..1e2f9a732f1c 100644
--- a/www/nscache/pkg-plist
+++ b/www/nscache/pkg-plist
@@ -1 +1,4 @@
bin/nscache
+share/locale/de/LC_MESSAGES/nscache.mo
+share/locale/it/LC_MESSAGES/nscache.mo
+share/locale/sk/LC_MESSAGES/nscache.mo