aboutsummaryrefslogtreecommitdiff
path: root/www/nspluginwrapper-devel
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2010-08-23 21:52:39 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2010-08-23 21:52:39 +0000
commit1ebfc2aa84ad7d96bc96ff371bda621db3323cf4 (patch)
tree9af19a34a1287a1c24c431bdd12764027dc16d14 /www/nspluginwrapper-devel
parentdfb01be5e62fc2673b41d82a4d094f300c4b3c8a (diff)
downloadports-1ebfc2aa84ad7d96bc96ff371bda621db3323cf4.tar.gz
ports-1ebfc2aa84ad7d96bc96ff371bda621db3323cf4.zip
Notes
Diffstat (limited to 'www/nspluginwrapper-devel')
-rw-r--r--www/nspluginwrapper-devel/Makefile21
-rw-r--r--www/nspluginwrapper-devel/distinfo6
-rw-r--r--www/nspluginwrapper-devel/files/npviewer.in5
-rw-r--r--www/nspluginwrapper-devel/files/patch-NPNVprivateModeBool43
-rw-r--r--www/nspluginwrapper-devel/files/patch-ulimit7
5 files changed, 60 insertions, 22 deletions
diff --git a/www/nspluginwrapper-devel/Makefile b/www/nspluginwrapper-devel/Makefile
index 32a905e5df3c..e2fb117a4ea5 100644
--- a/www/nspluginwrapper-devel/Makefile
+++ b/www/nspluginwrapper-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nspluginwrapper
PORTVERSION= 1.3.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www linux emulators
MASTER_SITES= LOCAL/jkim
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${BINFILE}${EXTRACT_SUFX}
@@ -21,7 +21,7 @@ LATEST_LINK= ${PORTNAME}-devel
CONFLICTS= nspluginwrapper-1.2.*
-BINFILE= ${PORTNAME}-i386-${PORTVERSION}-2
+BINFILE= ${PORTNAME}-i386-${PORTVERSION}-3
ONLY_FOR_ARCHS= i386 amd64
@@ -46,6 +46,9 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
PLIST_SUB= LIBDIR="${LIBDIR:C/^${PREFIX}\///}" HOST_ARCH="${HOST_ARCH}"
+SUB_FILES= npviewer
+SUB_LIST+= NSPLUGINWRAPPER="${LIBDIR}"
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
@@ -54,22 +57,16 @@ HOST_ARCH= x86_64
HOST_ARCH= ${ARCH}
.endif
-# We must manually extract, modify, and install the Linux version of npviewer.
-post-extract:
- ${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' \
- ${WRKDIR}/usr/lib/nspluginwrapper/i386/linux/npviewer
- @${RM} ${WRKDIR}/usr/lib/nspluginwrapper/i386/linux/npviewer.bak
- @${MV} ${WRKDIR}/usr ${WRKSRC}
-
post-patch:
${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' \
${WRKSRC}/src/npw-config.c
- @${RM} ${WRKSRC}/usr/lib/nspluginwrapper/i386/linux/npviewer.orig
post-install:
${MKDIR} ${LIBDIR}/i386/linux
- ${INSTALL_SCRIPT} ${WRKSRC}/usr/lib/nspluginwrapper/i386/linux/* \
- ${LIBDIR}/i386/linux/
+ ${INSTALL_PROGRAM} ${WRKDIR}/usr/lib/nspluginwrapper/i386/linux/*.bin \
+ ${WRKDIR}/usr/lib/nspluginwrapper/i386/linux/*.so \
+ ${LIBDIR}/i386/linux/
+ ${INSTALL_SCRIPT} ${WRKDIR}/npviewer ${LIBDIR}/i386/linux/
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/nspluginwrapper-devel/distinfo b/www/nspluginwrapper-devel/distinfo
index e5a5d80b645c..d660c9fb3c8e 100644
--- a/www/nspluginwrapper-devel/distinfo
+++ b/www/nspluginwrapper-devel/distinfo
@@ -1,6 +1,6 @@
MD5 (nspluginwrapper-1.3.0.tar.bz2) = 188f77bd3427c131ccba4bfdb25892a9
SHA256 (nspluginwrapper-1.3.0.tar.bz2) = b8900bd5f0bd950f95b963e5c8f5e20d7d15cc70e777b6058289687ad968b21c
SIZE (nspluginwrapper-1.3.0.tar.bz2) = 336049
-MD5 (nspluginwrapper-i386-1.3.0-2.tar.bz2) = b36157756e1d51010a27b3667be8999b
-SHA256 (nspluginwrapper-i386-1.3.0-2.tar.bz2) = d807c161ffe64689d50f49dc1212c6aadf556b928c26884d7f444fddb4e8eb73
-SIZE (nspluginwrapper-i386-1.3.0-2.tar.bz2) = 63613
+MD5 (nspluginwrapper-i386-1.3.0-3.tar.bz2) = 02b0b2628509b01a409c83fa2d5e0224
+SHA256 (nspluginwrapper-i386-1.3.0-3.tar.bz2) = 61c5a0920549e9998d9a210820217cea684f16413ac82e2929d2abfcdc4c2789
+SIZE (nspluginwrapper-i386-1.3.0-3.tar.bz2) = 62053
diff --git a/www/nspluginwrapper-devel/files/npviewer.in b/www/nspluginwrapper-devel/files/npviewer.in
new file mode 100644
index 000000000000..faff54f180ca
--- /dev/null
+++ b/www/nspluginwrapper-devel/files/npviewer.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+TARGET_OS=linux
+TARGET_ARCH=i386
+ulimit -s 32768 2>/dev/null
+. %%NSPLUGINWRAPPER%%/noarch/npviewer.sh
diff --git a/www/nspluginwrapper-devel/files/patch-NPNVprivateModeBool b/www/nspluginwrapper-devel/files/patch-NPNVprivateModeBool
new file mode 100644
index 000000000000..5dfefabd59ff
--- /dev/null
+++ b/www/nspluginwrapper-devel/files/patch-NPNVprivateModeBool
@@ -0,0 +1,43 @@
+--- npapi/npapi.h 2009-01-02 09:22:28.000000000 -0500
++++ npapi/npapi.h 2010-08-18 19:07:09.000000000 -0400
+@@ -439,7 +439,9 @@ typedef enum {
+ /* Get the NPObject wrapper for the plugins DOM element. */
+ NPNVPluginElementNPObject = 16,
+
+- NPNVSupportsWindowless = 17
++ NPNVSupportsWindowless = 17,
++
++ NPNVprivateModeBool = 18
+
+ } NPNVariable;
+
+--- src/npw-rpc.c 2010-08-18 19:10:19.000000000 -0400
++++ src/npw-rpc.c 2010-08-18 19:08:24.000000000 -0400
+@@ -41,6 +41,7 @@ int rpc_type_of_NPNVariable(int variable
+ case NPNVisOfflineBool:
+ case NPNVSupportsXEmbedBool:
+ case NPNVSupportsWindowless:
++ case NPNVprivateModeBool:
+ type = RPC_TYPE_BOOLEAN;
+ break;
+ case NPNVToolkit:
+--- src/npw-viewer.c 2010-08-18 19:10:19.000000000 -0400
++++ src/npw-viewer.c 2010-08-18 19:05:46.000000000 -0400
+@@ -1266,6 +1266,7 @@ g_NPN_GetValue(NPP instance, NPNVariable
+ case NPNVSupportsXEmbedBool:
+ case NPNVWindowNPObject:
+ case NPNVPluginElementNPObject:
++ case NPNVprivateModeBool:
+ return g_NPN_GetValue_real(instance, variable, value);
+ default:
+ switch (variable & 0xff) {
+--- src/utils.c 2009-01-02 09:22:29.000000000 -0500
++++ src/utils.c 2010-08-18 19:09:31.000000000 -0400
+@@ -283,6 +283,7 @@ const char *string_of_NPNVariable(int va
+ _(NPNVWindowNPObject);
+ _(NPNVPluginElementNPObject);
+ _(NPNVSupportsWindowless);
++ _(NPNVprivateModeBool);
+ #undef _
+ default:
+ switch (variable & 0xff) {
diff --git a/www/nspluginwrapper-devel/files/patch-ulimit b/www/nspluginwrapper-devel/files/patch-ulimit
deleted file mode 100644
index a372ddb4e8ec..000000000000
--- a/www/nspluginwrapper-devel/files/patch-ulimit
+++ /dev/null
@@ -1,7 +0,0 @@
-Index: usr/lib/nspluginwrapper/i386/linux/npviewer
-@@ -1,4 +1,5 @@
- #!/bin/sh
- TARGET_OS=linux
- TARGET_ARCH=i386
-+ulimit -s 32768 2>/dev/null
- . /usr/local/lib/nspluginwrapper/noarch/npviewer