aboutsummaryrefslogtreecommitdiff
path: root/www/nspluginwrapper/Makefile
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2017-02-16 18:46:10 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2017-02-16 18:46:10 +0000
commitbac66e9429ec8315cebf193f304970699870a98b (patch)
tree6118f2789ed50a220930527dbebea3a8c5b16ffb /www/nspluginwrapper/Makefile
parenta380af10bbb5ad120bc8553765c37eff6d1228e8 (diff)
downloadports-bac66e9429ec8315cebf193f304970699870a98b.tar.gz
ports-bac66e9429ec8315cebf193f304970699870a98b.zip
Notes
Diffstat (limited to 'www/nspluginwrapper/Makefile')
-rw-r--r--www/nspluginwrapper/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/www/nspluginwrapper/Makefile b/www/nspluginwrapper/Makefile
index 8c222756289d..8267c65f7340 100644
--- a/www/nspluginwrapper/Makefile
+++ b/www/nspluginwrapper/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nspluginwrapper
PORTVERSION= 1.4.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www linux emulators
MASTER_SITES= http://nspluginwrapper.org/download/ \
LOCAL/jkim \
@@ -35,24 +35,17 @@ USE_XORG= x11 xext xt
CFLAGS+= -std=c99
CONFIGURE_ARGS= --enable-generic --enable-strip --prefix=${PREFIX} \
- --target-os=linux --target-cpu=i386 \
+ --target-cpu=i386 --target-os=linux \
--with-cc=${CC} --with-cxx=${CXX}
LIBDIR= ${PREFIX}/lib/${PORTNAME}
LINUX_BINDIR= usr/lib/nspluginwrapper/i386/linux
-PLIST_SUB= LIBDIR="${LIBDIR:C/^${PREFIX}\///}" HOST_ARCH="${HOST_ARCH}"
+PLIST_SUB= HOST_ARCH="${ARCH:S/amd64/x86_64/}" \
+ LIBDIR="${LIBDIR:C/^${PREFIX}\///}"
SUB_FILES= npviewer
-SUB_LIST+= NSPLUGINWRAPPER="${LIBDIR}"
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-HOST_ARCH= x86_64
-.else
-HOST_ARCH= ${ARCH}
-.endif
+SUB_LIST= NSPLUGINWRAPPER="${LIBDIR}"
post-patch:
${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
@@ -66,4 +59,4 @@ post-install:
${WRKDIR}/${LINUX_BINDIR}/*.so ${STAGEDIR}${LIBDIR}/i386/linux/
${INSTALL_SCRIPT} ${WRKDIR}/npviewer ${STAGEDIR}${LIBDIR}/i386/linux/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>