aboutsummaryrefslogtreecommitdiff
path: root/www/nspluginwrapper/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /www/nspluginwrapper/Makefile
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'www/nspluginwrapper/Makefile')
-rw-r--r--www/nspluginwrapper/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/nspluginwrapper/Makefile b/www/nspluginwrapper/Makefile
index cbed28ce019a..5d2e9892a45a 100644
--- a/www/nspluginwrapper/Makefile
+++ b/www/nspluginwrapper/Makefile
@@ -34,7 +34,7 @@ USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --target-os=linux --target-cpu=i386 \
- --with-x11-prefix=${X11BASE} --with-cc=${CC} --with-cxx=${CXX}
+ --with-x11-prefix=${LOCALBASE} --with-cc=${CC} --with-cxx=${CXX}
LIBDIR= ${PREFIX}/lib/${PORTNAME}
@@ -49,7 +49,7 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's,x86_64,amd64,g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' ${WRKSRC}/configure
post-install:
${MKDIR} ${LIBDIR}/i386/linux
@@ -60,7 +60,7 @@ post-install:
.include <bsd.port.pre.mk>
# XXX switch to USE_XORG once XFree86-4 is removed
-BUILD_DEPENDS+= ${X11BASE}/libdata/xorg/libraries:${X_LIBRARIES_PORT}
-RUN_DEPENDS+= ${X11BASE}/libdata/xorg/libraries:${X_LIBRARIES_PORT}
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/xorg/libraries:${X_LIBRARIES_PORT}
+RUN_DEPENDS+= ${LOCALBASE}/libdata/xorg/libraries:${X_LIBRARIES_PORT}
.include <bsd.port.post.mk>