aboutsummaryrefslogtreecommitdiff
path: root/www/ocaml-wdialog/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-11 00:06:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-11 00:06:53 +0000
commit516175f87b7a3b01e6cae4823bfbe754a264beae (patch)
treeaff46fa5c2bd3ee64b7a26ba8f6e399ba833331f /www/ocaml-wdialog/Makefile
parent6a3b34bf28277c7db739da3aee2f4d182aadb969 (diff)
downloadports-516175f87b7a3b01e6cae4823bfbe754a264beae.tar.gz
ports-516175f87b7a3b01e6cae4823bfbe754a264beae.zip
Notes
Diffstat (limited to 'www/ocaml-wdialog/Makefile')
-rw-r--r--www/ocaml-wdialog/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/www/ocaml-wdialog/Makefile b/www/ocaml-wdialog/Makefile
index 8f810e22168e..bbd33cae405b 100644
--- a/www/ocaml-wdialog/Makefile
+++ b/www/ocaml-wdialog/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wdialog
-PORTVERSION= 2.0.2
+PORTVERSION= 2.1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wdialog
@@ -18,12 +18,16 @@ COMMENT= Advanced system to create dialog-centric web applications
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
- ${LOCALBASE}/lib/ocaml/site-lib/pxp-engine/pxp_engine.a:${PORTSDIR}/textproc/ocaml-pxp
-RUN_DEPENDS= ${LOCALBASE}/lib/ocaml/site-lib/pxp-engine/pxp_engine.a:${PORTSDIR}/textproc/ocaml-pxp
+ ${LOCALBASE}/lib/ocaml/site-lib/pxp-engine/pxp_engine.a:${PORTSDIR}/textproc/ocaml-pxp \
+ ${LOCALBASE}/lib/ocaml/site-lib/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex
+RUN_DEPENDS= ${LOCALBASE}/lib/ocaml/site-lib/pxp-engine/pxp_engine.a:${PORTSDIR}/textproc/ocaml-pxp \
+ ${LOCALBASE}/lib/ocaml/site-lib/ulex/ulexing.a:${PORTSDIR}/devel/ocaml-ulex
USE_GMAKE= yes
HAS_CONFIGURE= yes
+# Ocaml RPC port is not available for now, so we can't have the session daemon support
+CONFIGURE_ARGS+= -without-wd-session-daemon
ALL_TARGET= all opt