aboutsummaryrefslogtreecommitdiff
path: root/www/ocsigen
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 10:01:59 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 10:01:59 +0000
commit8a51784050c568375753e5dca2173d7f8f1b3eb6 (patch)
treea09a16b1600a6515e11db81862fcd0fe5c5afc97 /www/ocsigen
parent1049b2122eb03747cff97e5cd116cde947a1ffc7 (diff)
downloadports-8a51784050c568375753e5dca2173d7f8f1b3eb6.tar.gz
ports-8a51784050c568375753e5dca2173d7f8f1b3eb6.zip
Notes
Diffstat (limited to 'www/ocsigen')
-rw-r--r--www/ocsigen/Makefile31
1 files changed, 15 insertions, 16 deletions
diff --git a/www/ocsigen/Makefile b/www/ocsigen/Makefile
index 8934dbed6a26..db74236783b5 100644
--- a/www/ocsigen/Makefile
+++ b/www/ocsigen/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: ocsigen
-# Date created: March 14, 2007
-# Whom: Jaap Boender <jaapb@kerguelen.org>
-#
+# Created by: Jaap Boender <jaapb@kerguelen.org>
# $FreeBSD$
PORTNAME= ocsigen
@@ -29,8 +26,9 @@ USE_OCAML_LDCONFIG= yes
SA_DIR= ${PREFIX}/${OCAML_SITELIBDIR}
-OPTIONS= SQLITE "Use sqlite as a database backend" OFF \
- CAMLZIP "Use camlzip for compression" ON
+OPTIONS_DEFINE= SQLITE CAMLZIP
+OPTIONS_DEFAULT= CAMLZIP
+CAMLZIP_DESC= Use camlzip for compression
USE_GMAKE= yes
HAS_CONFIGURE= yes
@@ -50,16 +48,17 @@ CONFIGURE_ARGS= --name ${PORTNAME} \
ALL_TARGET= depend all
INSTALL_TARGET= installnodoc
-.if !defined(NOPORTDOCS)
-INSTALL_TARGET+= docinstall
-PORTDOCS= *
-.endif
MAN1= ocsigen.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_SQLITE)
+.if ${PORT_OPTIONS:MDOCS}
+INSTALL_TARGET+= docinstall
+PORTDOCS= *
+.endif
+
+.if ${PORT_OPTIONS:MSQLITE}
BUILD_DEPENDS+= ${SA_DIR}/sqlite3/sqlite3.a:${PORTSDIR}/databases/ocaml-sqlite3
RUN_DEPENDS+= ${SA_DIR}/sqlite3/sqlite3.a:${PORTSDIR}/databases/ocaml-sqlite3
CONFIGURE_ARGS+= --enable-sqlite
@@ -68,13 +67,13 @@ PLIST_FILES+= lib/ocsigen/extensions/ocsipersist-sqlite.cma
CONFIGURE_ARGS+= --disable-sqlite
.endif
-.if defined(WITHOUT_CAMLZIP)
-CONFIGURE_ARGS+= --disable-camlzip
-.else
+.if ${PORT_OPTIONS:MCAMLZIP}
CONFIGURE_ARGS+= --enable-camlzip
BUILD_DEPENDS+= ocaml-zip>=1.03_2:${PORTSDIR}/archivers/ocaml-zip
RUN_DEPENDS+= ocaml-zip>=1.03_2:${PORTSDIR}/archivers/ocaml-zip
PLIST_FILES+= lib/ocsigen/extensions/deflatemod.cmo
+.else
+CONFIGURE_ARGS+= --disable-camlzip
.endif
post-install:
@@ -83,4 +82,4 @@ post-install:
${PREFIX}/etc/${PORTNAME}/ocsigen.conf; \
fi
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>