aboutsummaryrefslogtreecommitdiff
path: root/www/onionbalance
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2019-01-05 13:35:00 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2019-01-05 13:35:00 +0000
commita367da3c7a47b3619eb053347ba5d02d01355bb8 (patch)
treeaf84fdb109135569ac4255b5eb710fe616641a03 /www/onionbalance
parentd3d8deecb45aeca620263abd904c06a3d8679d1d (diff)
downloadports-a367da3c7a47b3619eb053347ba5d02d01355bb8.tar.gz
ports-a367da3c7a47b3619eb053347ba5d02d01355bb8.zip
Notes
Diffstat (limited to 'www/onionbalance')
-rw-r--r--www/onionbalance/Makefile27
-rw-r--r--www/onionbalance/distinfo3
-rw-r--r--www/onionbalance/pkg-descr6
3 files changed, 36 insertions, 0 deletions
diff --git a/www/onionbalance/Makefile b/www/onionbalance/Makefile
new file mode 100644
index 000000000000..c9c0058be495
--- /dev/null
+++ b/www/onionbalance/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= onionbalance
+PORTVERSION= 0.1.8
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= OnionBalance-${PORTVERSION}
+
+MAINTAINER= egypcio@FreeBSD.org
+COMMENT= Load-balancing and Redundancy for Onion Services
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyaml>=0:textproc/py-pyaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>=0:security/py-pycrypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setproctitle>=0:devel/py-setproctitle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}stem>=0:security/py-stem@${PY_FLAVOR} \
+ tor:security/tor
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/www/onionbalance/distinfo b/www/onionbalance/distinfo
new file mode 100644
index 000000000000..45da329ced9e
--- /dev/null
+++ b/www/onionbalance/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1546352794
+SHA256 (OnionBalance-0.1.8.tar.gz) = 63a989c08aa10b41cd0edef5fd0b00c3251689d59bad8b88875078f68f03e78c
+SIZE (OnionBalance-0.1.8.tar.gz) = 55919
diff --git a/www/onionbalance/pkg-descr b/www/onionbalance/pkg-descr
new file mode 100644
index 000000000000..fc548a5e1844
--- /dev/null
+++ b/www/onionbalance/pkg-descr
@@ -0,0 +1,6 @@
+The OnionBalance software allows for Tor onion service requests to be
+distributed across multiple backend Tor instances. OnionBalance provides
+load-balancing while also making onion services more resilient and
+reliable by eliminating single points-of-failure.
+
+WWW: https://onionbalance.readthedocs.io/