aboutsummaryrefslogtreecommitdiff
path: root/www/oops/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-30 21:20:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-30 21:20:39 +0000
commit6cfc4afaa684c16e036e23f7a9e3081fe6be473a (patch)
tree8aa6618618cc318ff669fff612856b62276e5e59 /www/oops/Makefile
parent9fa2ebb975604ea1cc2144be4d56b70d646fd2da (diff)
downloadports-6cfc4afaa684c16e036e23f7a9e3081fe6be473a.tar.gz
ports-6cfc4afaa684c16e036e23f7a9e3081fe6be473a.zip
Notes
Diffstat (limited to 'www/oops/Makefile')
-rw-r--r--www/oops/Makefile46
1 files changed, 34 insertions, 12 deletions
diff --git a/www/oops/Makefile b/www/oops/Makefile
index dd873155f643..b14b6d9b58b2 100644
--- a/www/oops/Makefile
+++ b/www/oops/Makefile
@@ -7,7 +7,7 @@
PORTNAME= oops
PORTVERSION= ${OOPSVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://oops-cache.org/
DISTNAME= ${PORTNAME}-${OOPSVERSION}
@@ -36,24 +36,48 @@ MAN8= oops.8 oopsctl.8
OOPSVAR= /var/run/oops
OOPSLOG= /var/log/oops
-SCRIPTS_ENV+= WRKDIRPREFIX="${WRKDIRPREFIX}" \
- TOUCH="${TOUCH}" \
- MKDIR="${MKDIR}"
-
USE_RC_SUBR= YES
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
-.if defined(BATCH)
+OPTIONS= GIGABASE "GigaBase storage" on \
+ DB4 "Berkeley DB v4 storage" off \
+ MYSQL "MySQL auth support" off \
+ PGSQL "PostgreSQL auth support" off \
+ PCRE "PCRE support" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GIGABASE)
+.if defined (WITH_DB4)
+BROKEN= "Only one DB storage can be used (First)"
+.endif
LIB_DEPENDS+= gigabase_r.2:${PORTSDIR}/databases/gigabase
CONFIGURE_ARGS+= --without-DB
.endif
-pre-fetch:
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure.oops
+.if defined(WITH_DB4)
+.if defined(WITHOUT_GIGABASE)
+LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
+CONFIGURE_ARGS+= --without-GB
+.else
+BROKEN= "Only one DB storage can be used"
+.endif
+.endif
-.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
-.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
+.if defined(WITH_MYSQL)
+USE_MYSQL= YES
+CONFIGURE_ARGS+= --with-MYSQL=${PREFIX}
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PGSQL= YES
+CONFIGURE_ARGS+= --with-PGSQL=${PREFIX}/pgsql
+.endif
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+= --with-regexp=pcre
.endif
pre-configure:
@@ -66,8 +90,6 @@ post-build:
pre-install:
@PKG_PREFIX=${PREFIX} BATCH=${BATCH} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-.include <bsd.port.pre.mk>
-
post-install:
.if !defined(NOPORTDOCS)
@${INSTALL_MAN} ${WRKSRC}/doc/oops.8 ${PREFIX}/man/man8