aboutsummaryrefslogtreecommitdiff
path: root/www/opera
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-12-15 11:45:19 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-12-15 11:45:19 +0000
commitbb55e69f2ae626c16a272cd62bcf08b152eec2bc (patch)
tree78ada88e884faf2692a6aa7619243a447824e9ec /www/opera
parentb4a3a77daaf718ab8b232d19fa506a8eee497cde (diff)
downloadports-bb55e69f2ae626c16a272cd62bcf08b152eec2bc.tar.gz
ports-bb55e69f2ae626c16a272cd62bcf08b152eec2bc.zip
Notes
Diffstat (limited to 'www/opera')
-rw-r--r--www/opera/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/www/opera/Makefile b/www/opera/Makefile
index 720afde46aa9..8dfd6a191f3c 100644
--- a/www/opera/Makefile
+++ b/www/opera/Makefile
@@ -16,8 +16,8 @@ DISTNAME= ${PORTNAME}-${OPERA_VER}-${OPERA_BUILD}.${ARCH}.freebsd
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Blazingly fast, full-featured, standards-compliant browser
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
BUILD_DEPENDS= ${LOCALBASE}/bin/update-mime-database:${PORTSDIR}/misc/shared-mime-info
RUN_DEPENDS= ${LOCALBASE}/bin/update-mime-database:${PORTSDIR}/misc/shared-mime-info
@@ -27,9 +27,9 @@ OPERA_VER?= 12.16
OPERA_BUILD?= 1860
MASTER_SITES_VER_PATH= unix/${OPERA_VER:S/.//}
+USES= desktop-file-utils
USE_XZ= yes
USE_XORG= x11 xext sm ice xft xrender
-USE_GNOME= desktopfileutils
INSTALLS_ICONS= yes
MAN1= opera.1
@@ -38,11 +38,15 @@ MANCOMPRESSED= yes
NO_BUILD= yes
EXPLICIT_PACKAGE_DEPENDS= yes
-OPTIONS_DEFINE= CUPS VIDEO GTK2 KDE4
+OPTIONS_DEFINE= CUPS VIDEO GTK2 KDE4 COMPAT9
OPTIONS_DEFAULT= CUPS VIDEO
+NO_OPTIONS_SORT=yes
CUPS_DESC= support for printing (requires CUPS)
VIDEO_DESC= support for HTML5 video (requires GStreamer)
+COMPAT9_DESC= use libstdc++.so.6 from compat9x instead of gcc46
+
+CUPS_LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
.include <bsd.port.options.mk>
@@ -57,10 +61,6 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
.endif
.endif
-.if ${PORT_OPTIONS:MCUPS}
-LIB_DEPENDS+= cups:${PORTSDIR}/print/cups-client
-.endif
-
.if ${PORT_OPTIONS:MVIDEO}
USE_GSTREAMER+= vorbis ogg theora vp8 good
.endif
@@ -84,7 +84,11 @@ IGNORE= only for FreeBSD 7.x and higher
.endif
.if ${OSVERSION} >= 1000054
+.if ${PORT_OPTIONS:MCOMPAT9}
RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:${PORTSDIR}/misc/compat9x
+.else
+RUN_DEPENDS+= ${LOCALBASE}/lib/gcc46/libstdc++.so.6:${PORTSDIR}/lang/gcc46
+.endif
.endif
post-extract: