aboutsummaryrefslogtreecommitdiff
path: root/www/orion
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-05-17 13:42:10 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-05-17 13:42:10 +0000
commit6e65268427f35d7ae35e02fb0ec7c60036f1b884 (patch)
tree8b1cda63f84e55096d2f1b3a75f955dff7bed557 /www/orion
parentb22c4e2030f8ebe38781d3a1ce7ef487d469e470 (diff)
downloadports-6e65268427f35d7ae35e02fb0ec7c60036f1b884.tar.gz
ports-6e65268427f35d7ae35e02fb0ec7c60036f1b884.zip
Notes
Diffstat (limited to 'www/orion')
-rw-r--r--www/orion/Makefile51
-rw-r--r--www/orion/files/orionctl33
-rw-r--r--www/orion/pkg-descr4
-rw-r--r--www/orion/pkg-plist2
4 files changed, 65 insertions, 25 deletions
diff --git a/www/orion/Makefile b/www/orion/Makefile
index fc21fb278311..27fea5e00404 100644
--- a/www/orion/Makefile
+++ b/www/orion/Makefile
@@ -7,13 +7,13 @@
PORTNAME= orion
PORTVERSION= 1.4.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java www
MASTER_SITES= ftp://ftp.sunet.se/pub/database/utils/orionserver/ \
- http://www.jollem.com/
+ http://www.jollem.com/ \
+ http://www.sebster.com/~elvis/
DISTNAME= ${PORTNAME}${PORTVERSION}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- orion.sh${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ernst@jollem.com
@@ -26,6 +26,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
ORION_DESTDIR= ${PREFIX}/${DISTNAME}
ORION_LINKDIR= ${PREFIX}/${PORTNAME}
PORTTITLE= Orion Server
+ORIONCTL_NAME= orionctl
+ORIONCTL_DEST= ${PREFIX}/bin/${ORIONCTL_NAME}
RC_SCRIPT= ${PREFIX}/etc/rc.d/${PORTNAME}.sh
.include <bsd.port.pre.mk>
@@ -35,28 +37,33 @@ do-install:
${ECHO} "ERROR: The destination directory ${ORION_DESTDIR} already exists. Cancelling."; \
exit 65; \
fi
- @if [ -L ${ORION_LINKDIR} ]; then \
- ${ECHO} "WARNING: The link ${ORION_LINKDIR} already exists. Overwriting."; \
- /bin/ls -ld ${ORION_LINKDIR}; \
- else \
- if [ -e ${ORION_LINKDIR} ]; then \
- ${ECHO} "ERROR: ${ORION_LINKDIR} already exists, and it's not a symlink. Cancelling."; \
- /bin/ls -ld ${ORION_LINKDIR}; \
- exit 66; \
- fi; \
- fi
- @if [ -e ${ORION_LINKDIR} ]; then \
- ${ECHO} "WARNING: ${RC_SCRIPT} already exists. Overwriting."; \
- fi
@${MKDIR} ${ORION_DESTDIR}
@${CP} -R ${WRKSRC}/* ${ORION_DESTDIR}
- @${CP} ${WRKDIR}/orion.sh ${RC_SCRIPT}
- @if [ -e ${ORION_LINKDIR} ]; then \
- ${RM} ${ORION_LINKDIR}; \
- fi
- @${LN} -sf ${ORION_DESTDIR} ${ORION_LINKDIR}
+ @${CHMOD} 755 `find ${ORION_DESTDIR} -type d`
+ @${CP} ${FILESDIR}/${ORIONCTL_NAME} ${ORIONCTL_DEST}
+ @${CHMOD} 755 ${ORIONCTL_DEST}
+ @${LN} -s ${ORIONCTL_DEST} ${RC_SCRIPT}
post-install:
@echo "${PORTTITLE} ${PORTVERSION} has been installed in ${ORION_DESTDIR}."
.include <bsd.port.post.mk>
+
+
+# Portrevision from 1 to 2 (version is still 1.4.5)
+# Changed reference to linux-jdk1.2.2 into linux-jdk1.3.0 in the shell script,
+# since the port depends on linux-jdk1.3.0.
+# Fixed a few typos and other issues in the shell script
+# No longer installing a link from ${PREFIX}/orion -> ${PREFIX}/orion1.4.5
+# Making all directories under ${PREFIX}/orion1.4.5 a+x
+# Added one mirror site for the DISTFILE
+# Renamed shell script from `orion.sh' to `orionctl' (similar to `apachectl')
+# Installing the shell script in the ${PREFIX}/bin/ directory and symlinking
+# from ${PREFIX}/etc/rc.d/orion.sh to the former file, making sure that the
+# shell script is +x
+# Including the shell script in ${FILESDIR} instead of downloading
+
+# TODO: Create a new account for Orion so it won't run as root
+# TODO: Support restarting Orion with the shell script script
+# TODO: Support obtaining status info from a running Orion instance
+# TODO: Add a man page for `orionctl'
diff --git a/www/orion/files/orionctl b/www/orion/files/orionctl
new file mode 100644
index 000000000000..a8d258c30470
--- /dev/null
+++ b/www/orion/files/orionctl
@@ -0,0 +1,33 @@
+#!/bin/sh
+
+if [ "${LOCALBASE}a" = "a" ]; then
+ LOCALBASE=/usr/local
+fi
+
+JAVA_HOME=${LOCALBASE}/linux-jdk1.2.2
+ORION_HOME=${LOCALBASE}/orion
+LOG=${ORION_HOME}/log/orion.log
+PID_FILE=/var/run/orion.pid
+
+case "$1" in
+ start)
+ if [ -r ${ORION_HOME}/orion.jar ]; then
+ rm -rf ${PID_FILE}
+ touch ${PID_FILE}
+ chown root:wheel ${PID_FILE}
+ chmod 600 ${PID_FILE}
+ echo -n ' orion'
+ ( cd ${ORION_HOME} && ${JAVA_HOME}/bin/java -jar orion.jar & echo $! > ${PID_FILE} ) > ${LOG} 2>&1
+ fi
+ ;;
+ stop)
+ /bin/kill `cat ${PID_FILE}`
+ echo -n ' orion'
+ ;;
+ *)
+ echo ""
+ echo "Usage: `basename $0` { start | stop }"
+ echo ""
+ exit 64
+ ;;
+esac
diff --git a/www/orion/pkg-descr b/www/orion/pkg-descr
index d8abf3efa7a9..e7149bb25c8e 100644
--- a/www/orion/pkg-descr
+++ b/www/orion/pkg-descr
@@ -5,6 +5,6 @@ auto-deployment features.
This version is only for development use or for non-commercial
use. You need to purchase a license from http://www.orionserver.com/
-to be able to use this server commercially.
+if you would like to use this server commercially.
- WWW: http://www.orionserver.com/
+WWW: http://www.orionserver.com/
diff --git a/www/orion/pkg-plist b/www/orion/pkg-plist
index fac8258a8415..84dc264ce6e8 100644
--- a/www/orion/pkg-plist
+++ b/www/orion/pkg-plist
@@ -1,5 +1,5 @@
etc/rc.d/orion.sh
-orion
+bin/orionctl
orion1.4.5/config/database-schemas/hypersonic.xml
orion1.4.5/config/database-schemas/ms-access.xml
orion1.4.5/config/database-schemas/ms-sql.xml