aboutsummaryrefslogtreecommitdiff
path: root/www/orion
diff options
context:
space:
mode:
authorErnst de Haan <znerd@FreeBSD.org>2002-03-30 12:47:34 +0000
committerErnst de Haan <znerd@FreeBSD.org>2002-03-30 12:47:34 +0000
commit23b7e0ae1e0184ea36ce3e1eb48d5c709a274693 (patch)
treec7743547be90efcdb4414367076a74c0f27dce78 /www/orion
parente30c71bc7af2b27db5d3a66ed4ed9068374f94cb (diff)
downloadports-23b7e0ae1e0184ea36ce3e1eb48d5c709a274693.tar.gz
ports-23b7e0ae1e0184ea36ce3e1eb48d5c709a274693.zip
Notes
Diffstat (limited to 'www/orion')
-rw-r--r--www/orion/Makefile38
-rw-r--r--www/orion/files/orionctl.14
-rw-r--r--www/orion/files/patch-aa17
-rw-r--r--www/orion/files/patch-ab11
4 files changed, 47 insertions, 23 deletions
diff --git a/www/orion/Makefile b/www/orion/Makefile
index 8dc4455f27e2..77fd46c23de4 100644
--- a/www/orion/Makefile
+++ b/www/orion/Makefile
@@ -7,7 +7,7 @@
PORTNAME= orion
PORTVERSION= 1.5.2
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= www java
MASTER_SITES= http://www.orionserver.com/distributions/ \
http://www.atlassian.com/software/orion/downloads/ \
@@ -44,7 +44,10 @@ AUTO_START?= NO
PID_FILE= /var/run/${APP_SHORTNAME}.pid
REPLACE_FILES= ${FILESDIR}/daemonctl.c \
${FILESDIR}/${CONTROL_SCRIPT_NAME}.1 \
- ${FILESDIR}/${STARTUP_SCRIPT_NAME}
+ ${FILESDIR}/${STARTUP_SCRIPT_NAME} \
+ ${WRKSRC}/config/default-web-site.xml \
+ ${WRKSRC}/config/rmi.xml
+WRKDIR?= work
.include <bsd.port.pre.mk>
@@ -69,25 +72,6 @@ do-install:
@${RM} -f `${FIND} ${WRKSRC} -name '*.bat'` `${FIND} ${WRKSRC} -name '*.orig'`
@${ECHO_CMD} " [ DONE ]"
- @${ECHO_CMD} -n ">> Creating destination directory..."
- @${MKDIR} ${APP_HOME}
- @${MKDIR} ${APP_HOME}/application-deployments
- @${ECHO_CMD} " [ DONE ]"
-
- @${ECHO_CMD} -n ">> Copying files to destination directory..."
- @${CP} -R ${WRKSRC}/* ${APP_HOME}
- @${ECHO_CMD} " [ DONE ]"
-
- @${ECHO_CMD} -n ">> Configuring HTTP server port..."
- @${SED} -e "/port=\"80\"/s//port=\"${HTTP_PORT}\"/" \
- ${WRKSRC}/config/default-web-site.xml > ${APP_HOME}/config/default-web-site.xml
- @${ECHO_CMD} " [ DONE ]"
-
- @${ECHO_CMD} -n ">> Configuring RMI server port..."
- @${SED} -e "/<rmi-server>/s//<rmi-server host=\"\[ALL\]\" port=\"${RMI_PORT}\">/" \
- ${WRKSRC}/config/rmi.xml > ${APP_HOME}/config/rmi.xml
- @${ECHO_CMD} " [ DONE ]"
-
.for f in ${REPLACE_FILES}
@${ECHO_CMD} -n ">> Customizing `basename $f`..."
@${SED} \
@@ -97,6 +81,7 @@ do-install:
-e "/%%CONTROL_SCRIPT%%/s//${CONTROL_SCRIPT:S/\//\\\//g}/g" \
-e "/%%CONTROL_SCRIPT_NAME%%/s//${CONTROL_SCRIPT_NAME}/g" \
-e "/%%GROUP%%/s//${GROUP}/g" \
+ -e "/%%HTTP_PORT%%/s//${HTTP_PORT}/g" \
-e "/%%JAVA_CMD%%/s//bin\/java/g" \
-e "/%%JAVA_HOME%%/s//${JAVA_HOME:S/\//\\\//g}/g" \
-e "/%%JAR_FILE%%/s//${APP_SHORTNAME}.jar/g" \
@@ -108,11 +93,22 @@ do-install:
-e "/%%STDOUT_LOG%%/s//${STDOUT_LOG:S/\//\\\//g}/g" \
-e "/%%PREFIX%%/s//${PREFIX:S/\//\\\//g}/g" \
-e "/%%PID_FILE%%/s//${PID_FILE:S/\//\\\//g}/g" \
+ -e "/%%RMI_PORT%%/s//${RMI_PORT}/g" \
-e "/%%USER%%/s//${USER}/g" \
$f > ${WRKDIR}/`basename $f`
@${ECHO_CMD} " [ DONE ]"
.endfor
+ @${ECHO_CMD} -n ">> Creating destination directory..."
+ @${MKDIR} ${APP_HOME}
+ @${MKDIR} ${APP_HOME}/application-deployments
+ @${ECHO_CMD} " [ DONE ]"
+
+ @${ECHO_CMD} -n ">> Copying files to destination directory..."
+ @${CP} -R ${WRKSRC}/* ${APP_HOME}
+ @${CP} ${WRKDIR}/default-web-site.xml ${WRKDIR}/rmi.xml ${APP_HOME}/config
+ @${ECHO_CMD} " [ DONE ]"
+
.if defined(WITH_JIKES) && ${WITH_JIKES} == "YES"
@${ECHO_CMD} -n ">> Configuring Jikes support..."
@${SED} -e "/\<!-- \<compiler executable=\"jikes\" classpath=\"\/myjdkdir\/jre\/lib\/rt.jar\" \/\> -->/s//\<compiler executable=\"${JIKES_LOCATION:S/\//\\\//g}\" classpath=\"${JAVA_HOME:S/\//\\\//g}\/jre\/lib\/rt.jar\"\/\>/" \
diff --git a/www/orion/files/orionctl.1 b/www/orion/files/orionctl.1
index a449a4f30956..ad7386044167 100644
--- a/www/orion/files/orionctl.1
+++ b/www/orion/files/orionctl.1
@@ -55,8 +55,8 @@ The following errors conditions are defined:
.It Em %%APP_TITLE%% is not running (error code 7)
.It Em Unable to chdir to the %%APP_TITLE%% home directory (error code 8)
.It Em Unable to open the stdout log file (error code 9)
-.It Em Unable to open the stderr log file (error code 9)
-.It Em Unable to start %%APP_TITLE%% (error code 9)
+.It Em Unable to open the stderr log file (error code 10)
+.It Em Unable to start %%APP_TITLE%% (error code 11)
.El
.Sh FILES
.Bl -tag -width -indent
diff --git a/www/orion/files/patch-aa b/www/orion/files/patch-aa
new file mode 100644
index 000000000000..c4848823657e
--- /dev/null
+++ b/www/orion/files/patch-aa
@@ -0,0 +1,17 @@
+--- config/default-web-site.xml.orig Sat Mar 30 13:16:11 2002
++++ config/default-web-site.xml Sat Mar 30 13:16:56 2002
+@@ -1,12 +1,12 @@
+ <?xml version="1.0"?>
+ <!DOCTYPE web-site PUBLIC "Orion Web-site" "http://www.orionserver.com/dtds/web-site.dtd">
+
+-<web-site host="[ALL]" port="80" display-name="Default Orion WebSite">
++<web-site host="[ALL]" port="%%HTTP_PORT%%" display-name="Default Orion WebSite">
+ <!-- The default web-app for this site, bound to the root -->
+ <default-web-app application="default" name="defaultWebApp" />
+
+ <!-- Uncomment this to activate the news app -->
+ <!-- <web-app application="news" name="news-web" root="/news" /> -->
+- <!-- Access Log, where requests are logged to -->
++ <!-- Access Log, where requests are logged to -->
+ <access-log path="../log/default-web-access.log" />
+ </web-site>
diff --git a/www/orion/files/patch-ab b/www/orion/files/patch-ab
new file mode 100644
index 000000000000..c8807ed64076
--- /dev/null
+++ b/www/orion/files/patch-ab
@@ -0,0 +1,11 @@
+--- config/rmi.xml.orig Sat Mar 30 13:17:25 2002
++++ config/rmi.xml Sat Mar 30 13:17:59 2002
+@@ -1,7 +1,7 @@
+ <?xml version="1.0"?>
+ <!DOCTYPE rmi-server PUBLIC "Orion RMI-server" "http://www.orionserver.com/dtds/rmi-server.dtd">
+
+-<rmi-server>
++<rmi-server host="[ALL]" port="%%RMI_PORT%%">
+ <!-- A remote server connection example -->
+ <!-- <server host="the.remote.server.com" username="adminUser" password="123abc" /> -->
+