aboutsummaryrefslogtreecommitdiff
path: root/www/osb-browser
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2004-12-01 04:02:50 +0000
committerMichael Johnson <ahze@FreeBSD.org>2004-12-01 04:02:50 +0000
commit6bfee51d3d0b4a4cedccd4158c86ea01a6de2aba (patch)
tree31f299546e3d9ea7e4bdc6fd1274a1ccc2ecac23 /www/osb-browser
parent45e271d3f4dab1f2406bf8496e602a0a23acde11 (diff)
downloadports-6bfee51d3d0b4a4cedccd4158c86ea01a6de2aba.tar.gz
ports-6bfee51d3d0b4a4cedccd4158c86ea01a6de2aba.zip
Notes
Diffstat (limited to 'www/osb-browser')
-rw-r--r--www/osb-browser/Makefile36
-rw-r--r--www/osb-browser/distinfo2
-rw-r--r--www/osb-browser/pkg-descr3
-rw-r--r--www/osb-browser/pkg-plist3
4 files changed, 44 insertions, 0 deletions
diff --git a/www/osb-browser/Makefile b/www/osb-browser/Makefile
new file mode 100644
index 000000000000..e5956fc8d16f
--- /dev/null
+++ b/www/osb-browser/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: osb-browser
+# Date created: 2004-11-29
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= osb-browser
+PORTVERSION= 0.5.0
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtk-webcore
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Gtk-Webcore example web browser
+
+LIB_DEPENDS= nrcit.0:${PORTSDIR}/www/osb-nrcit
+
+USE_X_PREFIX= yes
+USE_GNOME= libglade2 gnomehack gnomeprefix
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
+ LDFLAGS="${PTHREAD_LIBS}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread||; s|-nostdinc++||; \
+ s|-nodefaultlibs||' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/www/osb-browser/distinfo b/www/osb-browser/distinfo
new file mode 100644
index 000000000000..4437e6aaff20
--- /dev/null
+++ b/www/osb-browser/distinfo
@@ -0,0 +1,2 @@
+MD5 (osb-browser-0.5.0.tar.gz) = 4dad43f6e1291dfefaec6e9209928a0d
+SIZE (osb-browser-0.5.0.tar.gz) = 233672
diff --git a/www/osb-browser/pkg-descr b/www/osb-browser/pkg-descr
new file mode 100644
index 000000000000..8d51c35cdb81
--- /dev/null
+++ b/www/osb-browser/pkg-descr
@@ -0,0 +1,3 @@
+An example Gtk-Webcore browser using the Gtk-Webcore KHTML browser engine.
+
+WWW: http://gtk-webcore.sf.net/
diff --git a/www/osb-browser/pkg-plist b/www/osb-browser/pkg-plist
new file mode 100644
index 000000000000..6c4683be6f6f
--- /dev/null
+++ b/www/osb-browser/pkg-plist
@@ -0,0 +1,3 @@
+bin/osb-browser
+share/gnome/osb-browser/default-location-icon.png
+share/gnome/osb-browser/osb-browser.glade