aboutsummaryrefslogtreecommitdiff
path: root/www/oscommerce/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-02-16 11:47:41 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-02-16 11:47:41 +0000
commit436a4a51dea5bf766c3612c82715e59a5a2094e5 (patch)
tree408465538b3ff6e587922280963c6e2f99dbc747 /www/oscommerce/Makefile
parentee0f897bd8899f5f876eb7af3d75e872f3f7574d (diff)
downloadports-436a4a51dea5bf766c3612c82715e59a5a2094e5.tar.gz
ports-436a4a51dea5bf766c3612c82715e59a5a2094e5.zip
Notes
Diffstat (limited to 'www/oscommerce/Makefile')
-rw-r--r--www/oscommerce/Makefile39
1 files changed, 12 insertions, 27 deletions
diff --git a/www/oscommerce/Makefile b/www/oscommerce/Makefile
index 778be31adf09..29637f3c9271 100644
--- a/www/oscommerce/Makefile
+++ b/www/oscommerce/Makefile
@@ -17,46 +17,31 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/r/ms/}
MAINTAINER= hcoyote@ghostar.org
COMMENT= An full-featured open source e-commerce system
-BROKEN= "Inconsistent dependencies (on mysql-client 3.x and 4.x)"
-DEPRECATED= "This port will be removed on April 15 if it is still broken."
-
-USE_MYSQL= yes
-WANT_MYSQL_VER= 323
-NO_BUILD= YES
-PHP4_PORT?= www/mod_php4
-OSCOMMERCE?= ${PREFIX}/www/data/oscommerce
+USE_PHP= yes
+WANT_PHP_WEB= yes
+NO_BUILD= yes
+OSCOMMERCE= ${PREFIX}/www/data/oscommerce
PKGMESSAGE= ${WRKDIR}/pkg-message
-.if defined(WITH_APACHE2)
-MOD_DIR= libexec/apache2
-.else
-MOD_DIR= libexec/apache
-.endif
-
-MOD_PHP= ${PREFIX}/${MOD_DIR}/libphp4.so
-
WWWOWN?= www
WWWGRP?= www
-RUN_DEPENDS+= ${MOD_PHP}:${PORTSDIR}/${PHP4_PORT}
-RUN_DEPENDS+= ${PREFIX}/bin/mysql:${PORTSDIR}/databases/mysql323-client
-
do-install:
${MKDIR} ${OSCOMMERCE}
${CP} -R ${WRKSRC}/catalog ${OSCOMMERCE}
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${OSCOMMERCE}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${CP} ${WRKSRC}/LICENSE ${DOCSDIR}
- ${CP} ${WRKSRC}/FAQ ${DOCSDIR}
- ${CP} ${WRKSRC}/INSTALL ${DOCSDIR}
- ${CP} ${WRKSRC}/README ${DOCSDIR}
- ${CP} ${WRKSRC}/STANDARD ${DOCSDIR}
- ${CP} ${WRKSRC}/tep_database-pr2.2-CVS.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/FAQ ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/STANDARD ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tep_database-pr2.2-CVS.pdf ${DOCSDIR}
.endif
post-install:
- @ ${SED} -e 's#%%OSCOMMERCE%%#${OSCOMMERCE}#g' pkg-message > ${PKGMESSAGE}
- ${CAT} ${PKGMESSAGE}
+ @${SED} -e 's#%%OSCOMMERCE%%#${OSCOMMERCE}#g' pkg-message > ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>