aboutsummaryrefslogtreecommitdiff
path: root/www/otter-browser
diff options
context:
space:
mode:
authorAlonso Schaich <alonso@FreeBSD.org>2014-09-01 09:13:20 +0000
committerAlonso Schaich <alonso@FreeBSD.org>2014-09-01 09:13:20 +0000
commit89400cdd84ce9e2a4d334c1effc17628e30745b5 (patch)
treea25bdfeb264fc0c9ead6d4024857d4f2fb650fba /www/otter-browser
parentdcf609ad818c7e33a715337145f911e97ba8609d (diff)
downloadports-89400cdd84ce9e2a4d334c1effc17628e30745b5.tar.gz
ports-89400cdd84ce9e2a4d334c1effc17628e30745b5.zip
Notes
Diffstat (limited to 'www/otter-browser')
-rw-r--r--www/otter-browser/Makefile9
-rw-r--r--www/otter-browser/distinfo4
-rw-r--r--www/otter-browser/files/patch-otter.pro12
3 files changed, 18 insertions, 7 deletions
diff --git a/www/otter-browser/Makefile b/www/otter-browser/Makefile
index aa9eb6ad99ab..7637889b08cb 100644
--- a/www/otter-browser/Makefile
+++ b/www/otter-browser/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= otter
-PORTVERSION= 0.9.01
-PORTREVISION= 1
+PORTVERSION= 0.9.02
CATEGORIES= www
# Avoid pkgname conflict with misc/otter
PKGNAMESUFFIX= -browser
@@ -11,15 +10,15 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Browser based on Qt 5
-USE_QT5= core gui network printsupport script sql webkit widgets \
- buildtools_build
+USE_QT5= concurrent core gui network printsupport script sql webkit \
+ widgets buildtools_build
USES= desktop-file-utils qmake:outsource
USE_GITHUB= yes
GH_ACCOUNT= Emdek
GH_PROJECT= otter
GH_TAGNAME= v${PORTVERSION}
-GH_COMMIT= 24e4053
+GH_COMMIT= f33f3ae
PLIST_FILES= bin/otter-browser \
share/applications/otter-browser.desktop
diff --git a/www/otter-browser/distinfo b/www/otter-browser/distinfo
index eefd830cbb45..2ac099a63146 100644
--- a/www/otter-browser/distinfo
+++ b/www/otter-browser/distinfo
@@ -1,2 +1,2 @@
-SHA256 (otter-v0.9.01.tar.gz) = 4820239cd3e9fea9a61e8eb7066f3069402946be812b5acb68e386335aa891f3
-SIZE (otter-v0.9.01.tar.gz) = 735635
+SHA256 (otter-v0.9.02.tar.gz) = 77f9053170070cb3dae254d20157b187e370672b82b77987e2cec44c87035159
+SIZE (otter-v0.9.02.tar.gz) = 1254693
diff --git a/www/otter-browser/files/patch-otter.pro b/www/otter-browser/files/patch-otter.pro
new file mode 100644
index 000000000000..c7d752a55433
--- /dev/null
+++ b/www/otter-browser/files/patch-otter.pro
@@ -0,0 +1,12 @@
+--- otter.pro.original 2014-08-02 12:12:05.354894688 +0200
++++ otter.pro 2014-08-02 12:12:36.880892354 +0200
+@@ -8,7 +8,8 @@
+ error("Qt 5.2.0 or newer is required.")
+ }
+
+-QT += core gui network printsupport script sql webkitwidgets widgets
++QT += core concurrent gui network printsupport script sql webkitwidgets \
++ widgets
+
+ win32: QT += winextras
+ win32: INCLUDEPATH += .\