aboutsummaryrefslogtreecommitdiff
path: root/www/owncloud
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-12-02 19:32:48 +0000
committerChris Rees <crees@FreeBSD.org>2012-12-02 19:32:48 +0000
commitdd07918e808b899c4b88aa4c2f5b818d639148b6 (patch)
treeec8dabc2205f84a21a2d85062b427f8c90628889 /www/owncloud
parent0ba0f1db672b01d72ffcd312fb204d4be269c211 (diff)
downloadports-dd07918e808b899c4b88aa4c2f5b818d639148b6.tar.gz
ports-dd07918e808b899c4b88aa4c2f5b818d639148b6.zip
Notes
Diffstat (limited to 'www/owncloud')
-rw-r--r--www/owncloud/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/www/owncloud/Makefile b/www/owncloud/Makefile
index 5cb4b7031e2e..6ab5c96070c9 100644
--- a/www/owncloud/Makefile
+++ b/www/owncloud/Makefile
@@ -30,9 +30,11 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
- @${FIND} -s -d ${WWWDIR} -type f -print | \
- ${SED} -e "s#${PREFIX}/##g" >> ${TMPPLIST}
- @${FIND} -s -d ${WWWDIR} -type d -print | \
- ${SED} -E -e "s#${PREFIX}/#@dirrm #g" >> ${TMPPLIST}
+ @cd ${WRKSRC} && \
+ ${FIND} -s -d . -type f -print | \
+ ${SED} -e "s#^\.#${WWWDIR_REL}#" >> ${TMPPLIST}
+ @cd ${WRKSRC} && \
+ ${FIND} -s -d . -type d -print | \
+ ${SED} -e "s#^\.#@dirrm ${WWWDIR_REL}#" >> ${TMPPLIST}
.include <bsd.port.mk>