aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Amon2
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2013-01-20 06:45:20 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2013-01-20 06:45:20 +0000
commit06980420e504515544806e6ce05bd0d6bfe8c4f5 (patch)
treec7247033502d715c47fb90dbb5e8fedb73724ab1 /www/p5-Amon2
parent4da07fefc438566e1052f2984f200180ba3dbc88 (diff)
downloadports-06980420e504515544806e6ce05bd0d6bfe8c4f5.tar.gz
ports-06980420e504515544806e6ce05bd0d6bfe8c4f5.zip
Notes
Diffstat (limited to 'www/p5-Amon2')
-rw-r--r--www/p5-Amon2/Makefile66
-rw-r--r--www/p5-Amon2/distinfo2
-rw-r--r--www/p5-Amon2/pkg-descr4
-rw-r--r--www/p5-Amon2/pkg-plist45
4 files changed, 117 insertions, 0 deletions
diff --git a/www/p5-Amon2/Makefile b/www/p5-Amon2/Makefile
new file mode 100644
index 000000000000..0cd3ea526a7a
--- /dev/null
+++ b/www/p5-Amon2/Makefile
@@ -0,0 +1,66 @@
+# $FreeBSD$
+
+PORTNAME= Amon2
+PORTVERSION= 3.66
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for/to lightweight web application framework
+
+RUN_DEPENDS= \
+ p5-Plack>=0.9982:${PORTSDIR}/www/p5-Plack \
+ p5-Plack-Middleware-Session>0:${PORTSDIR}/www/p5-Plack-Middleware-Session \
+ p5-Router-Simple>=0.14:${PORTSDIR}/www/p5-Router-Simple \
+ p5-Router-Simple-Sinatraish>=0.02:${PORTSDIR}/www/p5-Router-Simple-Sinatraish \
+ p5-Text-Xslate>=1.6001:${PORTSDIR}/textproc/p5-Text-Xslate \
+ p5-Try-Tiny>=0.06:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-URI>=1.54:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+TEST_DEPENDS= \
+ p5-Test-Requires>0:${PORTSDIR}/devel/p5-Test-Requires \
+ p5-Tiffany>0:${PORTSDIR}/textproc/p5-Tiffany \
+ p5-Test-WWW-Mechanize-PSGI>0:${PORTSDIR}/devel/p5-Test-WWW-Mechanize-PSGI \
+ p5-HTTP-MobileAgent>0:${PORTSDIR}/www/p5-HTTP-MobileAgent \
+ p5-Text-MicroTemplate-Extended>0:${PORTSDIR}/textproc/p5-Text-MicroTemplate-Extended \
+ p5-HTTP-Session>0:${PORTSDIR}/www/p5-HTTP-Session \
+ p5-Module-Find>0:${PORTSDIR}/devel/p5-Module-Find \
+ p5-DBD-SQLite>0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-String-CamelCase>0:${PORTSDIR}/textproc/p5-String-CamelCase \
+ p5-HTML-FillInForm>0:${PORTSDIR}/www/p5-HTML-FillInForm \
+ p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
+ p5-Data-Section-Simple>0:${PORTSDIR}/devel/p5-Data-Section-Simple \
+ p5-Test-TCP>0:${PORTSDIR}/devel/p5-Test-TCP \
+ p5-HTML-FillInForm-Lite>0:${PORTSDIR}/www/p5-HTML-FillInForm-Lite \
+ p5-Twiggy>0:${PORTSDIR}/www/p5-Twiggy \
+ p5-Protocol-WebSocket>0:${PORTSDIR}/www/p5-Protocol-WebSocket
+
+PERL_MODBUILD= yes
+
+MAN1= amon2-setup.pl.1
+MAN3= Amon2.3 \
+ Amon2::Config::Simple.3 \
+ Amon2::Declare.3 \
+ Amon2::Plugin::Web::CSRFDefender.3 \
+ Amon2::Plugin::Web::FillInFormLite.3 \
+ Amon2::Plugin::Web::HTTPSession.3 \
+ Amon2::Plugin::Web::JSON.3 \
+ Amon2::Plugin::Web::NoCache.3 \
+ Amon2::Plugin::Web::PlackSession.3 \
+ Amon2::Plugin::Web::Streaming.3 \
+ Amon2::Plugin::Web::WebSocket.3 \
+ Amon2::Setup::Flavor.3 \
+ Amon2::Setup::Flavor::Basic.3 \
+ Amon2::Setup::Flavor::Minimum.3 \
+ Amon2::Trigger.3 \
+ Amon2::Util.3 \
+ Amon2::Web.3 \
+ Amon2::Web::Dispatcher::Lite.3 \
+ Amon2::Web::Dispatcher::RouterSimple.3 \
+ Amon2::Web::Request.3 \
+ Amon2::Web::Response.3 \
+ Amon2::Web::Response::Callback.3 \
+ Amon2::Web::WebSocket.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Amon2/distinfo b/www/p5-Amon2/distinfo
new file mode 100644
index 000000000000..5a14df93675a
--- /dev/null
+++ b/www/p5-Amon2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Amon2-3.66.tar.gz) = a02247ff183fb9cd915d071b8849d3ba8a0a3bb4d2920a325763311e789938da
+SIZE (Amon2-3.66.tar.gz) = 244971
diff --git a/www/p5-Amon2/pkg-descr b/www/p5-Amon2/pkg-descr
new file mode 100644
index 000000000000..9e5cd249fa2d
--- /dev/null
+++ b/www/p5-Amon2/pkg-descr
@@ -0,0 +1,4 @@
+Amon2 is simple, readable, extensible, STABLE, FAST web application
+framework based on Plack.
+
+WWW: http://search.cpan.org/dist/Amon2/
diff --git a/www/p5-Amon2/pkg-plist b/www/p5-Amon2/pkg-plist
new file mode 100644
index 000000000000..a2a610e4945e
--- /dev/null
+++ b/www/p5-Amon2/pkg-plist
@@ -0,0 +1,45 @@
+bin/amon2-setup.pl
+%%SITE_PERL%%/Amon2.pm
+%%SITE_PERL%%/Amon2/Config/Simple.pm
+%%SITE_PERL%%/Amon2/Declare.pm
+%%SITE_PERL%%/Amon2/Plugin/Web/CSRFDefender.pm
+%%SITE_PERL%%/Amon2/Plugin/Web/FillInFormLite.pm
+%%SITE_PERL%%/Amon2/Plugin/Web/HTTPSession.pm
+%%SITE_PERL%%/Amon2/Plugin/Web/JSON.pm
+%%SITE_PERL%%/Amon2/Plugin/Web/NoCache.pm
+%%SITE_PERL%%/Amon2/Plugin/Web/PlackSession.pm
+%%SITE_PERL%%/Amon2/Plugin/Web/Streaming.pm
+%%SITE_PERL%%/Amon2/Plugin/Web/WebSocket.pm
+%%SITE_PERL%%/Amon2/Setup/Asset/Blueprint.pm
+%%SITE_PERL%%/Amon2/Setup/Asset/Bootstrap.pm
+%%SITE_PERL%%/Amon2/Setup/Asset/ES5Shim.pm
+%%SITE_PERL%%/Amon2/Setup/Asset/MicroLocationJS.pm
+%%SITE_PERL%%/Amon2/Setup/Asset/MicroTemplateJS.pm
+%%SITE_PERL%%/Amon2/Setup/Asset/SprintfJS.pm
+%%SITE_PERL%%/Amon2/Setup/Asset/StrftimeJS.pm
+%%SITE_PERL%%/Amon2/Setup/Asset/jQuery.pm
+%%SITE_PERL%%/Amon2/Setup/Flavor.pm
+%%SITE_PERL%%/Amon2/Setup/Flavor/Basic.pm
+%%SITE_PERL%%/Amon2/Setup/Flavor/Large.pm
+%%SITE_PERL%%/Amon2/Setup/Flavor/Minimum.pm
+%%SITE_PERL%%/Amon2/Setup/VC/Git.pm
+%%SITE_PERL%%/Amon2/Trigger.pm
+%%SITE_PERL%%/Amon2/Util.pm
+%%SITE_PERL%%/Amon2/Web.pm
+%%SITE_PERL%%/Amon2/Web/Dispatcher/Lite.pm
+%%SITE_PERL%%/Amon2/Web/Dispatcher/RouterSimple.pm
+%%SITE_PERL%%/Amon2/Web/Request.pm
+%%SITE_PERL%%/Amon2/Web/Response.pm
+%%SITE_PERL%%/Amon2/Web/Response/Callback.pm
+%%SITE_PERL%%/Amon2/Web/WebSocket.pm
+@dirrm %%SITE_PERL%%/Amon2/Web/Response
+@dirrm %%SITE_PERL%%/Amon2/Web/Dispatcher
+@dirrm %%SITE_PERL%%/Amon2/Web
+@dirrm %%SITE_PERL%%/Amon2/Setup/VC
+@dirrm %%SITE_PERL%%/Amon2/Setup/Flavor
+@dirrm %%SITE_PERL%%/Amon2/Setup/Asset
+@dirrm %%SITE_PERL%%/Amon2/Setup
+@dirrm %%SITE_PERL%%/Amon2/Plugin/Web
+@dirrm %%SITE_PERL%%/Amon2/Plugin
+@dirrm %%SITE_PERL%%/Amon2/Config
+@dirrm %%SITE_PERL%%/Amon2