aboutsummaryrefslogtreecommitdiff
path: root/www/p5-AnyEvent-HTTP/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-07-08 07:22:32 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-07-08 07:22:32 +0000
commita0609756f08a20988dfba59b1e721ee6aae9b43e (patch)
tree740861228ddb90b9c7ef287242e39cb31545b254 /www/p5-AnyEvent-HTTP/Makefile
parent60479b26cb9a068784b48c38fab5a895dc0c46f1 (diff)
downloadports-a0609756f08a20988dfba59b1e721ee6aae9b43e.tar.gz
ports-a0609756f08a20988dfba59b1e721ee6aae9b43e.zip
Notes
Diffstat (limited to 'www/p5-AnyEvent-HTTP/Makefile')
-rw-r--r--www/p5-AnyEvent-HTTP/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/www/p5-AnyEvent-HTTP/Makefile b/www/p5-AnyEvent-HTTP/Makefile
new file mode 100644
index 000000000000..6caced1827a0
--- /dev/null
+++ b/www/p5-AnyEvent-HTTP/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-AnyEvent-HTTP
+# Date created: 06 Jul 2008
+# Whom: Vladimir Timofeev <vovkasm@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AnyEvent-HTTP
+PORTVERSION= 1.03
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/ML/MLEHMANN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vovkasm@gmail.com
+COMMENT= Simple but non-blocking HTTP/HTTPS client
+
+BUILD_DEPENDS= p5-AnyEvent>=4.14:${PORTSDIR}/devel/p5-AnyEvent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= AnyEvent::HTTP.3
+
+.include <bsd.port.mk>