aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-ASP
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-01-29 05:48:18 +0000
committerSteve Price <steve@FreeBSD.org>2000-01-29 05:48:18 +0000
commiteeaf4387c558290832a3fbccfa3d0852ee03a8b4 (patch)
tree58ab38ca06ed6a63dc2358823d947fe92f33ccc3 /www/p5-Apache-ASP
parent413d8b01b683780089b1351673d8b185f007d7bc (diff)
downloadports-eeaf4387c558290832a3fbccfa3d0852ee03a8b4.tar.gz
ports-eeaf4387c558290832a3fbccfa3d0852ee03a8b4.zip
Notes
Diffstat (limited to 'www/p5-Apache-ASP')
-rw-r--r--www/p5-Apache-ASP/Makefile31
-rw-r--r--www/p5-Apache-ASP/distinfo1
-rw-r--r--www/p5-Apache-ASP/pkg-comment1
-rw-r--r--www/p5-Apache-ASP/pkg-descr25
-rw-r--r--www/p5-Apache-ASP/pkg-plist4
5 files changed, 62 insertions, 0 deletions
diff --git a/www/p5-Apache-ASP/Makefile b/www/p5-Apache-ASP/Makefile
new file mode 100644
index 000000000000..676d668914ad
--- /dev/null
+++ b/www/p5-Apache-ASP/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Apache-ASP
+# Version required: 0.17
+# Date created: 31 December 1999
+# Whom: Igor Vinokurov <igor@zynaps.ru>
+#
+# $FreeBSD$
+#
+
+DISTNAME= Apache-ASP-0.17
+PKGNAME= p5-Apache-ASP-0.17
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+
+MAINTAINER= igor@zynaps.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/p5-Apache \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MLDBM.pm:${PORTSDIR}/databases/p5-MLDBM \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump
+
+USE_PERL5= YES
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::ASP.3
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-ASP/distinfo b/www/p5-Apache-ASP/distinfo
new file mode 100644
index 000000000000..cc6af6544957
--- /dev/null
+++ b/www/p5-Apache-ASP/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-ASP-0.17.tar.gz) = 83938382f8bac87fd9d0922f4c200b5f
diff --git a/www/p5-Apache-ASP/pkg-comment b/www/p5-Apache-ASP/pkg-comment
new file mode 100644
index 000000000000..b5e3b03a6441
--- /dev/null
+++ b/www/p5-Apache-ASP/pkg-comment
@@ -0,0 +1 @@
+Active Server Pages for Apache with mod_perl
diff --git a/www/p5-Apache-ASP/pkg-descr b/www/p5-Apache-ASP/pkg-descr
new file mode 100644
index 000000000000..e23b87848dd9
--- /dev/null
+++ b/www/p5-Apache-ASP/pkg-descr
@@ -0,0 +1,25 @@
+From the README file:
+
+ This perl module provides an Active Server Pages port to the Apache HTTP
+ Server with perl as the host scripting language. Active Server Pages is
+ a web application platform that originated with the Microsoft IIS
+ server. Under Apache for both Win32 and Unix, it allows a developer to
+ create dynamic web applications with session management and perl code
+ embedded in static html files.
+
+ This is a portable solution, similar to ActiveState PerlScript and MKS
+ PScript implementation of perl for IIS ASP. Work has been done and will
+ continue to make ports to and from these other implementations as smooth
+ as possible.
+
+ This module works under the Apache HTTP Server with the mod_perl module
+ enabled. See http://www.apache.org and http://perl.apache.org for
+ further information.
+
+ For database access, ActiveX, and scripting language issues, please read
+ the FAQ section.
+
+WWW: http://www.nodeworks.com/asp/
+
+-- Igor
+igor@zynaps.ru
diff --git a/www/p5-Apache-ASP/pkg-plist b/www/p5-Apache-ASP/pkg-plist
new file mode 100644
index 000000000000..ed3f22131bd0
--- /dev/null
+++ b/www/p5-Apache-ASP/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/ASP/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Apache/ASP.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/ASP
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Apache