aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Admin-Config
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-12-05 17:21:08 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-12-05 17:21:08 +0000
commit2cfd59874c71c9aa1a8b9a6956cc76b2bd2c2eb8 (patch)
tree9cf9b7936123723ac892a12242ababc3be9470cd /www/p5-Apache-Admin-Config
parent64c34dbae9dbee5258d2412f4b86c460085d0391 (diff)
downloadports-2cfd59874c71c9aa1a8b9a6956cc76b2bd2c2eb8.tar.gz
ports-2cfd59874c71c9aa1a8b9a6956cc76b2bd2c2eb8.zip
Notes
Diffstat (limited to 'www/p5-Apache-Admin-Config')
-rw-r--r--www/p5-Apache-Admin-Config/Makefile27
-rw-r--r--www/p5-Apache-Admin-Config/distinfo1
-rw-r--r--www/p5-Apache-Admin-Config/pkg-comment1
-rw-r--r--www/p5-Apache-Admin-Config/pkg-descr9
-rw-r--r--www/p5-Apache-Admin-Config/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/www/p5-Apache-Admin-Config/Makefile b/www/p5-Apache-Admin-Config/Makefile
new file mode 100644
index 000000000000..d8b43bdaa1bd
--- /dev/null
+++ b/www/p5-Apache-Admin-Config/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: www/p5-Apache-Admin-Config
+# Date created: 05 December 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Admin-Config
+PORTVERSION= 0.12
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache::Admin::Config.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-patch:
+ ${PERL} -pi -e 's/(!\$$)/0 && $1/;' \
+ -e 's|(VERSION_FROM\s+=>\s+)(.*)(,.*)$$|$$1$$2$$3\nMAN3PODS=>{$$2=>q!\\\$$(INST_MAN3DIR)/${MAN3}!},|;' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-Admin-Config/distinfo b/www/p5-Apache-Admin-Config/distinfo
new file mode 100644
index 000000000000..de975b0ff2ec
--- /dev/null
+++ b/www/p5-Apache-Admin-Config/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-Admin-Config-0.12.tar.gz) = e8363300e7cb7a87c212d9092e8a74fd
diff --git a/www/p5-Apache-Admin-Config/pkg-comment b/www/p5-Apache-Admin-Config/pkg-comment
new file mode 100644
index 000000000000..8963dba2e279
--- /dev/null
+++ b/www/p5-Apache-Admin-Config/pkg-comment
@@ -0,0 +1 @@
+A perl module to manipulate Apache configuration files
diff --git a/www/p5-Apache-Admin-Config/pkg-descr b/www/p5-Apache-Admin-Config/pkg-descr
new file mode 100644
index 000000000000..64cd7419f77b
--- /dev/null
+++ b/www/p5-Apache-Admin-Config/pkg-descr
@@ -0,0 +1,9 @@
+Apache::Admin::Config provides an object interface to handling Apache
+like configuration files without modifying comments, identation, or
+truncated lines.
+
+Author: Olivier Poitrey <rs@rhapsodyk.netE>
+WWW: http://search.cpan.org/search?dist=Apache-Admin-Config
+
+-Anton
+<tobez@FreeBSD.org>
diff --git a/www/p5-Apache-Admin-Config/pkg-plist b/www/p5-Apache-Admin-Config/pkg-plist
new file mode 100644
index 000000000000..2ae24874878d
--- /dev/null
+++ b/www/p5-Apache-Admin-Config/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Admin/Config/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Apache/Admin/Config.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Admin/Config
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Admin 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Apache/Admin 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Apache 2>/dev/null || true