aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Archive
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-03 23:18:19 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-03 23:18:19 +0000
commitab7b230d69003b7c0a3bbf0539157da14433013b (patch)
tree272413b9b11600f7c08c17c9a3df90f70559900d /www/p5-Apache-Archive
parent779399a31e38bf5177829f9d091a74dc37dd31b2 (diff)
downloadports-ab7b230d69003b7c0a3bbf0539157da14433013b.tar.gz
ports-ab7b230d69003b7c0a3bbf0539157da14433013b.zip
Notes
Diffstat (limited to 'www/p5-Apache-Archive')
-rw-r--r--www/p5-Apache-Archive/Makefile27
-rw-r--r--www/p5-Apache-Archive/distinfo1
-rw-r--r--www/p5-Apache-Archive/pkg-comment1
-rw-r--r--www/p5-Apache-Archive/pkg-descr9
-rw-r--r--www/p5-Apache-Archive/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/www/p5-Apache-Archive/Makefile b/www/p5-Apache-Archive/Makefile
new file mode 100644
index 000000000000..678ee4e562aa
--- /dev/null
+++ b/www/p5-Apache-Archive/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Apache::Archive
+# Date created: 04 Nov 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Archive
+PORTVERSION= 0.1
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::Archive.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-Archive/distinfo b/www/p5-Apache-Archive/distinfo
new file mode 100644
index 000000000000..9790321e5537
--- /dev/null
+++ b/www/p5-Apache-Archive/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-Archive-0.1.tar.gz) = 7d9325b567263bc82af5274955dfde3e
diff --git a/www/p5-Apache-Archive/pkg-comment b/www/p5-Apache-Archive/pkg-comment
new file mode 100644
index 000000000000..da405b484269
--- /dev/null
+++ b/www/p5-Apache-Archive/pkg-comment
@@ -0,0 +1 @@
+Perl module that creates a menu to allow perusal of tarball contents
diff --git a/www/p5-Apache-Archive/pkg-descr b/www/p5-Apache-Archive/pkg-descr
new file mode 100644
index 000000000000..538ca6100535
--- /dev/null
+++ b/www/p5-Apache-Archive/pkg-descr
@@ -0,0 +1,9 @@
+Apache::Archive is a module deisnged to be used with the Apache web server
+and the mod_perl environment. It allows Apache to present tar and tar.gz
+files as a menu of their component parts, from which a user may pick and
+choose the elements to view or download. The appearance of the menu is
+fully configurable through templates.
+
+Author: Jon Peterson <jon@snowdrift.org>
+
+--will
diff --git a/www/p5-Apache-Archive/pkg-plist b/www/p5-Apache-Archive/pkg-plist
new file mode 100644
index 000000000000..3fca1151c2c5
--- /dev/null
+++ b/www/p5-Apache-Archive/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Apache/Archive.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Apache/Archive/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Archive/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Archive
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Apache/Archive