aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-AuthCookie/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-09-02 06:19:57 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-09-02 06:19:57 +0000
commitc5aad18587a6352cf8b43b2a520a5f1a874659ae (patch)
tree0b7b65fd8af5680ae411a9ba0bcf583b977db04f /www/p5-Apache-AuthCookie/Makefile
parent7eaaf632feed88891a457c0d736c357f226de7a6 (diff)
Notes
Diffstat (limited to 'www/p5-Apache-AuthCookie/Makefile')
-rw-r--r--www/p5-Apache-AuthCookie/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/www/p5-Apache-AuthCookie/Makefile b/www/p5-Apache-AuthCookie/Makefile
index 567ef1d352c7..171ae8d2d202 100644
--- a/www/p5-Apache-AuthCookie/Makefile
+++ b/www/p5-Apache-AuthCookie/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Apache-AuthCookie
-PORTVERSION= 3.04
+PORTVERSION= 3.05
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Apache
@@ -15,9 +15,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A perl module to provide custom forms for reauthentication
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl \
- ${APXS}:${PORTSDIR}/${APACHE_PORT}
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT}
+.if defined(WITH_MODPERL2)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Apache2/mod_perl.pm:${PORTSDIR}/www/mod_perl2
+.else
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+.endif
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test
CURUSER?= `whoami`
CURGRP?= `groups | ${AWK} '{print $$1}'`