aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-AuthTicket
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-05 03:24:01 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-05 03:24:01 +0000
commitb061465b728e533d6d495886305209a276b1c399 (patch)
treeb9b387509945f3bac019ebc9e3de15c6ed81f44c /www/p5-Apache-AuthTicket
parent9422230c903eead7c04b6e9fdf791d1efb7c4d69 (diff)
downloadports-b061465b728e533d6d495886305209a276b1c399.tar.gz
ports-b061465b728e533d6d495886305209a276b1c399.zip
Notes
Diffstat (limited to 'www/p5-Apache-AuthTicket')
-rw-r--r--www/p5-Apache-AuthTicket/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/www/p5-Apache-AuthTicket/Makefile b/www/p5-Apache-AuthTicket/Makefile
index dff2e93e9a4b..52b6fec319a2 100644
--- a/www/p5-Apache-AuthTicket/Makefile
+++ b/www/p5-Apache-AuthTicket/Makefile
@@ -16,13 +16,23 @@ COMMENT= Perl modules that implement a cookie-based authentication system
RUN_DEPENDS= ${SITE_PERL}/Apache/AuthCookie.pm:${PORTSDIR}/www/p5-Apache-AuthCookie \
${SITE_PERL}/SQL/Abstract.pm:${PORTSDIR}/databases/p5-SQL-Abstract \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test
BUILD_DEPENDS= ${RUN_DEPENDS}
-BROKEN= does not build
-
PERL_CONFIGURE= yes
MAN3= Apache::AuthTicket.3 Apache2::AuthTicket.3
-.include <bsd.port.mk>
+USE_APACHE= 1.3+
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} > 20
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
+.else
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+.endif
+
+.include <bsd.port.post.mk>