aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Clean/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-10-01 11:19:08 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-10-01 11:19:08 +0000
commit3bb679a33f2a78af35b08bd0b890cc341d91af7d (patch)
tree1eea89fbaff4c1d6290e8dd2047d60979c68352d /www/p5-Apache-Clean/Makefile
parentf7fc40dd3dedaffc58d157a44ee28603af3d74ab (diff)
downloadports-3bb679a33f2a78af35b08bd0b890cc341d91af7d.tar.gz
ports-3bb679a33f2a78af35b08bd0b890cc341d91af7d.zip
Notes
Diffstat (limited to 'www/p5-Apache-Clean/Makefile')
-rw-r--r--www/p5-Apache-Clean/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/www/p5-Apache-Clean/Makefile b/www/p5-Apache-Clean/Makefile
new file mode 100644
index 000000000000..f19ff9930a76
--- /dev/null
+++ b/www/p5-Apache-Clean/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Apache-Clean
+# Date created: Sep 09 2003
+# Whom: Martin Matuska <martin@tradex.sk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Clean
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache/GEOFF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= martin@tradex.sk
+COMMENT= A mod_perl interface into HTML::Clean
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache.pm:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/HTML/Clean.pm:${PORTSDIR}/www/p5-HTML-Clean
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::Clean.3
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>